Results 1 to 7 of 7

Thread: smbd and nmbd have stopped working on 64-bit 13.1

  1. #1

    Default smbd and nmbd have stopped working on 64-bit 13.1

    Samba was working until 12/22/13. I am not sure what happened them. Now when it tries to start, it cannot write its pid. There is no /var/run/samba directory for the pids. I made one as root, but am not sure which owner:group should access it.

    Code:
    [2013/12/22 11:46:49,  0] ../source3/nmbd/nmbd.c:57(terminate)
      Got SIGTERM: going down...
    [2013/12/22 11:48:22,  0] ../source3/nmbd/nmbd.c:902(main)
      nmbd version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2013
    [2013/12/22 11:48:22,  0] ../source3/nmbd/nmbd.c:941(main)
      standard input is not a socket, assuming -D option
    [2013/12/22 11:48:22,  0] ../source3/nmbd/asyncdns.c:157(start_async_dns)
      started asyncdns process 2843
    [2013/12/22 11:48:22,  0] ../lib/util/util.c:216(directory_create_or_exist)
      mkdir failed on directory /var/run/samba: Permission denied
    [2013/12/22 11:48:22,  0] ../source3/nmbd/nmbd.c:977(main)
      Failed to create directory /var/run/samba for pid files - Permission denied
    and
    Code:
      Failed to delete pidfile /var/run/samba/smbd.pid. Error was No such file or directory
    [2013/11/29 15:38:38,  0] ../source3/smbd/server.c:1198(main)
      smbd version 4.1.0-3.8.1-3113-SUSE-oS13.1-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2013
    [2013/12/22 11:46:49.069475,  0] ../lib/util/pidfile.c:153(pidfile_unlink)
    [2013/12/22 11:49:51,  0] ../source3/smbd/server.c:1198(main)
      smbd version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2013
    [2013/12/22 11:49:51.869976,  0] ../source3/smbd/server.c:1278(main)
      standard input is not a socket, assuming -D option
    [2013/12/22 11:49:51.870612,  0] ../lib/util/pidfile.c:117(pidfile_create)
      ERROR: can't open /var/run/samba/smbd.pid: Error was No such file or directory
    [2013/12/22 11:59:06,  0] ../source3/smbd/server.c:1198(main)
      smbd version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2013
    [2013/12/22 11:59:06.964404,  0] ../source3/smbd/server.c:1278(main)
      standard input is not a socket, assuming -D option
    [2013/12/22 11:59:06.965145,  0] ../lib/util/pidfile.c:117(pidfile_create)
      ERROR: can't open /var/run/samba/smbd.pid: Error was No such file or directory
    [2013/12/22 12:11:59,  0] ../source3/smbd/server.c:1198(main)
      smbd version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64 started.
    Also, I think there should be scripts for smbd and nmbd in /etc/init.d, but there are none. Without SWAT, how do I tell the status of the servers or start/stop/restart them?

    Also, each time I go into the Samba settings in YaST, it keeps wanting to set up the root account for samba. But I have already done that, so something is rotten.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,675
    Blog Entries
    3

    Default Re: smbd and nmbd have stopped working on 64-bit 13.1

    Quote Originally Posted by jarome View Post
    Samba was working until 12/22/13. I am not sure what happened them. Now when it tries to start, it cannot write its pid. There is no /var/run/samba directory for the pids. I made one as root, but am not sure which owner:group should access it.
    There's an earlier thread on this (and a bug report).

    It is an "apparmor" problem. I assume that there will be a fix in a few days.

    What I did, is change "apparmor" to "complain" mode for "nmbd" and "smbd". That got things working for me. I'll await a fix before reverting apparmor.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: smbd and nmbd have stopped working on 64-bit 13.1

    Is AppArmour on by default? I never turned it on.
    How do I change it to complain mode?
    How do I restart the daemons to test it?

  4. #4

    Default Re: smbd and nmbd have stopped working on 64-bit 13.1

    I'll be darned. I disabled AppArmour, and smbd and nmbd are working again. Has someone filed a bug about this?

    And I would appreciate knowing the answers to my other questions:
    1) How do I modify the AppArmour profiles for smbd and nmbd to only complain, so I can leave AppArmour on?
    2) How do I start/stop/restart the two daemons and find out their status?
    3) Why aren't their scripts in /etc/init.d for them?

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: smbd and nmbd have stopped working on 64-bit 13.1

    On 2013-12-25 21:46, jarome wrote:
    >
    > I'll be darned. I disabled AppArmour, and smbd and nmbd are working
    > again. Has someone filed a bug about this?


    nrickert said "yes".

    > 1) How do I modify the AppArmour profiles for smbd and nmbd to only
    > complain, so I can leave AppArmour on?


    YaST.

    Security/users -> apparmor -> Settings.

    > 2) How do I start/stop/restart the two daemons and find out their
    > status?


    Code:
    systemctl status cifs

    start, stop, status..., etc
    cifs, ... etc.


    > 3) Why aren't their scripts in /etc/init.d for them?


    Because we are not using systemv anymore. We use systemd.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,675
    Blog Entries
    3

    Default Re: smbd and nmbd have stopped working on 64-bit 13.1

    Quote Originally Posted by jarome View Post
    Has someone filed a bug about this?
    It has been reported as Bug 856651

    It's not one of the bugs I am involved with, so I had to look it up.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Thumbs up Re: smbd and nmbd have stopped working on 64-bit 13.1

    Quote Originally Posted by robin_listas View Post
    On 2013-12-25 21:46, jarome wrote:
    >
    > I'll be darned. I disabled AppArmour, and smbd and nmbd are working
    > again. Has someone filed a bug about this?


    nrickert said "yes".

    > 1) How do I modify the AppArmour profiles for smbd and nmbd to only
    > complain, so I can leave AppArmour on?


    YaST.

    Security/users -> apparmor -> Settings.
    Guys!

    I just logged in to thank-you!

    Been dwelling into to this "bug" a lot of time!

    Just got here when I searched google with the expression ---> "make samba 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64 work"

    There I was immediately pointed out to here!

    When one might think there would be no solution in sight (and although the bug is still present) you provided a workaround!

    Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •