Results 1 to 3 of 3

Thread: SuSE 13.1 und Hardware RAID

  1. #1

    Default SuSE 13.1 und Hardware RAID

    Never touch a running system, aber irgendwann muss man ja.
    Ich hatte zuerst versucht auf einer VM ein Update von 11.3 auf 13.1 zu machen, das nicht funktionierte. Dann ein Update von 11.3 auf 12.2 und dann auf 13.1 das zwar ging, aber irgendwie doch nicht richtig (NTP, SSH lief nicht richtig und andere Kleinigkeiten).
    Ebenso habe ich das auf dem Host versucht, aber dann liefen die VMs nicht mehr richtig, eine fuhr hoch, die andere nicht, dann wieder mal anders herum, aber der Grund für eine Neuinstallation war, dass der Host nicht mehr sauber runterfuhr. In der Fehlermeldung stand, dass der die Mountpoints nicht mehr aushängen kann (/dev/mapper/....). Es handelt sich hierbei um ein Hardware-RAID 1 (HP Proliant N36L), dass unter 11.3 problemlos funktionierte.
    Also entschied ich mich für eine Neuinstallation für die Rootplatte und die boot-Partition.
    In den Menüs der Installation fand er auch die Boot- und Root-Partition inkl. den richtigen RAID-Namen (/dev/mapper/... und darunter die sda und sdb). Also wunderbar -> Installation.
    Jetzt kommt das Problem, es wird beim Neustart keine (Boot)Partition mehr gefunden.
    Wenn ich mich rescue einlogge, stehen identische Werte unter sda und sdb (device.map: /dev/disk/by-id/raid-pdc_.......), aber ich kann nicht booten. Manuell mit dem Namen kann ich die ja auch nicht einbinden.

    Weiß jemand eine Lösung damit Weihnachten auch noch schön werden kann? :-/
    P.S. Beim Update von 12.2 auf 13.1 hat das Booten ja auch funktioniert, nur nicht bei der Neuinstallation.


    openSuSE 13.1
    HP Proliant N36L
    Hardware-RAID 1

    Gruß

  2. #2

    Default Re: SuSE 13.1 und Hardware RAID

    So, ich hab das jetzt so "gelöst":
    Den Vorschlag grub2 auf boot-Partition ergänzt mit dem Schreiben des MBR auf Platte, dann hat es funktioniert.
    Und da er nicht sauber herunterfährt und elektrisch an bleibt, hab ich unter Hilfestellung von Google das halt-Script durch ein eigenes ersetzt, dann schaltet er auch ab, aber toll ist das alles nicht...
    Das fehlerhafte Herunterfahren hat aber wohl nichts mit dem RAID zu tun, vermute ich mal.

  3. #3
    Daniel Wachter NNTP User

    Default Re: SuSE 13.1 und Hardware RAID

    Nur eines dazu, was ich gelernt habe: Bei Updates sollte man keine
    Versionen überspringen. Um von OS 11.3 auf 13.1 zu kommen, sollte man
    neu installieren. Man kann ja das Home-Verzeichnis aufheben, wenn es in
    einer eigenen Partition ist. Ich werde nie mehr Updates machen, sondern
    immer neu installieren.
    Dein RAID-Problem kann ich aber leider nicht lösen.
    Daniel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •