Results 1 to 2 of 2

Thread: Una​ble to add new repo to include a new RPM file

  1. #1

    Default Una​ble to add new repo to include a new RPM file

    Hi Folks,

    I have created a new repo dir rpms-6.4.0.0 on remote build server and to add a new RPM file ('jdk-7u45-linux-x64' ) to kiwi packaging and my build fails with error mentioned below.

    Please find more details below. Am I missing any step below ? Please let me know...is any other file needs an update ?

    - Created new directory rpms-6.4.0.0 under REPOSITORY_PATH
    - Copied RPM 'jdk-7u45-linux-x64' under REPOSITORY_PATH/rpms-6.4.0.0
    - Added following lines to kiwi\config.xml as below along with other repos.

    <repository type="rpm-dir" priority="92">
    <source path="REPOSITORY_PATH/rpms-6.4.0.0"/>
    </repository>

    .
    .
    .
    <packages type="image">
    .
    .

    <package name="jdk-7u45-linux-x64" />
    .
    .

    </packages>

    - Getting following error:
    [sshexec] The selected package 'sles-release-DVD-11.2-1.234.x86_64' from repos itory 'tmp_kiwimount-SLES-11-SP2-DVD-x86_64-GM-DVD1.iso' has lower version than the installed one. Use 'zypper install --oldpackage sles-release-DVD-11.2-1.234. x86_64' to force installation of the package.
    [sshexec] 'jdk-7u45-linux-x64' not found in package names. Trying capabilities .
    [sshexec] No provider of 'jdk-7u45-linux-x64' found.
    [sshexec] ECODE=104
    [sshexec] + echo 104
    [sshexec] + exit 104
    [sshexec] [*** end ***]
    [sshexec]
    [sshexec] done
    [sshexec]
    [sshexec] Dec-23 10:54:39 <3> : Image installation failed


  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: =?UTF-8?B?VW5h4oCLYmxlIHRvIGFkZCBuZXcgcmVwbyB0byBpbmNsdWRlIGE=?==?UTF-8?B?IG5ldyBSUE0gZmlsZQ==?=

    On 2013-12-23 20:46, ckenkare wrote:
    >
    > Hi Folks,
    >
    > I have created a new repo dir *-rpms-6.4.0.0 -*on remote build server
    > and to add a new RPM file ('jdk-7u45-linux-x64' ) to kiwi packaging and
    > my build fails with error mentioned below.


    Maybe I'm mistaken, but are you sure this is a programming/scripting question? Because if not, you
    should ask to get it moved to an appropriate subforum.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •