Results 1 to 7 of 7

Thread: How to enable unicode font data enty

  1. #1

    Default How to enable unicode font data enty

    Hi all,

    I am using opensuse 13.1 amd64 kde version of OS on my home desktop. I wanted to know how to enter the data in Indian languages. I have installed font package indic-fonts after which I am able to read the text in most of the Indian languages through web browsers and also other applications. But unable to enter new text or edit existing text.

    I tried copy & paste of Indian language text from web browser to Libre office word processor. Only few of the text paste will work fine with few grammatical errors. But copy & paste of Indian Language text from Adobe PDF file to any other application just returns unreadable text. Any advise on this matter will be highly appreciated. Thanks in advance.

    Regards
    Ganesh

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,882

    Default Re: How to enable unicode font data enty

    There are allways three things you need to handle characters.
    1) you need to be able to store them. Linux is quite capable of storing any UTF-8 encoded Unicode character. They can even be usd filnames.
    2) you need a font to display them on the screen/printer. As it is not realy effctive to have fonts or all the characters that are defind in Unicode installed, you normaly use a subset You increased the default instaled fonts by adding the indic-fonts package, which, as you confirm, should fullfil this requrement for several scripts used in India.
    3) you need a way to enter them. Now my knowledge is a bit weak here. I am certainly able to enter individual characters by pointing to them fom a list (as possible in LibreOfice through IInsert > Special character, or the KDE Special Characters tool (KDE menu > Tools >Accessability >), but to realy input text, you want to use he keyboard. When one does ot have a keyboard that supports the wanted character set, the keyword to search for is "input method" if I am correct. Such a software enables you to input characters by (combinations of) the keys of he keyboard you have. But as said, I have no experience here.

    I hope that this may show you a direction.
    And I hope of course that someone using this may post here.
    Henk van Velden

  3. #3

    Default Re: How to enable unicode font data enty

    Thank you Henk for your valuable suggestions. Out of three points you have mentioned first two were present already, third one was missing.

    Finally I found a solution. I have installed IBUS package from Yast and now it works fine. Only issue is the system tray icon for keyboard layout seem to be a gtk app. Not sure if there are any Qt equivalents available. I have noticed that Yast has installed the following packages automatically.

    ibus
    ibus-branding-openSUSE-KDE
    ibus-gtk
    ibus-gtk3
    ibus-gtk3-32bit
    ibus-lang
    ibus-m17n
    ibus-qt
    libibus-1_0-5-32bit
    libm17n0
    libotf0
    m17n-db


    Regards
    Ganesh

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to enable unicode font data enty

    Quote Originally Posted by ganeshmallyap View Post
    Thank you Henk for your valuable suggestions. Out of three points you have mentioned first two were present already, third one was missing.

    Finally I found a solution. I have installed IBUS package from Yast and now it works fine. Only issue is the system tray icon for keyboard layout seem to be a gtk app. Not sure if there are any Qt equivalents available. I have noticed that Yast has installed the following packages automatically.

    ibus
    ibus-branding-openSUSE-KDE
    ibus-gtk
    ibus-gtk3
    ibus-gtk3-32bit
    ibus-lang
    ibus-m17n
    ibus-qt
    libibus-1_0-5-32bit
    libm17n0
    libotf0
    m17n-db


    Regards
    Ganesh
    one thing you need to keep in mind with ibus in 13.1 is that it conflicts with libreoffice-kde4 so you will have a pretty ugly looking Libreoffice.
    There is an alternative to ibus called fcitx that works in much the same way and has no conflicts in 13.1

    If you keep ibus there is a themed KDE icon for systray you can install from yast

    ibus-branding-openSUSE-kde

    also, ibus is a gtk3 app so to maintain system appearance you should install

    gtk3-engine-oxygen
    gtk3-theme-oxygen

    and then set that in system configuration
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  5. #5

    Default Re: How to enable unicode font data enty

    Quote Originally Posted by farcusnz View Post
    one thing you need to keep in mind with ibus in 13.1 is that it conflicts with libreoffice-kde4 so you will have a pretty ugly looking Libreoffice.
    There is an alternative to ibus called fcitx that works in much the same way and has no conflicts in 13.1

    If you keep ibus there is a themed KDE icon for systray you can install from yast

    ibus-branding-openSUSE-kde

    also, ibus is a gtk3 app so to maintain system appearance you should install

    gtk3-engine-oxygen
    gtk3-theme-oxygen

    and then set that in system configuration
    Thanks for the timely alert farcusnz. Just now I have noticed this and uninstalled ibus. Except this issue, ibus was working perfect for me. I tried package fcitx as well. But could not find support for Indian languages.

    Is there any other way of taking care of this data input requirement?

    Regard
    Ganesh

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: How to enable unicode font data enty

    On 2013-12-25 10:46, ganeshmallyap wrote:

    > Thanks for the timely alert '*farcusnz*'
    > (https://forums.opensuse.org/members/farcusnz.html). Just now I have
    > noticed this and uninstalled ibus. Except this issue, ibus was working
    > perfect for me. I tried package fcitx as well. But could not find
    > support for Indian languages.


    Just install back ibus if it works for you.

    About the libreoffice problem, you can install the gnome integration packages instead, or live with
    the ugly aspect. Ugly, but works. Or so I understand.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to enable unicode font data enty

    Quote Originally Posted by ganeshmallyap View Post
    Thanks for the timely alert farcusnz. Just now I have noticed this and uninstalled ibus. Except this issue, ibus was working perfect for me. I tried package fcitx as well. But could not find support for Indian languages.

    Is there any other way of taking care of this data input requirement?

    Regard
    Ganesh
    you need to also install fcitx-m17n I believe
    also fcitx-config-kde4

    I've never tested with Indian though so can say if it works or not (but the Indian specific data will be in M17N as it is with ibus)

    If you can't get it going though - do as robin_listas says and just use ibus and libreoffice-gnome

    Libreoffice will look just fine but you will get gtk dialogues.

    There is a bug report on the ibus / libreoffice-kde4 problem which was supposed to be fixed but the fix didn't work so it is an ongoing issue.

    edit: both ibus and fcitx are currently not as polished in openSUSE 13.1 as they were in 12.3 and require a little bit of work (small tweaks) to get them to the same level as they were previously. I'm sure both will improve with a little bit more time.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •