Results 1 to 9 of 9

Thread: SUSE 13.1 LXDE - wrong GTK theme

  1. #1

    Unhappy SUSE 13.1 LXDE - wrong GTK theme

    Hello,

    i've installed SUSE 13.1 with LXDE yesterday, but there are some really ugly GTK "glitches":

    When i right-click on my desktop, it's not using my GTK theme: (no idea why, so i haven't tried anything)


    PCManFM is not using my gtk theme and selected files are black: (no idea why, so i haven't tried anything)


    Applications executed as root don't use my gtk theme: (i've copied my .gtkrc-2.0 to /root and edited paths)


    Correct gtk theme:


    The theme folder contains "gtk-2.0" and "gtk-3.0" so it's compatible with gtk2 and gtk3, right?
    ls output of the theme folder:
    Code:
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$ ls
    DeLoreanDark-Chromium.crx  gtk-3.0      metacity-1  Software-Center  xfwm4
    gtk-2.0                    index.theme  openbox-3   xfce-notify-4.0
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$
    Does anybody know why?

    Thanks, XorgMC

  2. #2

    Default Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by XorgMC View Post
    Hello,

    i've installed SUSE 13.1 with LXDE yesterday, but there are some really ugly GTK "glitches":

    When i right-click on my desktop, it's not using my GTK theme: (no idea why, so i haven't tried anything)

    PCManFM is not using my gtk theme and selected files are black: (no idea why, so i haven't tried anything)
    And how did you set that gtk theme?
    PcManFM and LXDE use Gtk3, so just setting the Gtk2 theme won't have any effect on them.

    Applications executed as root don't use my gtk theme: (i've copied my .gtkrc-2.0 to /root and edited paths)
    Well, YaST also uses Gtk3, so copying the .gtkrc-2.0 won't have effect on it of course.

    Correct gtk theme:
    Well, galculator uses Gtk2 and VLC uses Qt, so that would also support my suspicion that you did not set the Gtk3 theme correctly.

    The Gtk3 theme is configured in ~/.config/gtk-3.0/settings.ini ...

  3. #3

    Default Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by wolfi323 View Post
    And how did you set that gtk theme?
    PcManFM and LXDE use Gtk3, so just setting the Gtk2 theme won't have any effect on them.


    Well, YaST also uses Gtk3, so copying the .gtkrc-2.0 won't have effect on it of course.


    Well, galculator uses Gtk2 and VLC uses Qt, so that would also support my suspicion that you did not set the Gtk3 theme correctly.

    The Gtk3 theme is configured in ~/.config/gtk-3.0/settings.ini ...
    I choosed the theme with [first LXApperance (nothing happened)] gtk-chtheme (worked).

    If LXDE uses GTK3, why is the right-click menu wrong and the application menu ok?

  4. #4

    Default Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by XorgMC View Post
    I choosed the theme with [first LXApperance (nothing happened)] gtk-chtheme (worked).
    Yeah, right. According to its homepage that program sets the Gtk2 theme.

    If LXDE uses GTK3, why is the right-click menu wrong and the application menu ok?
    Well, maybe that was not quite correct, sorry.
    PcManFM (and YaST) uses Gtk3, lxpanel f.e. uses Gtk2.
    Seems to be quite a mess...

    So I still would say you should set the Gtk3 theme correctly, too.

  5. #5

    Default AW: Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by wolfi323 View Post
    Yeah, right. According to its homepage that program sets the Gtk2 theme.


    Well, maybe that was not quite correct, sorry.
    PcManFM (and YaST) uses Gtk3, lxpanel f.e. uses Gtk2.
    Seems to be quite a mess...

    So I still would say you should set the Gtk3 theme correctly, too.
    How to do this, when LXApperance isn't working?

  6. #6

    Default Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by XorgMC View Post
    How to do this, when LXApperance isn't working?
    Use something else.
    F.e. KDE's Systemsettings, GNOME's Controlcenter or Tweak Tool.
    Or edit ~/.config/gtk-3.0/settings.ini with a text editor, see here for more information:
    https://wiki.archlinux.org/index.php/GTK+#GTK.2B_3.x

  7. #7

    Default AW: Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by wolfi323 View Post
    Use something else.
    F.e. KDE's Systemsettings, GNOME's Controlcenter or Tweak Tool.
    Or edit ~/.config/gtk-3.0/settings.ini with a text editor, see here for more information:
    https://wiki.archlinux.org/index.php/GTK+#GTK.2B_3.x
    Still not working

    Choosed my gtk+ theme with GNOME Tweak Tool and edited ~/.config/gtk-3.0/settings.ini

    After relogging, still that ugly gtk3 theme, but GTT is showing me the theme that i choosed (as a setting, but it's also in that ugly theme)

    Contents of my ~/.config/gtk-3.0/settings.ini:
    Code:
    xorg@xorg-pc:~$ cat .config/gtk-3.0/settings.ini
    [Settings]
    gtk-theme-name=delorean-dark-theme-3.9
    gtk-icon-theme-name=oxygen
    gtk-font-name=Sans 10
    gtk-cursor-theme-size=18
    gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
    gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
    gtk-button-images=1
    gtk-menu-images=1
    gtk-enable-event-sounds=1
    gtk-enable-input-feedback-sounds=1
    gtk-xft-antialias=1
    gtk-xft-hinting=1
    gtk-xft-hintstyle=hintfull
    gtk-application-prefer-dark-theme=1
    xorg@xorg-pc:~$
    Contents of my .gtkrc-2.0:
    Code:
    xorg@xorg-pc:~$ cat .gtkrc-2.0
    # -- THEME AUTO-WRITTEN DO NOT EDIT
    include "/home/xorg/.themes/delorean-dark-theme-3.9/gtk-2.0/gtkrc"
    
    style "user-font" {
        font_name = "Sans 10"
    }
    
    widget_class "*" style "user-font"
    
    gtk-font-name="Sans 10"
    
    include "/home/xorg/.gtkrc.mine"
    
    # -- THEME AUTO-WRITTEN DO NOT EDIT
    xorg@xorg-pc:~$
    Contents of the theme's folder:
    Code:
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$ ls
    DeLoreanDark-Chromium.crx  gtk-3.0*      metacity-1*  Software-Center*  xfwm4*
    gtk-2.0*                    index.theme  openbox-3*   xfce-notify-4.0*
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$ ls gtk-2.0/
    colors-dev  gtkrc  images*  panel-background*  panelrc  sidebarrc
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$ ls gtk-3.0/
    assets*                                 gtk-widgets-assets-dark.css
    borders*                                gtk-widgets-backgrounds.css
    gnome-applications.css                 gtk-widgets-borders.css
    gnome-applications-dark-overrides.css  gtk-widgets-borders-dark.css
    gtk.css                                gtk-widgets.css
    gtk-dark.css                           gtk-widgets-dark-overrides.css
    gtk-fallback.css                       overlay-scrollbar.css
    gtk-main-common.css                    settings.ini
    gtk-main.css                           unity.css
    gtk-main-dark.css                      unity-neon.css
    gtk-widgets-assets.css                 unity-simple.css
    xorg@xorg-pc:~/.themes/delorean-dark-theme-3.9$
    (Entrys with * are folders (they are blue in terminal))

    Now i'm confused...

  8. #8

    Default Re: SUSE 13.1 LXDE - wrong GTK theme

    Quote Originally Posted by XorgMC View Post
    Still not working
    Hm, maybe that theme doesn't work with the latest gtk3?
    Where did you download the theme from? I could try it on my system.

    Does it work if you select a different Gtk3 theme?

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,722

    Default AW: SUSE 13.1 LXDE - wrong GTK theme

    Other distributions
    Download DeLorean-Dark-Themes-3.8. Unzip and as privileged user copy the following four delorean-dark-theme-*-3.9 folders to /usr/share/themes/. This theme will not work properly when installed to ~/.themes.
    DeLorean-Dark-Themes-3.8 by killhellokitty on deviantART

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •