Results 1 to 8 of 8

Thread: Updating 13.1 to use kernel 3.12

  1. #1

    Default Updating 13.1 to use kernel 3.12

    Hi,

    I'm a new OpenSUSE user. I recently installed OpenSUSE 13.1 but I'm having a wifi issue. I read elsewhere that somebody upgraded their kernel to fix the exact same issue. So I did:

    Code:
    zypper ar http://download.opensuse.org/repositories/Kernel:/stable/standard Kernel:stable
    zypper in --from Kernel:stable kernel-desktop
    When I installed it, it mentioned that it had an untrusted cert but I could click Trust to continue with the installation. After reboot, Grub is spitting out:

    Code:
    Loading Linux 3.12.5-2.g38448a14-desktop
    error: /boot/vmlinuz-3.12.5-2.g38448a14-desktop has invalid signature
    Loading initial ramdisk ...
    error: you need to load the kernel first
    I can still load the 3.11.6-4 kernel that came with OpenSUSE 13.1.

    Wondering how to boot up with the new kernel?

    Thanks!

  2. #2
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: Updating 13.1 to use kernel 3.12

    Do you use EFI system with secure boot enabled?

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Updating 13.1 to use kernel 3.12

    Quote Originally Posted by amoebaworks View Post
    Hi,

    I'm a new OpenSUSE user. I recently installed OpenSUSE 13.1 but I'm having a wifi issue. I read elsewhere that somebody upgraded their kernel to fix the exact same issue. So I did:

    Code:
    zypper ar http://download.opensuse.org/repositories/Kernel:/stable/standard Kernel:stable
    zypper in --from Kernel:stable kernel-desktop
    When I installed it, it mentioned that it had an untrusted cert but I could click Trust to continue with the installation. After reboot, Grub is spitting out:

    Code:
    Loading Linux 3.12.5-2.g38448a14-desktop
    error: /boot/vmlinuz-3.12.5-2.g38448a14-desktop has invalid signature
    Loading initial ramdisk ...
    error: you need to load the kernel first
    I can still load the 3.11.6-4 kernel that came with OpenSUSE 13.1.

    Wondering how to boot up with the new kernel?

    Thanks!
    That sounds to me like a bug.
    Recommend searching for a related bug at http://bugzilla.novell.com.
    If no bug exists, then create one and include all the relevant info you can think of.

    My guess is that if a bug is verified, it will be fixed soon.

    TSU

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Updating 13.1 to use kernel 3.12

    What WIFI card/chip? upgrading kernel may not be needed you might only need to install firmware for the card.

  5. #5

    Default Re: Updating 13.1 to use kernel 3.12

    I've use the secure boot and it's the same message.

    I have a Ralink rt3290 WiFi card. I looked on the wireless forums and didn't get much luck other than this one: http://forums.opensuse.org/english/g...suse-13-a.html

    I have seen suggestions on using a backport driver or going to the Ralink site and compiling a driver (suggested from an Ubuntu forum). I thought updating the kernel would work the best / easiest.

    I'll file a bug and maybe try the kernel-of-the-day. Or can I get 3.12.4 kernel some how?

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Updating 13.1 to use kernel 3.12

    On 12/23/2013 04:06 PM, amoebaworks wrote:
    >
    > I've use the secure boot and it's the same message.
    >
    > I have a Ralink rt3290 WiFi card. I looked on the wireless forums and
    > didn't get much luck other than this one: http://tinyurl.com/lrwj8va
    >
    > I have seen suggestions on using a backport driver or going to the
    > Ralink site and compiling a driver (suggested from an Ubuntu forum). I
    > thought updating the kernel would work the best / easiest.
    >
    > I'll file a bug and maybe try the kernel-of-the-day. Or can I get 3.12.4
    > kernel some how?


    If you look at the patch, there is a line that says "Cc: stable@vger.kernel.org
    # 3.11+". That means that once the patch is merged, it will be backported to
    every kernel 3.11 and newer. The second part is that it was merged into the
    mainline kernel on Mon Sep 23 04:08:13 2013. It usually takes only a few weeks
    before the change gets ported back to the stable kernels. The git commit log for
    kernel 3.11 shows that this patch was added on November 13, and it was part of
    3.11.8. You need a kernel at least that new. I'm not sure why 13.1 is "stuck" at
    3.11.6 when 3.11.10. File a bug report about your wifi trouble, and tell the
    devs that the fix you need is in 3.11.8.



  7. #7

    Default Re: Updating 13.1 to use kernel 3.12

    Strange issue.
    No problems here following the same procedure of amoebaworks ...

  8. #8

    Default Re: Updating 13.1 to use kernel 3.12

    Ok. I clued in what arvidjaar was suggesting. I had to turn off the Secure Boot from the BIOS. And then launched opensuse EFI instead of opensuse-secureboot from the BIOS boot menu.

    I can now use the latest kernel and have wifi!!! Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •