Results 1 to 6 of 6

Thread: Audacity of opensuse 13.1 crashes

  1. #1

    Unhappy Audacity of opensuse 13.1 crashes

    Have you noticed that audacity installed from opensuse or Packman repositories crashes when trying to invoke equalizer?

    gdb reports segmentation fault in some sort of GUI function. Same says audacity's wiki, referring to a known bug in widget utilities. However, audacity's wiki speaks about hundreds of bugs, and I am not sure what reasons they bring.


    Solution found: use audacity version 2.0.2-3.1.2.x86_64 from opensuse 12.3. Seems to work until now.

    Audacity was a good, popular program. This is the first time I have a major problem with it.

  2. #2
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Audacity of opensuse 13.1 crashes

    I hadn't until you pointed it out, it is the same on my computer (OS 13.1). I tested Audacity with various LADSPA EQs and they do work though, and so do the other effect modules I briefly skimmed through.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  3. #3
    Join Date
    Aug 2008
    Location
    Temporarily, planet Earth
    Posts
    104

    Default Re: Audacity of opensuse 13.1 crashes

    I have a different problem: when exporting a m4a, one core of my CPU goes to 100% running audacity.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Audacity of opensuse 13.1 crashes

    Does it crash Audacity or is the export successful?
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5
    Join Date
    Aug 2008
    Location
    Temporarily, planet Earth
    Posts
    104

    Default Re: Audacity of opensuse 13.1 crashes

    Quote Originally Posted by F_Sauce View Post
    Does it crash Audacity or is the export successful?
    Neither. The CPU runs at 100%.

    This happens when I export as an AAC. Sometimes the first export works, but the second hangs.

    I installed the debug and source RPMs and attach GDB. A backtrace show it in libavcoderc.so.52.

    The libraries and Audacity (2.0.4) are from Packman.

    This happens with 13.1 default (openSUSE) Audacity.

    I see there is version 2.0.5 which has numerous bug fixes.

  6. #6
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Audacity of opensuse 13.1 crashes

    Hello again,

    Just did a test on my 13.1 system using Audacity 2.0.4, I could not produce the same error when exporting to m4a with ffmpeg as you did. I did not test very thoroughly though, but four successive exports went thorugh just fine. Might be somnething else than Audacity causing the error.

    Olav
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •