Results 1 to 5 of 5

Thread: TrueCrypt in Opensuse 13.1 not installing.

  1. #1

    Default TrueCrypt in Opensuse 13.1 not installing.

    Question:

    I am new to not only Opensuse but also Linux in general. I installed 13.1 Gnome 64 bit. Windows failed to respond after a severe hardware failure. The hardware was fixed, but left me with no operating system.

    I had previously been running system encryption, and I wish to resume this with Opensuse.

    After many failed attempts to install from the package available on the site, and searching the forums for help, I must say I am totally lost as to why it won't install.

    Here is the error message I get when gedit opens the file:

    There was a problem opening the file “/home/user/Downloads/truecrypt-7.1a-setup-x64”.

    The file you opened has some invalid characters. If you continue editing this file you could corrupt this document.
    You can also choose another character encoding and try again.


    I have tried using different character endcoding and even used the modprobe loop command in my kernel. Alas, to no avail. Is it actually realcrypt that I am supposed to install? I had seen that mentioned in a subject line, but it was not elaborated on.

    Like I said, I am new to all this, and as I work out getting the system to where I want it I am hoping to learn much. If there is a link to a 13.1 specific package I haven't been able to find it.

    Any help with this would be appreciated.

    Thanks in advance

    Stuart

  2. #2

    Default Re: TrueCrypt in Opensuse 13.1 not installing.

    Very frustrating development after attempting this install attempt.

    I tried installing realcrypt from here:

    http://software.opensuse.org/package...term=realcrypt

    Alas, it was not meant to be.

    After a restart, it would seem that I now cannot get my WI-fi to log in. The password is good, but it rejects it.

    Could the Modprobe loop command interfere with this?

  3. #3

    Default Re: TrueCrypt in Opensuse 13.1 not installing.

    Quote Originally Posted by StuartU View Post
    Question:

    I am new to not only Opensuse but also Linux in general. I installed 13.1 Gnome 64 bit. Windows failed to respond after a severe hardware failure. The hardware was fixed, but left me with no operating system.

    I had previously been running system encryption, and I wish to resume this with Opensuse.

    After many failed attempts to install from the package available on the site, and searching the forums for help, I must say I am totally lost as to why it won't install.

    Here is the error message I get when gedit opens the file:

    There was a problem opening the file “/home/user/Downloads/truecrypt-7.1a-setup-x64”.

    The file you opened has some invalid characters. If you continue editing this file you could corrupt this document.
    You can also choose another character encoding and try again.


    I have tried using different character endcoding and even used the modprobe loop command in my kernel. Alas, to no avail. Is it actually realcrypt that I am supposed to install? I had seen that mentioned in a subject line, but it was not elaborated on.

    Like I said, I am new to all this, and as I work out getting the system to where I want it I am hoping to learn much. If there is a link to a 13.1 specific package I haven't been able to find it.

    Any help with this would be appreciated.

    Thanks in advance

    Stuart

    Probably not much help here but the file is binary which is why it wont open in gedit. Are you getting a segmentation fault and a warning 'Unable to load any usable ISO8859 font'? If so, I ran into the same issue but so far have been unsuccessful in resolving. If I figure it out, I'll repost.

  4. #4
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,162

    Default Re: TrueCrypt in Opensuse 13.1 not installing.

    Give this a try:
    Code:
    #echo loop > /etc/modules-load.d/loop.conf
    In Terminal
    The "#" key means as root.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  5. #5
    Join Date
    Jan 2014
    Location
    Singapore
    Posts
    15

    Default Re: TrueCrypt in Opensuse 13.1 not installing.

    For what it's worth:
    I am running openSUSE 13.1 with the KDE 4.11 environment, and had no trouble installing Truecrypt twice in the last few days.
    I have it installed on my desktop.
    When I extracted the tar-ball from the gz-file and tried to install it NOW (with a Truecrypt installation already present), I get the same or very similar messages you are reporting, they appear at the top of the window that pops up. That indicates a collision that was absent previously.

    One possible explanation is that you have an incomplete installation or installation files floating around your files and directories.
    One possible remedy is to find those files, delete or uninstall any residues of your previous attempts and attempt a clean reinstallation.

    When I did my installations, in both instances it worked without a single complaint. I was done in less than two minutes. You should get these windows upon clicking on the file truecrypt-7.1a-setup-x64:

    http://www.susepaste.org/2515437
    http://www.susepaste.org/17604723
    http://www.susepaste.org/78511811

    My two cents worth.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •