Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Apper authentication popups don't pop up

  1. #1

    Default Apper authentication popups don't pop up

    I have just updated from OpenSuSE 12.3 to 13.1 on a dual-opteron PC (kernel 3.11.6-4-desktop, KDE 4.11.3), and I can no longer use Apper to update. I can check for updates with it, but when I try to apply them, I see no authentication dialogue popup, I receive a notification that I have failed to authenticate, and no update occurs. With Apper set to check for updates daily, I then receive more similar notifications but no authentication dialogues every time it tries to check for updates, which it does every few minutes. Other authentication dialogues--YaST, kwallet, CUPs--work OK. I have used YaST's Onlime Update module to update, but it has far fewer updates on offer than Apper. Any suggestions?

    Ben

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,373
    Blog Entries
    3

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by benbrewster View Post
    Any suggestions?
    Right click on the tray (panel) and select "System Tray Settings". I usually right click just above the triangle for hidden icons.

    In the tray settings, look at the "Extra Items". There should be one for "Software Updater". Make sure that is checked.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: Apper authentication popups don't pop up

    This sounds to me like a permissions issue, that happens if your user session is not correctly registered with logind.

    Please post the output of:
    Code:
    loginctl

  4. #4

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by nrickert View Post
    Right click on the tray (panel) and select "System Tray Settings". I usually right click just above the triangle for hidden icons.

    In the tray settings, look at the "Extra Items". There should be one for "Software Updater". Make sure that is checked.
    ben@linux-3j1n:~> loginctl
    SESSION UID USER SEAT
    1 0 root seat0


    1 sessions listed.

  5. #5

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by wolfi323 View Post
    This sounds to me like a permissions issue, that happens if your user session is not correctly registered with logind.

    Please post the output of:
    Code:
    loginctl

    ben@linux-3j1n:~> loginctl
    SESSION UID USER SEAT
    1 0 root seat0


    1 sessions listed.

  6. #6

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by benbrewster View Post
    ben@linux-3j1n:~> loginctl
    SESSION UID USER SEAT
    1 0 root seat0


    1 sessions listed.
    Are you logged in as root?

    If not, how are you logging in and get to the X session exactly?

  7. #7

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by wolfi323 View Post
    Are you logged in as root?

    If not, how are you logging in and get to the X session exactly?
    No, I'm logged in as a user. The computer is set to boot to level 3. I then login as root, run kdm, and log in as user.

  8. #8

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by benbrewster View Post
    No, I'm logged in as a user. The computer is set to boot to level 3. I then login as root, run kdm, and log in as user.
    And how do you run kdm? I'm asking because it's kdm that should register the user session with logind and apparently this does not happen in your case.
    Does it work if you run kdm with "rcxdm start" or "init 5"?
    (loginctl should show your user session)

  9. #9

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by wolfi323 View Post
    And how do you run kdm? I'm asking because it's kdm that should register the user session with logind and apparently this does not happen in your case.
    Does it work if you run kdm with "rcxdm start" or "init 5"?
    (loginctl should show your user session)
    I run the command "kdm" and then enter the user name and password in the dialog that appears once X-windows is launched.

  10. #10

    Default Re: Apper authentication popups don't pop up

    Quote Originally Posted by benbrewster View Post
    I run the command "kdm" and then enter the user name and password in the dialog that appears once X-windows is launched.
    Try with "rcxdm start" or "init 5", please, and check if your user session is registered then with "loginctl".

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •