Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: VLC codec problem today?

  1. #1

    Default VLC codec problem today?

    I updated (zypper dup) from the Tumbleweed repositories yesterday, which encountered a conflict. I resolved it by removing the offending packages rather than breaking the dependency, but now I'm in a state where I have no codecs for vlc. Attempting to install them (yast) says:

    Code:
    nothing provides libxvidcore.so.4 needed by libavcodec55-2.1.1-2.2.i586
        [ ] break libavcodec55-2.1.1-2.2.i586 by ignoring some of its dependencies
        [ ] do not install vlc-codecs-2.1.2-186.3.i586
    Is there a way to re-add these?

    Code:
    > zypper repos
    # | Alias                            | Name                             | Enabled | Refresh
    --+----------------------------------+----------------------------------+---------+--------
    1 | Packman_Tumbleweed               | Packman Tumbleweed               | Yes     | Yes    
    2 | openSUSE:Stable_OSS              | openSUSE:Stable_OSS              | Yes     | Yes    
    3 | openSUSE:Stable_Updates          | openSUSE:Stable_Updates          | Yes     | Yes    
    4 | openSUSE:Stable_non-OSS          | openSUSE:Stable_non-OSS          | Yes     | Yes    
    5 | openSUSE:Stable_non-OSS__Updates | openSUSE:Stable_non-OSS__Updates | Yes     | Yes    
    6 | openSUSE:Tumbleweed              | openSUSE:Tumbleweed              | Yes     | Yes    
    7 | opensuse-guide.org-repo_1        | libdvdcss repository             | Yes     | Yes

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VLC codec problem today?

    Please post the repos using "zypper lr -d", so we can see the url's.

  3. #3

    Default Re: VLC codec problem today?

    Ah, sorry, didn't realise that was important:

    Code:
    # | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
    --+----------------------------------+----------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
    1 | Packman_Tumbleweed               | Packman Tumbleweed               | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed                         |        
    2 | openSUSE:Stable_OSS              | openSUSE:Stable_OSS              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |        
    3 | openSUSE:Stable_Updates          | openSUSE:Stable_Updates          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |        
    4 | openSUSE:Stable_non-OSS          | openSUSE:Stable_non-OSS          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |        
    5 | openSUSE:Stable_non-OSS__Updates | openSUSE:Stable_non-OSS__Updates | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-non-oss-current/            |        
    6 | openSUSE:Tumbleweed              | openSUSE:Tumbleweed              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |        
    7 | opensuse-guide.org-repo_1        | libdvdcss repository             | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                     |

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VLC codec problem today?

    Quote Originally Posted by nick_battle View Post
    Ah, sorry, didn't realise that was important:
    Yes, it also shows the repo priorities. If those are changed, as some users do that, it can affect the results of updating.

    You need to install the package "libxvidcore4" from your Packman repo to satisfy the dependency for libxvidcore.so.4

    If you get any further conflicts or that doesn't solve your missing codecs problem, take the safe option and post back with the info. BTW you can see what packages were previously removed by using your text editor on /var/log/zypp/history, and searching probably towards the end of the log in your case.

  5. #5

    Default Re: VLC codec problem today?

    Quote Originally Posted by consused View Post
    You need to install the package "libxvidcore4" from your Packman repo to satisfy the dependency for libxvidcore.so.4
    But yast says that I already have libxvidcore4 installed from Packman - 1.3.2-2.7-i586 from Packman Tumbleweed with priority 99 and vendor PackMan :: Startseite. There are no other options to install it from elsewhere (in the Versions tab). Is it perhaps a version problem, that libavcodec55-2.1.1-2.2.i586 needs a later/different version of libxvidcore4?

    (I'm afraid I've since deleted that zypp log file with some rather aggressive cleanup scripts).

  6. #6

    Default Re: VLC codec problem today?

    Seems to be a general problem on 32bit ATM. I noticed the same on 13.1 32bit a few days ago.
    Somebody also reported it on the Packman mailinglist:
    [packman] Something is wrong with updates

    So hopefully they will fix it soon...

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: VLC codec problem today?

    Quote Originally Posted by nick_battle View Post
    But yast says that I already have libxvidcore4 installed from Packman - 1.3.2-2.7-i586 from Packman Tumbleweed with priority 99 and vendor PackMan :: Startseite. There are no other options to install it from elsewhere (in the Versions tab). Is it perhaps a version problem, that libavcodec55-2.1.1-2.2.i586 needs a later/different version of libxvidcore4?

    (I'm afraid I've since deleted that zypp log file with some rather aggressive cleanup scripts).
    That seems to be the right version for libavcodec55 (i586) as shown by my YaST (although I use x86_64). Package libxvidcore4 (1.3.2-2.7) installs /usr/lib64/libxvidcore.so.4 which links to /usr/lib64/libxvidcore.so.4.3 here, so check for those present on your system.

    I didn't get any conflicts with recent updates pertaining to Tumbleweed using x86_64, so it looks like a problem for the Packman i586 update.

    Sorry I can't help further, given your missing log file.

  8. #8

    Default Re: VLC codec problem today?

    Quote Originally Posted by consused View Post
    That seems to be the right version for libavcodec55 (i586) as shown by my YaST (although I use x86_64). Package libxvidcore4 (1.3.2-2.7) installs /usr/lib64/libxvidcore.so.4 which links to /usr/lib64/libxvidcore.so.4.3 here, so check for those present on your system.

    I didn't get any conflicts with recent updates pertaining to Tumbleweed using x86_64, so it looks like a problem for the Packman i586 update.

    Sorry I can't help further, given your missing log file.
    Yes, the libxvidcore.so.4 is a symlink to ~so.4.3 on my system also (but i586, in /usr/lib). One day I will clean up my log clean-up to be less clean

    Thanks for the help anyway. Perhaps as wolfi323 says, it is a Packman problem. Certainly the files mentioned in the link look familiar. I'll try another update in a few days time.

  9. #9

    Default Re: VLC codec problem today?

    JFYI: The problem should be fixed in the meantime. In short, there apparently have been two faulty build servers that created incorrect packages. They have been removed now and those packages rebuilt, so everything should be fine again.

    [packman] Solved! was: Re: Something is wrong with updates

  10. #10

    Default Re: VLC codec problem today?

    Quote Originally Posted by wolfi323 View Post
    JFYI: The problem should be fixed in the meantime. In short, there apparently have been two faulty build servers that created incorrect packages. They have been removed now and those packages rebuilt, so everything should be fine again.
    Thanks for the update. I did another zypper dup, and I could see it update several relevant packages. Installing vlc-codecs though still gives a missing dependency:

    Code:
    nothing provides libtwolame.so.0 needed by vlc-codecs-2.1.2-186.12.i586
    Ignoring the dependency and installing the codecs anyway seems to work though. Thanks again.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •