Results 1 to 4 of 4

Thread: Automatical mounting of ext-hdd causes funny results with a drive:

  1. #1

    Default Automatical mounting of ext-hdd causes funny results with a drive:

    hello dear Suse-experts,

    first of all - i had simmilar issues - and got lots of help form the folks here .- from Robin, Jim and others. MAny many thanks for all the help

    now i run into more issues.

    here the story i have a external harddrive that has got 1 Terabyte:

    i ve formatted it with ext4

    Gerät: /dev/sdb1
    Größe: 931.51 GB
    Verschlüsselt: Nein
    Gerätepfad: pci-0000:00:12.2-usb-0:1:1.0-scsi-0:0:0:0-part1
    Geräte-ID 1: ata-ST1000DM003-1CH162_S1DE523L-part1
    Geräte-ID 2: scsi-SASMT_2105_B8140000000000000503-part1
    Geräte-ID 3: wwn-0x5000c5006c7d7e56-part1
    FS-ID: 0x83 Linux native
    Dateisystem:
    Dateisystem: Ext4
    it has the id-system (Kennung HDDRIVE2GO


    if i try to mount it on my Samsung-notebook q 210, 12,1" with OpenSuse 12.3 i get very funny results back:

    a. with Dolphin i can see a drive in

    var/run/media/martin/HDDRIVE2GO

    note: that (HDDRIVE2GO) is the external HDD:

    And with Dolphin i can

    a. create new directories in that var/run/media/martin/HDDRIVE2GO
    b. copy datas from one folder to another...

    note: i did not start any mounting to reach that behaviour -
    question: do we have some kind of automatical mounting here:



    well besides this i allways thought that i have to mount -
    so i subsequently followed the following steps:

    Code:
    linux-70ce:/home/martin #
    linux-70ce:/home/martin # mkdir /mnt/ext
    linux-70ce:/home/martin # mkdir -p /mnt/ext
    linux-70ce:/home/martin # mount /dev/sdb1 /mnt/ext
    see the results:

    Code:
    linux-70ce:/home/martin # df -aTh
    Dateisystem    Typ             Größe Benutzt Verf. Verw% Eingehängt auf
    rootfs         rootfs            20G    5,8G   13G   31% /
    devtmpfs       devtmpfs         1,5G    8,0K  1,5G    1% /dev
    tmpfs          tmpfs            1,5G    608K  1,5G    1% /dev/shm
    tmpfs          tmpfs            1,5G    8,4M  1,5G    1% /run
    devpts         devpts              0       0     0     - /dev/pts
    /dev/sda6      ext4              20G    5,8G   13G   31% /
    proc           proc                0       0     0     - /proc
    sysfs          sysfs               0       0     0     - /sys
    securityfs     securityfs          0       0     0     - /sys/kernel/security
    tmpfs          tmpfs            1,5G       0  1,5G    0% /sys/fs/cgroup
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/systemd
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/cpuset
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/cpu,cpuacct
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/memory
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/devices
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/freezer
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/net_cls
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/blkio
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/perf_event
    cgroup         cgroup              0       0     0     - /sys/fs/cgroup/hugetlb
    systemd-1      autofs              0       0     0     - /proc/sys/fs/binfmt_misc
    mqueue         mqueue              0       0     0     - /dev/mqueue
    hugetlbfs      hugetlbfs           0       0     0     - /dev/hugepages
    tmpfs          tmpfs            1,5G    8,4M  1,5G    1% /var/lock
    debugfs        debugfs             0       0     0     - /sys/kernel/debug
    tmpfs          tmpfs            1,5G    8,4M  1,5G    1% /var/run
    /dev/sda7      ext4             251G     70G  180G   29% /home
    fusectl        fusectl             0       0     0     - /sys/fs/fuse/connections
    gvfsd-fuse     fuse.gvfsd-fuse  0,0K    0,0K  0,0K     - /run/user/1000/gvfs
    gvfsd-fuse     fuse.gvfsd-fuse  0,0K    0,0K  0,0K     - /var/run/user/1000/gvfs
    binfmt_misc    binfmt_misc         0       0     0     - /proc/sys/fs/binfmt_misc
    /dev/sdb1      ext4             917G     48G  869G    6% /mnt/ext
    linux-70ce:/home/martin #



    and if we have a closer look than we see the following

    Code:
    linux-70ce:/home/martin # mount /dev/sdb1 /mnt/ext

    and see more:

    Code:
    linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    linux-70ce:/mnt # chmod -R 0777 /mnt/
    chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    linux-70ce:/mnt #

    very exciting: if i try to copy some things to that drive - i cannot - since i have no rights... !? [duhh]

    Code:
    cp -R /home/martin/* /mnt/ext

    see the results:
    Code:
    linux-70ce:/mnt # cp -R /home/martin/* /mnt/ext
    cp: reguläre Datei „/mnt/ext/2013_05_21_sinsheim_office_my_backups_os.rar“ kann nicht angelegt werden: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/2013_juni_data“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/2013_nov_data“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/a_Bilder“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/all_databases“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/all_safings“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/all_scrapers“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/Arbeitsfläche“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/Bilder“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/bin“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/_calender_bau_14“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/databases_“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/Dokumente“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: kann Verzeichnis „/mnt/ext/fotos heike“ nicht anlegen: Das Dateisystem ist nur lesbar
    cp: reguläre Datei „/mnt/ext/_keyring.asc“ kann nicht angelegt werden: Das Dateisystem ist nur les
    translation: this: kann nicht angelegt werden: Das Dateisystem ist nur lesbar .- means - cann not be created - the directory is only readable!?


    questions:

    why do i have such exctingintg things as the following:

    a. with Dolphin i can see a drive in

    var/run/media/martin/HDDRIVE2GO

    note: that is the external HDD

    with Dolphin i can create new directories in that var/run/media/martin/HDDRIVE2GO

    - and yes: i did not create this mounting point -
    so - the question is: is there a automatical mounting active!?

    love to hear from you
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2

    Default Re: Automatical mounting of ext-hdd causes funny results with a drive:

    Quote Originally Posted by dilbertone View Post
    And with Dolphin i can

    a. create new directories in that var/run/media/martin/HDDRIVE2GO
    b. copy datas from one folder to another...

    note: i did not start any mounting to reach that behaviour -
    question: do we have some kind of automatical mounting here:
    If you select a drive in dolphin or KDE's file selection dialog, it will be mounted to /var/run/media/$USER before opening it.


    well besides this i allways thought that i have to mount -
    so i subsequently followed the following steps:

    Code:
    linux-70ce:/home/martin #
    linux-70ce:/home/martin # mkdir /mnt/ext
    linux-70ce:/home/martin # mkdir -p /mnt/ext
    linux-70ce:/home/martin # mount /dev/sdb1 /mnt/ext
    That's the traditional way to mount a drive. You could also create an entry in /etc/fstab. If you specify the option "user", you don't have to be root to mount the partition.

    Or you can use udisks2 to mount it (like KDE does):
    Code:
    udisksctl mount -b /dev/sdb1
    This will mount it to /var/run/media/$USER, as if it was opened in dolphin.

    translation: this: kann nicht angelegt werden: Das Dateisystem ist nur lesbar .- means - cann not be created - the directory is only readable!?
    Check that your user has permissions for the mount point itself (before the drive is mounted):
    Code:
    ls -ld /mnt/ext

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Automatical mounting of ext-hdd causes funny results with a drive:

    On 2013-12-20 10:16, dilbertone wrote:

    > i ve formatted it with ext4
    >>
    >>
    >> Gerät: /dev/sdb1
    >> Größe: 931.51 GB
    >> Verschlüsselt: Nein
    >> Gerätepfad: pci-0000:00:12.2-usb-0:1:1.0-scsi-0:0:0:0-part1
    >> Geräte-ID 1: ata-ST1000DM003-1CH162_S1DE523L-part1
    >> Geräte-ID 2: scsi-SASMT_2105_B8140000000000000503-part1
    >> Geräte-ID 3: wwn-0x5000c5006c7d7e56-part1
    >> FS-ID: 0x83 Linux native
    >> Dateisystem:
    >> Dateisystem: Ext4
    >> it has the id-system (Kennung HDDRIVE2GO



    I have a bit of difficulty understanding your post.


    Just a comment. When the system language is not English, you should do,
    in order to post here, like this:


    Code:
    minas-tirith:~ # LANG=en_US.UTF-8 zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...

    or this:

    Code:
    minas-tirith:~ # LANG=C zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...
    ^C

    That way we can all read it, regardless of local languages of sender and
    reader. It is not a permanent change, it only applies to one command.



    > *note: *i did not start any mounting to reach that behaviour -
    > *question: *do we have some kind of automatical mounting here:


    Yes.


    > well besides this i allways thought that i have to mount -
    > so i subsequently followed the following steps:


    But it is already mounted, see above.


    ....

    > and see more:
    >


    No idea what I see here, I can't read it.

    >
    > Code:
    > --------------------
    >
    > linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    > chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    > linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    > chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    > linux-70ce:/mnt # chmod -R 0777 /mnt/ext
    > chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    > linux-70ce:/mnt # chmod -R 0777 /mnt/
    > chmod: Beim Setzen der Zugriffsrechte für „/mnt/ext“: Das Dateisystem ist nur lesbar
    > linux-70ce:/mnt #
    >
    > --------------------






    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4

    Default Re: Automatical mounting of ext-hdd causes funny results with a drive:

    hello Robin hello Wolfi


    many many thanks for the replies with the valuable assets of ideas and knowledge.

    This helps alot!

    i will check the permission-things and

    Code:
    ls -ld /mnt/ext
    Note: At the moment i am not at home. But i later today i do all the tests and afterwards i come back and let you know the results.
    Many many thanks for the hints - regarding the Mounting in Dolphin - way.
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •