Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Cannot Start Samba after openSUSE 13.1 upgrade

  1. #1

    Default Cannot Start Samba after openSUSE 13.1 upgrade

    Cannot get samba to start on server after upgrade to openSUSE 13.1. At real loss with the lack of information in the logs. I will try and start out with some output I am getting back and my smb.conf. the hostname will be obfuscated as 'HOSTNAME' so ignore that. Samba logs in /var/logs/samba have the same output for the most part and nothing more useful.

    When trying to start since it fails at startup
    Code:
    HOSTNAME:/home/admin # systemctl start smb.service && systemctl start nmb.service
    Job for smb.service failed. See 'systemctl status smb.service' and 'journalctl -xn' for details.
    HOSTNAME:/home/admin # systemctl status smb.service
    smb.service - Samba SMB Daemon
       Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
       Active: failed (Result: resources) since Thu 2013-12-19 22:21:33 MST; 29s ago
      Process: 11601 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
     Main PID: 9507 (code=exited, status=1/FAILURE)
    
    
    Dec 19 22:21:33 HOSTNAME systemd[1]: Starting Samba SMB Daemon...
    Dec 19 22:21:33 HOSTNAME smbd[11601]: [2013/12/19 22:21:33.884975,  0] ../source3/smbd/server.c:1278(main)
    Dec 19 22:21:33 HOSTNAME smbd[11601]: standard input is not a socket, assuming -D option
    Dec 19 22:21:33 HOSTNAME smbd[11602]: [2013/12/19 22:21:33.886266,  0] ../lib/util/pidfile.c:117(pidfile_create)
    Dec 19 22:21:33 HOSTNAME smbd[11602]: ERROR: can't open /var/run/samba/smbd.pid: Error was No such file or directory
    Dec 19 22:21:33 HOSTNAME systemd[1]: PID file /run/samba/smbd.pid not readable (yet?) after start.
    Dec 19 22:21:33 HOSTNAME systemd[1]: smb.service never wrote its PID file. Failing.
    Dec 19 22:21:33 HOSTNAME systemd[1]: Failed to start Samba SMB Daemon.
    Dec 19 22:21:33 HOSTNAME systemd[1]: Unit smb.service entered failed state.
    smb.conf
    Code:
    [global]
            workgroup = WORKGROUP
            passdb backend = tdbsam
            printing = cups
            printcap name = cups
            printcap cache time = 750
            cups options = raw
            map to guest = Bad User
            include = /etc/samba/dhcp.conf
            logon path = \\%L\profiles\.msprofile
            logon home = \\%L\%U\.9xprofile
            logon drive = P:
            usershare allow guests = No
            domain logons = No
            domain master = No
            netbios name = HOSTNAME
            security = domain
            wins support = No
            password server = *
            wins server =
    [somesite]
            writeable = yes
            path = /srv/www/htdocs/somesite
            inherit acls = Yes
            read only = No
            follow symlinks = Yes
            username = admin
    [commonfiles]
            public = yes
            path = /commonfiles
            inherit acls = Yes
    Thanks in advance

  2. #2

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    Maybe Apparmor is blocking it?
    Try to turn it off:
    Code:
    sudo rcapparmor stop
    Does Samba start then?

    There was a problem with Samba's Apparmor profile included in 13.1 IIRC. But that should be fixed already.
    Did you install all updates?

  3. #3
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    129

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    I have the same problem.....
    Don't see samba and nmb at all in the runlevel.
    I think there was an update yesterday, think this it has caused.











  4. #4

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    Did you try:
    Code:
    systemctl start smb.service nmb.service

  5. #5

    Default AW: Re: Cannot Start Samba after openSUSE 13.1 upgrade

    Quote Originally Posted by GJElde View Post
    I have the same problem.....
    Don't see samba and nmb at all in the runlevel.
    How do you know you have the _same_ problem? The OP doesn't mention anything about it not being visible in the runlevel editor...

    Well, don't use the Runlevel editor. It's broken with systemd (even was in 12.3 already).
    Use the new YaST->System->Services Manager instead.

    I think there was an update yesterday, think this it has caused.
    Right, I just noticed it doesn't start here either anymore.
    Anyway, quitting Apparmor as I suggested fixes the problem for me.
    Code:
    sudo /sbin/rcapparmor stop
    You can completely disable it in YaST->System->Services Manager or with:
    Code:
    sudo systemctl disable apparmor.service
    Apparently that update caused a problem with apparmor (again).

  6. #6

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    PS: If you don't want to disable Apparmor, just run this to update the Apparmor profile:
    Code:
    sudo logprof
    Choose "Allow" for smb and nmb and save your changes, then Samba should work again.

  7. #7
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    129

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    About the service manager in yast, that my fault......
    I have missed that.....



    Sorry my English is not very good.

    Found this:

    apparmor.service - LSB: AppArmor initialization Loaded: loaded (/etc/init.d/boot.apparmor) Active: active (exited) since Fri 2013-12-20 13:34:54 CET; 25min ago Process: 580 ExecStart=/etc/init.d/boot.apparmor start (code=exited, status=0/SUCCESS)
    Dec 20 13:34:54 linux-gfqx systemd[1]: Starting LSB: AppArmor initialization... Dec 20 13:34:54 linux-gfqx boot.apparmor[580]: Starting AppArmor AppArmor parser error for /etc/apparmor.d/usr.sbin.smbd in /etc/apparmor.d/local/usr.sbin.smbd-shares at line 19: syntax error, unexpected TOK_ID, expecting TOK_MODE Dec 20 13:34:54 linux-gfqx boot.apparmor[580]: /etc/apparmor.d/usr.sbin.smbd failed to load..failed Dec 20 13:34:54 linux-gfqx boot.apparmor[580]: ..done Dec 20 13:34:54 linux-gfqx systemd[1]: Started LSB: AppArmor initialization.


    I disable Apparmor and stop it.

    Thanks all.

  8. #8

    Cool [Solved] Cannot Start Samba after openSUSE 13.1 upgrade

    Looks like it was as simple as apparmor, thanks for the tip , and allowing it via logprof was just what I needed to do. Same note about the runlevel as well but it is in system manager which I had already figured out. Also, had install updates along with dvd during the actual install and double checked afterwards.

    I was able to solve with the following for anyone who is referencing my OP, not sure where the highjack has gone though.

    Code:
    logprof
    You will need to run with superuser rights.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Cannot Start Samba after openSUSE 13.1 upgrade

    Quote Originally Posted by GJElde View Post
    I have the same problem.....
    Don't see samba and nmb at all in the runlevel.
    I think there was an update yesterday, think this it has caused.









    Did you notice we have a dutch openSUSE Launch Party, 27th of december ? Info in the dutch subforums.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Unhappy Re: Cannot Start Samba after openSUSE 13.1 upgrade

    another way to fix this problem is go into

    /var/run and make a folder called samba, then start samba up. The only down side about this is if you restart your computer it wil delete the samba folder.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •