Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Can't authenticate when connecting to wireless router

  1. #1
    Join Date
    Jun 2008
    Location
    Batavia, IL, USA
    Posts
    14

    Default Can't authenticate when connecting to wireless router

    I have a Lenovo G550 laptop which I have been running 12.1, 12.2 and 12.3 x64 on successfully for a couple of years, including using the built-in BCM4312 wifi radio. After performing a clean, new install of 13.1 x64 and installing broadcom-wl with b43-firmware and b43-cutter, I was able to get both NM and ifup to find my router and configure the connection. With ifup, I get no connection and no error message when booting, despite trying connect on hotplug, connect at boot time or connect on cable connection. When I try to connect with NM, I receive an authentication error popup with a prompt to re-enter my WPA/PSK password. I have verified that the password is correct and that my router is indeed configured for WPA/PSK. (My desktop, also running 13.1 x64, connects to the same router without problems when using the identical configuration.) route -n finds no connections. What should I look at? Which error logs will help me?

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Can't authenticate when connecting to wireless router

    On 12/19/2013 12:56 PM, wesenbergj wrote:
    >
    > I have a Lenovo G550 laptop which I have been running 12.1, 12.2 and
    > 12.3 x64 on successfully for a couple of years, including using the
    > built-in BCM4312 wifi radio. After performing a clean, new install of
    > 13.1 x64 and installing broadcom-wl with b43-firmware and b43-cutter, I
    > was able to get both NM and ifup to find my router and configure the
    > connection. With ifup, I get no connection and no error message when
    > booting, despite trying connect on hotplug, connect at boot time or
    > connect on cable connection. When I try to connect with NM, I receive an
    > authentication error popup with a prompt to re-enter my WPA/PSK
    > password. I have verified that the password is correct and that my
    > router is indeed configured for WPA/PSK. (My desktop, also running 13.1
    > x64, connects to the same router without problems when using the
    > identical configuration.) route -n finds no connections. What should I
    > look at? Which error logs will help me?


    Using the NM applet, delete the existing connection and recreate it. That
    usually clears up this problem. The logs, at least for KDE, are found in
    /var/log/NetworkManager and /var/log/wpa_supplicant.log.

    BTW, b43-firmware and b43-cutter have absolutely nothing to do with wl. As wl is
    proprietary closed source, there is little else we will be able to help you
    with. If you are unable to get it to work, I suggest that you remove wl, and get
    rid of the blacklist entries for b43 and ssb.



  3. #3
    Join Date
    Jun 2008
    Location
    Batavia, IL, USA
    Posts
    14

    Default Re: Can't authenticate when connecting to wireless router

    The /var/log/wpa_supplicant.log shows this error when I use the internal BCM4312 radio:

    Code:
    wlp4s0: Trying to associate with 20:10:7a:5c:ce:ff (SSID='SubGenius' freq=2442 MHz)
    wlp4s0: Associated with 20:10:7a:5c:ce:ff
    wlp4s0: Associated with 20:10:7a:5c:ce:ff
    wlp4s0: CTRL-EVENT-DISCONNECTED bssid=20:10:7a:5c:ce:ff reason=0
    wlp4s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    wlp4s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="SubGenius" auth_failures=1 duration=10
    When using a USB RTL8187 radio, I get similar results, but with a different error code:

    Code:
    lp0s29f7u5: SME: Trying to authenticate with 20:10:7a:5c:ce:ff (SSID='SubGenius' freq=2442 MHz)
    wlp0s29f7u5: Trying to associate with 20:10:7a:5c:ce:ff (SSID='SubGenius' freq=2442 MHz)
    wlp0s29f7u5: Associated with 20:10:7a:5c:ce:ff
    wlp0s29f7u5: CTRL-EVENT-DISCONNECTED bssid=20:10:7a:5c:ce:ff reason=15
    wlp0s29f7u5: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    wlp0s29f7u5: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="SubGenius" auth_failures=1 duration=10
    This was in spite of verifying several times that I didn't mistype the password. Since I couldn't find anything in wpa_supplicant documentation to tell me what those reason codes are, I started experimenting with my settings and noticed that NM wasn't automatically capturing a BSSID as expected. I logged into my router (actually a WiMax modem/gateway thingy), wrote the BSSID down and manually entered it in the wireless interface configuration in NM and VIOLA! (sic), it connected. So, I'm scratching my head, trying to figure out why the same OS allows me to connect to the same gateway automatically on my desktop PC but not my laptop. I did notice some similar problems with the latest kernel's wpa_supplicant in some other distros. Could this be a bug?

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Can't authenticate when connecting to wireless router

    On 12/19/2013 11:16 PM, wesenbergj wrote:

    > This was in spite of verifying several times that I didn't mistype the
    > password. Since I couldn't find anything in wpa_supplicant documentation
    > to tell me what those reason codes are, I started experimenting with my
    > settings and noticed that NM wasn't automatically capturing a BSSID as
    > expected. I logged into my router (actually a WiMax modem/gateway
    > thingy), wrote the BSSID down and manually entered it in the wireless
    > interface configuration in NM and VIOLA! (sic), it connected. So, I'm
    > scratching my head, trying to figure out why the same OS allows me to
    > connect to the same gateway automatically on my desktop PC but not my
    > laptop. I did notice some similar problems with the latest kernel's
    > wpa_supplicant in some other distros. Could this be a bug?


    It is not normal that you need to specify the BSSID when entering a network
    connection. My best guess is that when you did the edit to add the BSSID, you
    cleared the condition that was actually causing the problem. What happens if you
    re-edit and remove the BSSID? If the problem returns, then it could be a bug. I
    don't have a WiMax thingy - perhaps there is some unusual interaction with it.


  5. #5
    Join Date
    Jun 2008
    Location
    Batavia, IL, USA
    Posts
    14

    Default Re: Can't authenticate when connecting to wireless router

    First of all, I'll give you a more complete description of my WiMax "thingy". I'm using the former Clearwire, now fully owned by Sprint, as my ISP. My device is called the Clear Hub Express, made by Advance Data Technology Corporation (Hwa Ya). Specs, manuals, etc. are at Support Download | CLEAR

    I rebooted my laptop again today to see if I could repeat the problem and, again, it wouldn't pick up the BSSID. I also tested it with the Samsung V100T Samsung LTE Mobile HotSpot PRO | T-Mobile I just bought today and I had the same problem after setting it up and testing it in Win 7 on the same laptop. I will have an opportunity to test these radios on other wifi networks in a few days.

    Since my desktop has worked flawlessly with 13.1 x64 for a couple of weeks, I borrowed its ASUS USB-N13 RT2800-based radio and tried it on my laptop. One press of the button on its side got it to connect to the Clear Hub Express. It also connects to the V100T - again, only after pressing the button on its side. The other radios don't have a hardware connect button. I've never had to use the button with that radio connected to my desktop.

    I moved the RTL8187 radio, which didn't work on the laptop, back to my desktop and it connected immediately to the Clear Hub. I can post fully expanded hardware lists for both PCs if you like. The one big difference between the two is the laptop has an Intel T4400 dual-core CPU and the desktop contains an AMD Phenom II 955 quad core CPU. Could differences in the wpa_supplicant modules for those processors be the cause?

    I can also supply more detailed information on the Clear Hub Express and VT100T settings if they'll be useful to you.

  6. #6
    Join Date
    Jun 2008
    Location
    Batavia, IL, USA
    Posts
    14

    Default Re: Can't authenticate when connecting to wireless router

    One more question: Is it possible to disable the only the internal laptop radio via software? Every local network shows up twice in NM when I plug a USB radio in. This is a mere convenience. It's just annoying to have to remember which network instance to disable after every boot-up or wake-up.

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Can't authenticate when connecting to wireless router

    On 12/20/2013 10:56 PM, wesenbergj wrote:
    >
    > First of all, I'll give you a more complete description of my WiMax
    > "thingy". I'm using the former Clearwire, now fully owned by Sprint, as
    > my ISP. My device is called the Clear Hub Express, made by Advance Data
    > Technology Corporation (Hwa Ya). Specs, manuals, etc. are at 'Support
    > Download | CLEAR'
    > (http://www.clear.com/support/downloa...ar-hub-express)
    >
    > I rebooted my laptop again today to see if I could repeat the problem
    > and, again, it wouldn't pick up the BSSID. I also tested it with the
    > Samsung V100T 'Samsung LTE Mobile HotSpot PRO | T-Mobile'
    > (http://tinyurl.com/nfcqwau) I just bought today and I had the same
    > problem after setting it up and testing it in Win 7 on the same laptop.
    > I will have an opportunity to test these radios on other wifi networks
    > in a few days.
    >
    > Since my desktop has worked flawlessly with 13.1 x64 for a couple of
    > weeks, I borrowed its ASUS USB-N13 RT2800-based radio and tried it on my
    > laptop. One press of the button on its side got it to connect to the
    > Clear Hub Express. It also connects to the V100T - again, only after
    > pressing the button on its side. The other radios don't have a hardware
    > connect button. I've never had to use the button with that radio
    > connected to my desktop.
    >
    > I moved the RTL8187 radio, which didn't work on the laptop, back to my
    > desktop and it connected immediately to the Clear Hub. I can post fully
    > expanded hardware lists for both PCs if you like. The one big difference
    > between the two is the laptop has an Intel T4400 dual-core CPU and the
    > desktop contains an AMD Phenom II 955 quad core CPU. Could differences
    > in the wpa_supplicant modules for those processors be the cause?


    If both of them are running 64-bit versions, the code is the same. Any
    difference in the instruction sets of the two machines is handles automatically.
    In fact, usere code such as wpa_supplicant is compiled using a general
    instruction set.

    > I can also supply more detailed information on the Clear Hub Express and
    > VT100T settings if they'll be useful to you.


    The button on the side activates WPS. Most Linux drivers do not implement that
    mode used by Windows. It is always safer to know and use the real passphrase,
    not that PIN or the button.




  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Can't authenticate when connecting to wireless router

    On 12/20/2013 11:06 PM, wesenbergj wrote:
    >
    > One more question: Is it possible to disable the only the internal
    > laptop radio via software? Every local network shows up twice in NM when
    > I plug a USB radio in. This is a mere convenience. It's just annoying to
    > have to remember which network instance to disable after every boot-up
    > or wake-up.


    I do not find any difficulty in sorting out which entry belongs to which
    interface. Launch the applet and click on the interface entry. That will show
    only the SSIDs seen by that device and the driver it is using.

    If you really want to keep a driver from loading, 'man 5 modprobe.conf'. In
    particular, look at the section on blacklist.


  9. #9
    Join Date
    Jun 2008
    Location
    Batavia, IL, USA
    Posts
    14

    Default Re: Can't authenticate when connecting to wireless router

    For reasons totally unrelated to this thread, I installed a new HD in my laptop and performed a clean installation of 13.1 x64. Now, none of my three wifi radios (internal BCM4312, RT2800USB, or RTL8187USB) will authenticate when trying to connect with either NM or ifup. I'm running kernel 3.11.10-7.1 with no pending updates. As before, wpa_supplicant.log shows this recurring error regardless of which radio I use:

    Code:
    wlp4s0: CTRL-EVENT-DISCONNECTED bssid=20:10:7a:5c:ce:ff reason=0
    wlp4s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    wlp4s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="SubGenius" auth_failures=1 duration=10
    As before, both USB radios connect immediately and automatically on my desktop, which is running the same kernel (minus the Packman b43 module).

    Does anybody care to take a whack at this? Or can somebody refer me to a different forum?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,337
    Blog Entries
    15

    Default Re: Can't authenticate when connecting to wireless router

    On Sun 23 Feb 2014 01:36:01 AM CST, wesenbergj wrote:


    For reasons totally unrelated to this thread, I installed a new HD in my
    laptop and performed a clean installation of 13.1 x64. Now, none of my
    three wifi radios (internal BCM4312, RT2800USB, or RTL8187USB) will
    authenticate when trying to connect with either NM or ifup. I'm running
    kernel 3.11.10-7.1 with no pending updates. As before,
    wpa_supplicant.log shows this recurring error regardless of which radio
    I use:


    Code:
    --------------------
    wlp4s0: CTRL-EVENT-DISCONNECTED bssid=20:10:7a:5c:ce:ff reason=0
    wlp4s0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
    wlp4s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="SubGenius"
    auth_failures=1 duration=10 --------------------


    As before, both USB radios connect immediately and automatically on my
    desktop, which is running the same kernel (minus the Packman b43
    module).

    Does anybody care to take a whack at this? Or can somebody refer me to a
    different forum?


    Hi
    I would say either the password your using is incorrect or the
    authentication method, eg AES TKIP etc. Check they match on the
    wireless router.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •