Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Flash player update dependency problem

  1. #1

    Default Flash player update dependency problem

    I received an update notice for flash player, but the update fails because it needs kdebase4-runtime <= 4.11.97. As far as I can tell, this package is not in the repositories.

  2. #2

    Default Re: Flash player update dependency problem

    I have the same problem, oS 13.1 x64, KDE 4.11.3.

    Full error is:
    Code:
    nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-11.2.202.332-18.1.x86_64
    Rgds, Jon

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: Flash player update dependency problem

    Have a look at your posts, who is posting correct output, they're opposites.
    And, I'd love to see output of
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Mar 2011
    Location
    Norway
    Posts
    77

    Default Re: Flash player update dependency problem

    The error message in the first post has a tiny error that is very significant, the correct error message is in the second post. I get this when running updates too.
    Code:
    nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-11.2.202.332-18.1.i586
    These are my configured repositories at the moment:
    Code:
    :~> zypper repos -pu
    # | Alias                     | Name                               | Enabled | Refresh | Priority | URI                                                            
    --+---------------------------+------------------------------------+---------+---------+----------+----------------------------------------------------------------
    1 | repo-debug                | openSUSE-13.1-Debug                | No      | No      |   99     | http://download.opensuse.org/debug/distribution/13.1/repo/oss/ 
    2 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | No      |   99     | http://download.opensuse.org/debug/update/13.1/                
    3 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | No      |   99     | http://download.opensuse.org/debug/update/13.1-non-oss/        
    4 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/non-oss/   
    5 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | http://download.opensuse.org/distribution/13.1/repo/oss/       
    6 | repo-packman-essentials   | openSUSE-13.1-Packman-Essentials   | Yes     | Yes     |   99     | http://packman.inode.at/suse/openSUSE_13.1/Essentials/         
    7 | repo-source               | openSUSE-13.1-Source               | No      | No      |   99     | http://download.opensuse.org/source/distribution/13.1/repo/oss/
    8 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1/                      
    9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | http://download.opensuse.org/update/13.1-non-oss/
    The output of 'zypper info kdebase4-runtime'
    Code:
    Information for package kdebase4-runtime:
    -----------------------------------------
    Repository: openSUSE-13.1-Update
    Name: kdebase4-runtime
    Version: 4.11.3-50.8
    Arch: i586
    Vendor: openSUSE
    Installed: Yes
    Status: up-to-date
    Installed Size: 19.9 MiB
    Summary: The KDE Runtime Components
    Description: 
    This package contains all run-time dependencies of KDE applications.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,981

    Default AW: Re: Flash player update dependency problem

    nothing provides kdebase4-runtime >= 4.11.97
    This package isn´t anymore in the KDE4.12 Repo.
    Do a
    Code:
    zypper dup --from "KDE4.12-Repo"
    "KDE4.12-Repo" has to be replaced.

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,981

    Default AW: Re: Flash player update dependency problem

    You have no KDE4.12 -Repo and therefore my last Post is unnecessary.

  7. #7

    Default Re: Flash player update dependency problem


  8. #8

    Default Re: Flash player update dependency problem

    Sorry, my post contained a typo. The error is the same as the one reported by 6520302.

    Code:
     nothing provides kdebase4-runtime >= 4.11.97 needed by flash-player-kde4-11.2.202.332-18.1.x86_64

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Flash player update dependency problem

    You can actually delete flash-player-kde4
    Without any harmful effects
    This will resolve your conflict for now.
    I don't know if anyone actually uses the flash config anyway
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Flash player update dependency problem

    Quote Originally Posted by caf4926 View Post
    You can actually delete flash-player-kde4
    Without any harmful effects
    This will resolve your conflict for now.
    I don't know if anyone actually uses the flash config anyway
    A major credit card company uses Flash Player with their virtual card option.
    When you say "flash config" do you mean the settings in flash player or something else?
    Will flash player still function after removing flash-player-kde4?

    Thanks, jon

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •