Results 1 to 6 of 6

Thread: HDMI out not working properly in 13.1

  1. #1

    Default HDMI out not working properly in 13.1

    I'm trying to use HDMI-out to show my laptop screen on both my laptop and the TV screen. I get the following issues:

    * Sometimes it's just black on the laptop

    * If I go into Configure-Desktop->Display & Monitor, even If I drag the TV's "box" on top of the computer box, one of the displays is always messed up. Either the TV shows only a zoomed in part of the desktop, or the laptop does this.

    I've never been able to get them to both show correctly at the same time. What do I need to do?

    openSUSE 13.1 (64bit)
    Linux 3.11.6-4
    KDE 4.11.3
    Samsung Series 9 NP900x4C

    Both the laptop and the HDMI screen are 16x9 ratios.

  2. #2

    Default Re: HDMI out not working properly in 13.1

    More info:

    I notice it no longer has "Size & Orientation". This "tab" doesn't exist! Where did that go?

    Also, while both are 16x9, the laptop is 1600x900 and the TV is 1920x1080. And there's no way to stretch the laptop in the configuration GUI.

    This post: https://www.kubuntuforums.net/showth...ystem-settings seems to say that this functionality is no longer in kscreen but is in krandr. However, when I try to install krandr, I get conflicts, of which the only resolution is to uninstall kscreen, kdebase4-workspace, plasma-addons. That seems like overkill. Is there no way to set the screen sizes?

  3. #3

    Default Re: HDMI out not working properly in 13.1

    Here's what it looks like:



    When I click the box with the green arrows, it only gives me sizes that never intersect between the two displays. So their ratio is the same but one screen is always missing some of the desktop.

  4. #4
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: HDMI out not working properly in 13.1

    On 12/18/2013 08:26 PM, 6tr6tr wrote:
    >
    > I'm trying to use HDMI-out to show my laptop screen on both my laptop
    > and the TV screen. I get the following issues:
    >
    > * Sometimes it's just black on the laptop
    >
    > * If I go into Configure-Desktop->Display & Monitor, even If I drag the
    > TV's "box" on top of the computer box, one of the displays is always
    > messed up. Either the TV shows only a zoomed in part of the desktop, or
    > the laptop does this.
    >


    Just to clarify, when you say "drag the TV's box on top of the laptops
    box" do you mean like this? http://paste.opensuse.org/view/raw/85874742

    If you mean the way you have shown in the screenshot you posted above
    then of course parts of the screen will be cut off since you are only
    sharing part of the screens. If you cant find a resolution for them to
    share then you will have to force it in xorg.

    I do find it strange that you cant find one common resolution between
    the two displays though.

    --
    Was I helpful? Click that little star so that I can brag about it to my
    invisible friends
    Bring the Penguins Back! https://features.opensuse.org/316767

  5. #5

    Default Re: HDMI out not working properly in 13.1

    Quote Originally Posted by alanbortu View Post
    On 12/18/2013 08:26 PM, 6tr6tr wrote:
    >
    > I'm trying to use HDMI-out to show my laptop screen on both my laptop
    > and the TV screen. I get the following issues:
    >
    > * Sometimes it's just black on the laptop
    >
    > * If I go into Configure-Desktop->Display & Monitor, even If I drag the
    > TV's "box" on top of the computer box, one of the displays is always
    > messed up. Either the TV shows only a zoomed in part of the desktop, or
    > the laptop does this.
    >


    Just to clarify, when you say "drag the TV's box on top of the laptops
    box" do you mean like this? http://paste.opensuse.org/view/raw/85874742
    No, I mean like the picture I included. If I do what you show, then the laptop shows the taskbar and desktop but no windows and the TV shows only the application windows. It's a weird amalgmation where I have to mouse off the TV screen to get to the taskbar. I'm looking for a mirroring effect.

    Quote Originally Posted by alanbortu View Post

    If you mean the way you have shown in the screenshot you posted above
    then of course parts of the screen will be cut off since you are only
    sharing part of the screens. If you cant find a resolution for them to
    share then you will have to force it in xorg.

    I do find it strange that you cant find one common resolution between
    the two displays though.
    The options I get are:

    LAPTOP: 1600x900, 1024x768, 800x600, 640x480

    TV: 1920x1080, 1680x1050, 1600x1200, 1440x900, 1440x480, 1280x1024...1024x768, 800x600

    So there is overlap but only in the very low resolution, non-HD realm. That's not a good solution.

    Are there any other options?

  6. #6

    Default Re: HDMI out not working properly in 13.1

    What are you ultimately trying to accomplish? Cloned screens or extend the desktop?

    If you want to extend the desktop then you would do what alanbortu suggested. If you are trying to get a 1:1 clone that is not possible, since the displays have different native resolutions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •