Results 1 to 6 of 6

Thread: Missing rpcbind from system services in yast2 on Opensuse 13.1

  1. #1
    Join Date
    Feb 2012
    Location
    Copenhagen
    Posts
    15

    Default Missing rpcbind from system services in yast2 on Opensuse 13.1

    I'm running OpenSUSE 13.1 X 64. and have problems using Legacy NFS without the rpcbind service. It's gone from the yast2 system services.
    i can manually start the rpc service with:

    systemctl enable rpcbind
    systemctl start rpcbind

    and then start the nfs service in the yast2 system services

    but it would really be great to be able to start the rpcbind service in the runlevel editor again as in the previous versions of OpenSUSE.






  2. #2
    Join Date
    Sep 2012
    Posts
    5,203

    Default Re: Missing rpcbind from system services in yast2 on Opensuse 13.1

    In 13.1 rpcbind is using socket activation - i.e. it is started as soon as first request is seen. To enable listening on socket use
    Code:
    systemctl enable rpcbind.socket
    systemctl start rpcbind.socket
    "systemctl enable rpcbind.service" (that you did - .service is default) may also enable socket unit as well, that I do not really remember.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Missing rpcbind from system services in yast2 on Opensuse 13.1

    On 2013-12-18 14:46, arvidjaar wrote:
    >
    > In 13.1 rpcbind is using socket activation - i.e. it is started as soon
    > as first request is seen. To enable listening on socket use
    > Code:
    > --------------------
    > systemctl enable rpcbind.socket
    > systemctl start rpcbind.socket
    > --------------------
    >
    >
    > "systemctl enable rpcbind.service" (that you did - .service is default)
    > may also enable socket unit as well, that I do not really remember.


    It was automatically enabled here after configuring NFS in yast
    (client), and it is running (I import a share):

    Code:
    
    > Eleanor4:~ # systemctl status rpcbind.socket
    > rpcbind.socket - RPCbind Server Activation Socket
    >    Loaded: loaded (/usr/lib/systemd/system/rpcbind.socket; enabled)
    >    Active: active (running) since Sun 2013-12-15 12:50:29 CET; 3 days ago
    >    Listen: /run/rpcbind.sock (Stream)
    >            0.0.0.0:111 (Stream)
    >            0.0.0.0:111 (Datagram)
    >            [::]:111 (Stream)
    >            [::]:111 (Datagram)
    >
    > Dec 15 12:50:29 Eleanor4 systemd[1]: Starting RPCbind Server Activation Socket.
    > Dec 15 12:50:29 Eleanor4 systemd[1]: Listening on RPCbind Server Activation Socket.
    > Eleanor4:~ #
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,781
    Blog Entries
    3

    Default Re: Missing rpcbind from system services in yast2 on Opensuse 13.1

    Quote Originally Posted by timfolsen View Post
    but it would really be great to be able to start the rpcbind service in the runlevel editor again as in the previous versions of OpenSUSE.
    Yast --> Services Manager

    That seems to be the new name of the old runlevel editor.

    I had no trouble finding "rpcbind" there when I setup NFS. And, on a recheck, I still have no trouble finding "rpcbind".
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Feb 2012
    Location
    Copenhagen
    Posts
    15

    Default Re: Missing rpcbind from system services in yast2 on Opensuse 13.1

    Thank you for your replies. Found it. I Completely overlooked the Services manager. It might be a bit confusing with 2 possible entries to start/stop services in yast2, and with one of them missing a few basic services.

    Cheers
    - Tim

  6. #6

    Default Re: Missing rpcbind from system services in yast2 on Opensuse 13.1

    Quote Originally Posted by timfolsen View Post
    It might be a bit confusing with 2 possible entries to start/stop services in yast2, and with one of them missing a few basic services.
    Well, the old runlevel editor is not installed by default anymore on 13.1.
    But it is still included in the distribution, so you still have it after an upgrade.

    And AFAICT it should list all available services, but according to my experience with earlier openSUSE versions (12.3 in particular), it might have problems to enable/disable certain services. That's one of the reasons it got replaced by the new Services Manager.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •