Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: What's wrong with gnome network manager?!!!

  1. #1

    Default What's wrong with gnome network manager?!!!

    Hi everyone.
    One simple question
    What the hell is going with gnome?!
    I 've installed opensuse 13.1 with gnome Desktop.
    There 's no option for disconnecting from Wifi Networks in network manager.
    Please don't tell sth 's like : disable the adapter or try the forget button in the options.

    No button or menu for disconnecting?

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: What's wrong with gnome network manager?!!!

    phenomx64 wrote:
    > Hi everyone.
    > One simple question
    > What the hell is going with gnome?!
    > I 've installed opensuse 13.1 with gnome Desktop.
    > There 's no option for disconnecting from Wifi Networks in network
    > manager.
    > Please don't tell sth 's like : disable the adapter or try the forget
    > button in the options.
    >
    > No button or menu for disconnecting?

    you can stop network service using command
    sudo systemctl stop network.service

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    Where are my penguins :- https://features.opensuse.org/316767

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: What's wrong with gnome network manager?!!!

    On Tue, 17 Dec 2013 22:06:01 +0000, phenomx64 wrote:

    > Hi everyone.
    > One simple question What the hell is going with gnome?!
    > I 've installed opensuse 13.1 with gnome Desktop.
    > There 's no option for disconnecting from Wifi Networks in network
    > manager.


    Make sure you've updated to gnome 3.10.2 (it's in the update channel).

    On my laptop, if I expand the Wi-Fi item in the menu (upper right
    corner), I have the following options:

    Select Network
    Turn Off
    Wi-Fi Settings

    "Turn Off" does what you're looking for. You do need to make sure nm-
    applet is running.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4
    Join Date
    Sep 2008
    Location
    Tyrnv, Finnland
    Posts
    12

    Default Re: What's wrong with gnome network manager?!!!

    I also have opensuse 13.1 with gnome Desktop. But in my case the problem is that I can not get connected. Although everything else seems to work. The system recognices the usb-chip and gives a list of all of the wifi-nets residing in the air of my apartment. And the one I have connected other devices for ex. my HTC One Mini phone.

    I have used Yast and its
    Network Settings. Wlan Adapter RTL818 is recognized and its MAC:, BusID: ja name enp0s2flu5 are shown and the IP-addres is found by DHCP. Clicking Configure and OK
    everything necessary seems to happen.

    But even after restart no netconnection. To test it I have started Firefox and it can not find the Net.

    Probably I should now use the terminal. But it was long ago I tried
    ifconfig etc. and I do not remember them yet, so please some help

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: What's wrong with gnome network manager?!!!

    If you want to use the network manager, you have to first configure the network services to use it.

    Navigate to

    YaST >> Network Devices >> Network Settings >> Global Options, set 'User Controlled with NetworkManager'

    Once the Gnome NM is running, you can proceed to configuring your wireless there.

  6. #6
    Join Date
    Sep 2008
    Location
    Tyrnv, Finnland
    Posts
    12

    Default Re: What's wrong with gnome network manager?!!!

    And now, the wifi started to work. It's a Christmas Miracle

    Without doing anything new, I went to the computer and started openSUSE 13.1 Gnome and I even was able to uppdate the system!

    By the way - Windows7 in the same computer has worked well all the time ...

  7. #7

    Default Re: What's wrong with gnome network manager?!!!

    Everybody please, read my post first.
    Don't tell sth like install or enable gnome network manager. I had installed it so!
    Dont tell sth like turn off the adapter.
    I don't want to turn off my wifi!
    I just want to disconnect from Associated wireless AP. Like older versions of gnome network manager.
    No way?!?!
    It's a shame for new gnome network manager.

  8. #8
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: What's wrong with gnome network manager?!!!

    On 12/24/2013 02:16 PM, phenomx64 wrote:
    >
    > Everybody please, read my post first.
    > Don't tell sth like install or enable gnome network manager. I had
    > installed it so!
    > Dont tell sth like turn off the adapter.
    > I don't want to turn off my wifi!
    > I just want to disconnect from Associated wireless AP. Like older
    > versions of gnome network manager.
    > No way?!?!
    > It's a shame for new gnome network manager.


    Did you test during the -MSX, -Beta, or -RCX releases? If so, why didn't you
    catch this problem. If you didn't test, why not? This is a community-based
    distro. That means we all are expected to do our part. If one finds and reports
    a bug, but nothing happens, then you can get irate, but only then.

    I am a KDE user, and its applet does what you want.

    If there is not a bug already filed, then do so. Otherwise, the problem will
    never be fixed.

    As a workaround, install the rfkill package. Then to shutdown the radio, you can
    issue the command 'sudo /usr/sbin/rfkill block all'. To restore, then use 'sudo
    /usr/sbin/rfkill unblock all'.



  9. #9
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: What's wrong with gnome network manager?!!!

    On Tue, 24 Dec 2013 20:16:01 +0000, phenomx64 wrote:

    > Everybody please, read my post first.
    > Don't tell sth like install or enable gnome network manager. I had
    > installed it so!
    > Dont tell sth like turn off the adapter.
    > I don't want to turn off my wifi!
    > I just want to disconnect from Associated wireless AP. Like older
    > versions of gnome network manager.
    > No way?!?!
    > It's a shame for new gnome network manager.


    Did you try my suggestion, and make sure you updated to the latest GNOME
    in the update channel? That version works fine here, on GNOME 3, on
    openSUSE 13.1.

    Instead of saying things like "do not tell ... like" - try following the
    suggestions that are made. And please be polite when asking questions -
    or you might find people disinclined to help you. We do expect people to
    be courteous here (both asking and responding).

    As Larry says, we all do testing, including you - if you find a bug,
    report it so it can be fixed. Just complaining about it isn't going to
    get it fixed.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  10. #10

    Default Re: What's wrong with gnome network manager?!!!

    Quote Originally Posted by lwfinger View Post
    On 12/24/2013 02:16 PM, phenomx64 wrote:
    >
    > Everybody please, read my post first.
    > Don't tell sth like install or enable gnome network manager. I had
    > installed it so!
    > Dont tell sth like turn off the adapter.
    > I don't want to turn off my wifi!
    > I just want to disconnect from Associated wireless AP. Like older
    > versions of gnome network manager.
    > No way?!?!
    > It's a shame for new gnome network manager.


    Did you test during the -MSX, -Beta, or -RCX releases? If so, why didn't you
    catch this problem. If you didn't test, why not? This is a community-based
    distro. That means we all are expected to do our part. If one finds and reports
    a bug, but nothing happens, then you can get irate, but only then.

    I am a KDE user, and its applet does what you want.

    If there is not a bug already filed, then do so. Otherwise, the problem will
    never be fixed.

    As a workaround, install the rfkill package. Then to shutdown the radio, you can
    issue the command 'sudo /usr/sbin/rfkill block all'. To restore, then use 'sudo
    /usr/sbin/rfkill unblock all'.

    Hi sir. You are right. I'm guilty, because i never had participate in beta or RC releases and test them.I'm an Opensuse fan, really love it. tried every famous distro and found it's the best. You are right. It's a community distro and we must make it,but I was wondering how a programmer can not make think of these. Nearly every process nearly have the reverse. Install,uninstall, turn off,turn on ,delete, undelete and so on. And in this case if you connect to a AP, you must have a little option to DISCONNECT from it. Not to shut down the radio. How did the nm-applet coders forget to have this.It's somehow funny. I didn't report this because I think it's a feature not a bug!
    I just wanted a simple disconnect option like the red cross in KDE nm-applet, disconnect button in M$ windows.
    I will be glad to report the bugs. but in most cases when I report them, then the team will neglect it or maybe because of that I'm not a native english speaker I can't express my self well to them.
    Although some bugs have a long story and never solved , like the hibernate button for gnome
    Anyway please tell me where to report this bug? novel bugzilla or nm-applet?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •