Results 1 to 3 of 3

Thread: Problems setting up touchscreen in openSUSE-13.1 (Atmel maxTouch Digitizer)

  1. #1

    Default Problems setting up touchscreen in openSUSE-13.1 (Atmel maxTouch Digitizer)

    Hi,

    I installed openSUSE-13.1 (64 bit) on Dell XPS 12 Duo. All fine, expect that the touchscreen does not work.
    I have the impression that udev does not reserve an input device for it...

    - lsmod does not list the evdev module.
    - I can load it manually, but that does not help.

    At Ubuntu sul Dell XPS 12. Touchscreen e Kernel Sputnik - Notebook Italia is an Ubuntu System that works (Site is in Italy). In the Video (position 3:59) you can see that xinput has an Entry "Atmel Atmel maxTouch Digitizer".

    my xinput is the same, but without touchscreen entry :-(
    Code:
    ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]
        ↳ Power Button                              id=8    [slave  keyboard (3)]
        ↳ Integrated Webcam                         id=9    [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
        ↳ Dell WMI hotkeys                          id=12   [slave  keyboard (3)]
    lspci lsusb shows not a touchscreen device

    Code:
    # lspci
    00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
    00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
    00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
    00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
    00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
    00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
    00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
    06:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)
    
    # lsusb
    Bus 001 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 003: ID 8087:07dc Intel Corp. 
    Bus 002 Device 004: ID 0bda:5716 Realtek Semiconductor Corp. 
    Bus 002 Device 005: ID 8087:09fa Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    modprobe atmel_mxt_ts loads the module but nothing happens
    the same with modprobe evdev
    no touchscreen input device /proc/bus/input/devices

    How do I convince the kernel to load the module and to use it?

    Thanks for any hints
    Volker


    PS: at Windows 8 touchscreen works fine - but I am a linuxer and won't use win8!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,721

    Default Re: Problems setting up touchscreen in openSUSE-13.1 (Atmel maxTouch Digitizer)

    Will be moved to hardware aand is CLOSED for the moment.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,721

    Default Re: Problems setting up touchscreen in openSUSE-13.1 (Atmel maxTouch Digitizer)

    Quote Originally Posted by hcvv View Post
    Will be moved to hardware aand is CLOSED for the moment.
    Moved from Laptop and open again.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •