Results 1 to 3 of 3

Thread: Clarifications on KMS and Kernel [Intel celeron 1005M]

  1. #1

    Lightbulb Clarifications on KMS and Kernel [Intel celeron 1005M]

    Hi there!
    I hope this is the right section, if not, my apologies for the misunderstanding!

    I successfully installed openSUSE 13.1 via DVD on my laptop, which has an Intel Celeron 1005M with Intel graphics. I was able to do so, only by pressing F3 and disabling KMS at the beginning of the installation. Now the system is installed and works, but the KDE animations are sort of slow, while on another machine with a tiny AMD E-450 and same 4GB of RAM (installed with KMS enabled) animations seem faster and smoother. In addition to that, brightness keys aren't working, nor is xbacklight, and there's no brightness bar in the energy applet. I'm guessing it might a problem related to KMS being disabled, but I'm not sure.
    I'm not new to the Linux world, but I'm definitely not an experienced user and it's the first time I face such a problem. Googling on the net I sort of understood what KMS is, and I got it might be a kernel problem, not distro specific (am I right?). I tried Mint 16 with kernel 3.11 and I had the same situation, the only workaround was booting in "compatibility mode" (which I guess disables KMS).

    Now the point is: what should I do? Is it really related only to the kernel? Should I submit a bug or something? I still have not tried newer kernel versions like 3.12, does anyone know if it might solve this annoying problem?

    Thanks a lot guys!

  2. #2

    Default Re: Clarifications on KMS and Kernel [Intel celeron 1005M]

    Quote Originally Posted by Codalunga View Post
    I successfully installed openSUSE 13.1 via DVD on my laptop, which has an Intel Celeron 1005M with Intel graphics. I was able to do so, only by pressing F3 and disabling KMS at the beginning of the installation. Now the system is installed and works, but the KDE animations are sort of slow, while on another machine with a tiny AMD E-450 and same 4GB of RAM (installed with KMS enabled) animations seem faster and smoother. In addition to that, brightness keys aren't working, nor is xbacklight, and there's no brightness bar in the energy applet. I'm guessing it might a problem related to KMS being disabled, but I'm not sure.
    I'm not new to the Linux world, but I'm definitely not an experienced user and it's the first time I face such a problem. Googling on the net I sort of understood what KMS is, and I got it might be a kernel problem, not distro specific (am I right?). I tried Mint 16 with kernel 3.11 and I had the same situation, the only workaround was booting in "compatibility mode" (which I guess disables KMS).
    The intel driver only works _with_ KMS, so by disabling KMS you are in fact disabling the use of the intel driver.
    You are now using either fbdev or vesa, which of course have no idea about screen brightness, 3D, hardware acceleration, and so on...

    Now the point is: what should I do? Is it really related only to the kernel? Should I submit a bug or something? I still have not tried newer kernel versions like 3.12, does anyone know if it might solve this annoying problem?
    There have been two official updates to the intel driver for 13.1 already, which fix a lot of bugs/crashes.

    So I would suggest to bring the system is up-to-date if necessary ("sudo zypper up", YaST->Online Update, or your desktops update applet).
    And then try to remove "nomodeset" from the boot options (YaST->System->Boot Loader->Boot Loader Options).
    Chances are that your system is working correctly afterwards...

  3. #3

    Default Re: Clarifications on KMS and Kernel [Intel celeron 1005M]

    Man it worked! Now animations look great and there's the brightness bar in the battery applet! I can change the brightness from there, but not from keyboard yet. Default keys are assigned to the KDE daemon, but nothing changes. The command
    Code:
    xbacklight -set 50
    works, but creating new shortcuts with
    Code:
    xbacklight -dec 10
    or
    Code:
    xbacklight -inc 10
    doesn't. That's strange. Anyway, thanks again for your help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •