Results 1 to 6 of 6

Thread: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

  1. #1

    Default Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    I have a new HP Z230 desktop system featuring a Xeon E3-1245 v3 CPU at 3.4 GHz with integrated P4600 graphics.
    A fresh install of openSuSE 13.1 went smoothly, thank you all very much for that.
    I am using 1280x1024 video with a single Planar PL1911M monitor. KInfocenter reports the OpenGL driver as
    Intel Open Source Technology Center, Mesa DRI Intel(R) Haswell Server, version 3.0 Mesa 9.2.3, kernel
    module i915.

    I have installed argyllcms 1.6.0-2.1.3 Argyll color management and installed a display
    calibration file using dispcalGUI and colormunki Smile which may or may not be relevant.

    I have installed a Windows XP VM Guest using the KVM emulated cirrus video. With the default setting of
    KDE Desktop Effects enabled, I am able to crash or freeze the X-server with a mean time to fail of
    around 10 minutes, by moving windows, resizing windows, or scrolling windows in the VM guest VNC
    window. It does not matter if the VNC window is fullscreen maximized 1280x1024x16, or smaller for
    the VM resolution of 1024x768x24bit. Symptoms of crashing include Kwin unresponsive at 100% CPU,
    /var/log/messages ala
    2013-12-12T09:01:34.628056-06:00 zip kdm[4235]: X server for display :0 terminated unexpectedly,
    and messages of crashes or overrun event queues in the /var/log/Xorg0.log log similar to:
    Code:
    (EE) Backtrace:
    (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x3d) [0x585acd]
    (EE) 1: /usr/bin/Xorg (mieqEnqueue+0x22b) [0x5679fb]
    (EE) 2: /usr/bin/Xorg (QueuePointerEvents+0x52) [0x4534a2]
    (EE) 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f593d1ff000+0x5b0d) [0x7f593d204b0d]
    (EE) 4: /usr/bin/Xorg (0x400000+0x797b8) [0x4797b8]
    (EE) 5: /usr/bin/Xorg (0x400000+0xa1e40) [0x4a1e40]
    (EE) 6: /lib64/libpthread.so.0 (0x7f594578c000+0xf9f0) [0x7f594579b9f0]
    (EE) 7: /lib64/libc.so.6 (ioctl+0x7) [0x7f59446be1e7]
    (EE) 8: /usr/lib64/libdrm.so.2 (drmIoctl+0x34) [0x7f5945583d64]
    (EE) 9: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x2708f) [0x7f59405f508f]
    (EE) 10: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x9869f) [0x7f594066669f]
    (EE) 11: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 12: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 13: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 14: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 15: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    ...  (identical lines numbered consecutively)
    (EE) 59: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 60: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 61: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 62: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE) 63: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f59405ce000+0x98774) [0x7f5940666774]
    (EE)
    (EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
    (EE) [mi] mieq is *NOT* the cause.  It is a victim.
    The above would appear to be recursion gone wild.

    If KDE Desktop Effects are disabled, then the system is stable. (App) (Configure Desktop) (Desktop Effects)
    uncheck Enable desktop effects at startup.

    I have software skills and am willing to install debug versions or help with bug resolution.

    The system is up-to-date with Open SUSE 13.1 updates.

    Regards,
    Ed Hume
    Austin, TX USA

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,313

    Default Re: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    There was a new Intel driver that fixed some problem with the one shipped. Did you install the updates?

    I know nothing about KVM or the rather exotic hardware you are running so that is the best I can do

  3. #3

    Default Re: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    Yes, the problem exists as described with the original install, and then after the update of the video driver came through a few days ago.

  4. #4

    Default Re: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    Quote Originally Posted by ed_hume View Post
    Yes, the problem exists as described with the original install, and then after the update of the video driver came through a few days ago.
    Maybe try the packages from here:
    http://forums.opensuse.org/english/g...ml#post2604951

    Or try to switch to UXA acceleration:
    https://forums.opensuse.org/english/...ml#post2604892

  5. #5

    Default Re: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    Quote Originally Posted by wolfi323 View Post
    The first link to sumski's patched driver, quoted above, seems to have fixed the problem. Thank you! I hope his fix gets merged into the head revision.

  6. #6

    Default Re: Intel Haswell P4600 Graphics Unstable with default OpenSUSE 13.1 desktop effects install

    Quote Originally Posted by ed_hume View Post
    The first link to sumski's patched driver, quoted above, seems to have fixed the problem. Thank you! I hope his fix gets merged into the head revision.
    This updated driver has been released as official online update for 13.1 yesterday, so you could switch back to the driver from the standard update repo then.

    And the fix is actually taken from the upstream git repo, so it _is_ already in the "head revision"...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •