Results 1 to 9 of 9

Thread: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

  1. #1

    Default KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Hello everybody,

    I have Acer E series laptop and I installed OpenSuse 13.1 with KDE wm recently.
    I also have a monitor which I connect using HDMI to the laptop and 90% of all time I use That monitor and don't even touch my laptop.

    The problem I encountered is: In the System Settings -> Multimedia -> Audio and Video Settings on the Tab Audio hardware setup The default hardware profile is always HDMI audio. Even when I change it back to Analog Stereo, after reboot it is still HDMI.
    On the Device Preference Tab of the same window The first Preference for ALL entries is Analog Stereo.

    This really annoys me, because each time I start my computer I need to go to Settings and change Audio hardware Profile back to Analog Stereo, to be able to Listen to Music in my Headphones.

    Does Anybody know how to make Analog Stereo default permanently?

    Hope for soon responce)

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,926
    Blog Entries
    14

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Have a look in Yast - Hardware - Sound. You may see 2 devices, where HDMI will be the primary card. In the lower right corner of the module there's a button that allows you to set the laptop's internal audio card/chip as the primary sound card. That should solve it.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Quote Originally Posted by Knurpht View Post
    Have a look in Yast - Hardware - Sound. You may see 2 devices, where HDMI will be the primary card. In the lower right corner of the module there's a button that allows you to set the laptop's internal audio card/chip as the primary sound card. That should solve it.
    Thanks for Response, but unfortunately I have only 1 device in Yast - hardware - Sound, so Nothing Changed when I set that device to be primary

  4. #4

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Quote Originally Posted by domiurg9 View Post
    Thanks for Response, but unfortunately I have only 1 device in Yast - hardware - Sound, so Nothing Changed when I set that device to be primary
    I have this problem too. Did you solve it?
    Thanks.

  5. #5

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    I have no Idea still how to do it(
    I'm forced to do it manually each time I login((

  6. #6
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Hello,

    I'm resurrecting this thread. Has there been any resolution to this issue? It is beyond annoying.

    Thanks!

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Quote Originally Posted by mikejazzfan View Post
    I'm resurrecting this thread. Has there been any resolution to this issue? It is beyond annoying.
    Can you provide more information such that a solid recommendation can be given ? To do so, with your PC connected to the internet, please in a konsole/xterm as a regular user send the command:
    Code:
    /usr/sbin/alsa-info.sh
    and do NOT update if asked to update. Select the SHARE/UPLOAD option. Let the script run to completion. Then look inside the konsole/xterm and you will be provided with a web-address/URL where the script collection of your PC's audio configuraiton was uploaded. Please post the URL/web address location here. Maybe with that information I can provide you a solid recommendation to fix this.

    I am currently on the road on vacation, and only checking the forum in the evenings, if the hotel where I stay has internet access. So my reply may be a bit slow in coming.

  8. #8
    Join Date
    Jul 2014
    Location
    Round Rock, TX
    Posts
    76

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Thanks! Here is the link: http://www.alsa-project.org/db/?f=43...4b59c15c2e5685

    I have my "main" monitor (Dell S2440LB) connected to the computer via HDMI. I've attempted to plug the speakers into the monitor but that doesn't resolve. My second monitor is connected via standard DB15. I hope this helps!

    Thanks,
    Mike

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,138
    Blog Entries
    40

    Default Re: KDE Audio Settings, Change default Profile from HDMI to Analog Stereo

    Quote Originally Posted by mikejazzfan View Post
    Thanks! Here is the link: http://www.alsa-project.org/db/?f=43...4b59c15c2e5685

    I have my "main" monitor (Dell S2440LB) connected to the computer via HDMI. I've attempted to plug the speakers into the monitor but that doesn't resolve. My second monitor is connected via standard DB15. I hope this helps!
    Thanks. That clarifies. Only one audio device and only one alsa sound module running.
    Code:
    APLAY
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: CX20641 Analog [CX20641 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Sound devices are hw:0,0 (analog audio) and hw:0,3 (HDMI).

    First, try to see if it is an incorrectly saved setting/mixer state. I've read that there are a few layers saving/restoring the mixer state, alsactl invoked via udev, PulseAudio, and kmix.

    A possible fix would be to clean up the config. Go to runlevel 3 once, login as root, kill all pending PA processes. Then adjust via "alsamixer -c0", and run "alsactl store". This resets the mixer restored via alsactl.

    For Pulse Audio, remove ~/.pulse and ~/.config/pulse directories (if exist).

    If the above does not help, try installing 'pavucontrol' (pulse audio volume control) and use it to assign each sound application to a specific audio device/output. There are some blog entries on pulse audio volume control here:


    Please note that pulse audio allows assignment of output from each multi-media application on an individual basis. It will then remember the assignment for later restarts. Note the application needs to be running, playing a media file, for the initial setup.
    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •