Results 1 to 2 of 2

Thread: 12.3->13.1 x86 under VMware hangs

  1. #1

    Default 12.3->13.1 x86 under VMware hangs

    OpenSuse 12.3 x86 running under VMware Player 6 dual boot with XP on Windows 7 (I have some legacy programs that won't run on Win 7 that I have to run occasionally).

    1) Upgrade via change in repositories and then "zypper install zypper", "zypper dup" process hangs during install of any package that calls modprobe.

    2) Upgrade via download of x86 iso and boot from iso hangs when Xwindows attempts to start. Using Text Mode gets past that but then any package that calls modprobe during installation hangs.

    3) Clean install of 13.1 from iso using Text Mode also hangs during any call to modprobe.

    I know it's modprobe because if I switch to a text window and kill that PID, the process appears to continue but then the reboot dies due to missing partitions (Buslogic driver wasn't loaded).

    The emulated SCSI adapter is the legacy Buslogic. I can't change it to LSI because Windows uses both IDE and SCSI partitions and it fails to mount the Windows drives that are hosted on the SCSI drive under LSI.

    Building a new VM under VMware Player 6 installs the LSI SCSI driver and 13.1 works fine. But as noted above I can't make that change in the existing VM due to Windows XP..

    NOTE: I don't HAVE to upgrade to 13.1...I just want to...

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 12.3->13.1 x86 under VMware hangs

    On 2013-12-15 19:16, kd7myc wrote:

    You should have posted on the virtualization forum here. Please ask a
    moderator to move your post. Use the triangle button below.

    > Building a new VM under VMware Player 6 installs the LSI SCSI driver and
    > 13.1 works fine. But as noted above I can't make that change in the
    > existing VM due to Windows XP..


    You can change, perhaps, the virtual machine "type" or "model". Make a
    copy of the image first.


    http://communities.vmware.com/thread/278581

    +++···························
    2. Dec 5, 2010 8:55 AM in response to: reticulatus
    Re: VM Player and upgrading hardware versions



    It may be as simple as manually editing the .VMX file for the virtual
    machine.



    Power off the VM, do not just suspend it.
    Navigate to the folder containing the VM
    Make a copy of the existing .VMX file, it will be the one where the
    icon has just the three blue squares of the VMware logo.
    If possible, make a copy of the entire VM... just in case.
    Open Notepad and then drag the original VMX into Notepad's window.
    Change config.version to "8"
    Change virtualHW.version to "7"
    Save the file, then double-click on the .VMX to open it.
    If a WIndows VM then you should get prompted about changed hardware
    Install the newer VMware tools to get newer drivers, etc.


    Let us know how it works. What OS is the VM?
    ···························++-


    Well, I did that and it worked. I'm using «config.version = "8"».


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •