Results 1 to 8 of 8

Thread: Nvidia blob only kind of working

  1. #1

    Default Nvidia blob only kind of working

    Hi there,

    I haven't used openSUSE in quite some time, so I'm not that familiar with it.
    I added the Nvidia community-repository and installed the nvidia-blob (G03). It does seem to work, kind of.
    Compositing the Gnome-desktop works fine. But games like supertuxkart run much slower than i remember.
    XBMC will not even start because of missing hardware acceleration. And glxinfo reports this weird OpenGL string:
    SUSE Paste

    My card should support OpenGL 3.3.
    As you can see my card is a 9800 GT, which should be supported by the driver.
    I also tried the G02 version, but that one didn't even render my desktop

    Thx for any help in advance

  2. #2

    Default Re: Nvidia blob only kind of working

    I guess this is pretty much what happened to me:
    nvidia 325 drivers fall back to openGL 2.1.2 :: Steam for Linux General Discussions
    No direct rendering for me either.

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Nvidia blob only kind of working

    Are you guys sue you are actually running the NVIDIA driver? Sounds like you may be falling back to a lesser drive

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,786

    Default Re: Nvidia blob only kind of working

    It is allways kind to others to at least tell what version of openSUSE you are talking about, but IMHO it is even more important with NVIDIA driver questions.
    Henk van Velden

  5. #5

    Default Re: Nvidia blob only kind of working

    Quote Originally Posted by hcvv View Post
    It is allways kind to others to at least tell what version of openSUSE you are talking about, but IMHO it is even more important with NVIDIA driver questions.
    Sorry, I'm on 13.1 x64.
    And I already found a solution to my problem on the web:

    https://devtalk.nvidia.com/default/t...ngl-rendering/

    hello,

    I had the same problem and all i had to do to activate direct rendering was add my user to the video group and after a reboot direct rendering was enabled.

    hope this helps.
    That did the trick.
    But just to be sure: Is this something you have to do manually, or is openSUSE suppost to add you automatically to the "video"-group?

  6. #6

    Default Re: Nvidia blob only kind of working

    Quote Originally Posted by EvilTwin1 View Post
    But just to be sure: Is this something you have to do manually, or is openSUSE suppost to add you automatically to the "video"-group?
    No to both.
    You shouldn't have to be part of the "video" group at all. Systemd-logind should give your user the necessary access permissions to the nvidia card. (On 12.3 this didn't happen yet so you had to add your user to the "video" group, but that was fixed later by an update)
    If this doesn't happen, there can be two reasons:
    - A regression in systemd that it doesn't give you the correct permissions for the nvidia card
    - Your user's session is not registered correctly, this would also give you other problems as a consequence.

    Could you please post the output of the following commands run as your user?
    Code:
    loginctl
    getfacl /dev/nvidia*

  7. #7

    Default Re: Nvidia blob only kind of working

    Quote Originally Posted by wolfi323 View Post
    No to both.
    You shouldn't have to be part of the "video" group at all. Systemd-logind should give your user the necessary access permissions to the nvidia card. (On 12.3 this didn't happen yet so you had to add your user to the "video" group, but that was fixed later by an update)
    If this doesn't happen, there can be two reasons:
    - A regression in systemd that it doesn't give you the correct permissions for the nvidia card
    - Your user's session is not registered correctly, this would also give you other problems as a consequence.

    Could you please post the output of the following commands run as your user?
    Code:
    loginctl
    getfacl /dev/nvidia*
    Here you go =)
    SUSE Paste

  8. #8

    Default Re: Nvidia blob only kind of working

    Quote Originally Posted by EvilTwin1 View Post
    Here you go =)
    SUSE Paste
    Code:
    getfacl /dev/nvidia*
    # file: dev/nvidia0
    # owner: root
    # group: video
    user::rw-
    
    group::rw-
    other::---
     
    # file: dev/nvidiactl
    # owner: root
    # group: video
    user::rw-
    user:jeanluc:rw-
    group::rw-
    mask::rw-
    other::---
    You got access to /dev/nvidiactl, but not /dev/nvidia0...

    Looks like this bug should be reopened then:
    https://bugzilla.novell.com/show_bug.cgi?id=808319

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •