Results 1 to 7 of 7

Thread: extern hdd - formatted to ext4 - how could i mount the drive?

  1. #1

    Default extern hdd - formatted to ext4 - how could i mount the drive?

    hello dear linux-friends


    have a external hdd - it was formated with ntfs

    now i used the opensuse 12.3 patitioner -

    yast:: system:: partitioner

    i formated this terabyte hdd with ext4

    now i cannot write to it - i think i have to mount it:

    which mounting point i have to use!?

    see the protocoll:
    i tried to use the mounting point srv - it did not work - i tried to change...


    mounting-point /dev/sdb1 to /usr/local changed

    it tid not work: What can i do now

    Gerät: /dev/sdb1
    Größe: 931.51 GB
    Verschlüsselt: Nein
    Gerätepfad: pci-0000:00:12.2-usb-0:1:1.0-scsi-0:0:0:0-part1
    Geräte-ID 1: ata-ST1000DM003-1CH162_S1DE523L-part1
    Geräte-ID 2: scsi-SASMT_2105_B8140000000000000503-part1
    Geräte-ID 3: wwn-0x5000c5006c7d7e56-part1
    FS-ID: 0x83 Linux native
    Dateisystem:
    Dateisystem: Ext4

    Einhängepunkt: /srv
    Kennung: HDDRIVE2GO
    can you help me - i need some advices


    for any and all help i will be very very thankful

    greetings

    your dilbert
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    Mount point hast to exist.

    So make a directory called /srv

    You can have it mount at boot also in Yast or edit of /etc/fstab

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    On Fri, 13 Dec 2013 19:26:01 +0000, dilbertone wrote:

    > i formated this terabyte hdd with ext4
    >
    > now i cannot write to it - i think i have to mount it:
    >
    > which mounting point i have to use!?
    >
    > see the protocoll:
    > i tried to use the mounting point srv - it did not work - i tried to
    > change...
    >
    >
    > mounting-point /dev/sdb1 to /usr/local changed


    /dev/sdb1 is the partition - /usr/local is not a normal place to mount a
    drive (though it can be, certainly, if you're putting data at that path
    and want to use a larger drive for it).

    When you say "the mounting point srv - it did not work" - what was the
    exact text of the error message you got?

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    hello many many thanks for the quick reply

    i wlll try to create a mount point-...
    many many thanks for the hints.


    first of all here we have the results for the command fdisk -l
    afterwards - that means in the next hour i want to create its mount point - according to your ideas:

    btw - what about this one:

    Code:
    # mkdir /mnt/external

    or with that:
    Code:
    /media 
    or
    /media/run
    note - iwill do it in the next few hours - and come back and report all the findings.

    first of all - here we have the very very first results oft the fdisk command...

    Code:
    Gerät  boot.     Anfang        Ende     Blöcke   Id  System
    /dev/sda1              63     8385929     4192933+  82  Linux Swap / Solaris
    /dev/sda2         8385930     8594774      104422+  83  Linux
    /dev/sda3         8594775     8803619      104422+  83  Linux
    /dev/sda4   *     8803620   976768064   483982222+   5  Erweiterte
    /dev/sda5         8803683    12996584     2096451   83  Linux
    /dev/sda6        12996648    21382514     4192933+  83  Linux
    /dev/sda7        21382578    42347339    10482381   83  Linux
    /dev/sda8        42347403    63312164    10482381   83  Linux
    /dev/sda9        63312228    84276989    10482381   83  Linux
    /dev/sda10       84277053    88469954     2096451   83  Linux
    /dev/sda11       88470018    96855884     4192933+  83  Linux
    /dev/sda12       96855948   117820709    10482381   83  Linux
    /dev/sda13      117821440   159766527    20972544   83  Linux
    /dev/sda14      159768576   976766975   408499200   83  Linux
    
    Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
    255 Köpfe, 63 Sektoren/Spur, 121601 Zylinder, zusammen 1953525168 Sektoren
    Einheiten = Sektoren von 1 × 512 = 512 Bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xcd407128
                                                                                                                                                                                                    
       Gerät  boot.     Anfang        Ende     Blöcke   Id  System                                                                                                                                  
    /dev/sdb1   *          64  1953520063   976760000   83  Linux

    what do you say.... [sorry for the german tongue - i will try to do the commands in engl. Utf8 in the future...


    look forward to hear from you
    greetings

    dilbertone - the first
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    On 2013-12-13 20:26, dilbertone wrote:

    > now i used the opensuse 12.3 patitioner -
    >
    > yast:: system:: partitioner
    >
    > i formated this terabyte hdd with ext4
    >
    > now i cannot write to it - i think i have to mount it:
    >
    > which mounting point i have to use!?


    Any one you _type_ yourself. You do not need to limit yourself to those
    in the droplist. For instance, "/data/one", or
    "/home/MYUSERNAME/ExternalDataBigAndAbsurdNameIWantToGiveIt/". Notice
    that YaST will create that mountpoint you tell it to use.

    I suggest that as it is an external disk, add "nofail" as option in the
    option field, or your system will fail to boot if the disk is not
    present at boot time.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    hello dear Robin - hello dear all!!



    Quote Originally Posted by robin_listas View Post
    On 2013-12-13 20:26, dilbertone wrote:

    Any one you _type_ yourself. You do not need to limit yourself to those
    in the droplist. For instance, "/data/one", or
    "/home/MYUSERNAME/ExternalDataBigAndAbsurdNameIWantToGiveIt/". Notice
    that YaST will create that mountpoint you tell it to use.

    I suggest that as it is an external disk, add "nofail" as option in the
    option field, or your system will fail to boot if the disk is not
    present at boot time.

    --
    Cheers / Saludos,

    Carlos E. R.
    many many thanks for he quick reply - great to hear from you!


    well now i have mounted a external drive at

    Code:
    # mkdir /mnt/external
    and subsequently

    Code:
    mkdir -p /mnt/external
    mount /dev/sdb1 /mnt/external
    now only the root-user has access to write to these folders.

    Code:
    linux-wyee:/home/martin # dir /mnt
    insgesamt 4
    drwxr-xr-x 2 root root 4096 13. Dez 22:01 external
    how to change this - how to change that all can write to the external drive.
    i need to change the permissions within the terminal....

    Code:
    chmod 777 /dev/sdb1 /mnt/external or something alike -
    what do you think!?
    dilbert ;-)
    Wordpress-development - a Toolset: wpgear.org

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: extern hdd - formatted to ext4 - how could i mount the drive?

    On 2013-12-14 09:36, dilbertone wrote:


    > how to change this - how to change that all can write to the external
    > drive.
    > i need to change the permissions within the terminal....


    Code:
    chown martin:users /mnt/external
    That's one way. Another, preferred, is create a directory in that
    partition and chown it to you:


    Code:
    mkdir /mnt/external/martin
    chown martin:users /mnt/external/mine
    And then write in that directory. Makes things easier when plugging on a
    different computer (it is an external disk, after all). Also you can
    have different directories for different users, like on home.

    Your choice :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •