Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: wlan not working; ethernet yes

  1. #1
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default wlan not working; ethernet yes

    Hi
    Last week i made a fresh install of opensuse 13.1 but I can't connect to my wifi. In Yast, the hardware information throws this for Wireless lan:

    24: PCI 100.0: 0282 WLAN controller
    [Created at pci.319]
    Unique ID: S6TQ.MxvvoCwdjwB
    Parent ID: z8Q3.kAvxafkpie6
    SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
    SysFS BusID: 0000:01:00.0
    Hardware Class: network
    Model: "RaLink WLAN controller"
    Vendor: pci 0x1814 "RaLink"
    Device: pci 0x3290
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x18ec
    Driver: "rt2800pci"
    Driver Modules: "rt2800pci"
    Device File: wlo1
    Features: WLAN
    Memory Range: 0x92510000-0x9251ffff (rw,non-prefetchable)
    IRQ: 45 (35421 events)
    HW Address: 0c:84:dc:aa:87:fd
    Link detected: no
    WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
    WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
    WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    Module Alias: "pci:v00001814d00003290sv0000103Csd000018ECbc02sc80i00"
    Driver Info #0:
    Driver Status: rt2800pci is active
    Driver Activation Cmd: "modprobe rt2800pci"
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #17 (PCI bridge)


    Can you help me connecting?
    Thanks

  2. #2

    Default Re: wlan not working; ethernet yes

    Quote Originally Posted by jazmiel View Post
    Can you help me connecting?
    Well, how are you trying to connect?
    If you use your Desktop's network applet, you might have to enable NetworkManager first in YaST->System->Network Devices->Network Settings->Global Options.
    Without NetworkManager running you have to configure your wlan in YaST.

  3. #3
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: wlan not working; ethernet yes

    Thanks for your reply
    Yes, I'm using the Network Manager.
    When I edit the network connection i see the SSID corresponding to the service provider. If I 'click' on Select BSSID button it correctly puts the MAC address. In the beginning I chose to: Connect automatically and System connection.
    In the wireless security tab I typed the password but, can't connect.
    What would you suggest me to do?


    Quote Originally Posted by wolfi323 View Post
    Well, how are you trying to connect?

  4. #4
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: wlan not working; ethernet yes

    Help anyone?


    Quote Originally Posted by jazmiel View Post
    Thanks for your reply
    Yes, I'm using the Network Manager.
    When I edit the network connection i see the SSID corresponding to the service provider. If I 'click' on Select BSSID button it correctly puts the MAC address. In the beginning I chose to: Connect automatically and System connection.
    In the wireless security tab I typed the password but, can't connect.
    What would you suggest me to do?

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: wlan not working; ethernet yes

    You only have to select the network, enter passphrase/key, and that's it. No need to fill out any other values.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: wlan not working; ethernet yes

    Thanks for your reply
    I've been doing exactly what you indicate me and haven't been able to connect wirelessly. I'm sure my net-card works fine (I dual boot with w8 where it works well) but in opensuse... nothing!
    I installed opensuse 13.1 just last week. I'm probing it (I'm quite new in linux; learning and fascinated with this software) and I would really want to give opensuse a try.
    Any advice?


    Quote Originally Posted by Knurpht View Post
    You only have to select the network, enter passphrase/key, and that's it. No need to fill out any other values.

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: wlan not working; ethernet yes

    On 12/14/2013 06:56 PM, jazmiel wrote:
    >
    > Thanks for your reply
    > I've been doing exactly what you indicate me and haven't been able to
    > connect wirelessly. I'm sure my net-card works fine (I dual boot with
    > w8 where it works well) but in opensuse... nothing!
    > I installed opensuse 13.1 just last week. I'm probing it (I'm quite new
    > in linux; learning and fascinated with this software) and I would
    > really want to give opensuse a try.
    > Any advice?


    Are you using WEP? If so, you must use the key. A passphrase will not work.


  8. #8
    Join Date
    Dec 2013
    Location
    Near México City
    Posts
    175

    Default Re: wlan not working; ethernet yes

    Hi, again!
    Going to Yast --> Network Settings --> Global Options --> Configuration Method, I have activated: Controlled by NetworkManager, and I don't see a WEP option.


    Quote Originally Posted by lwfinger View Post
    On 12/14/2013 06:56 PM, jazmiel wrote:
    Are you using WEP? If so, you must use the key. A passphrase will not work.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: wlan not working; ethernet yes

    Quote Originally Posted by jazmiel View Post
    Hi, again!
    Going to Yast --> Network Settings --> Global Options --> Configuration Method, I have activated: Controlled by NetworkManager, and I don't see a WEP option.
    No, when using NM, edit the wireless connection via the icon. Gnome and KDE versions are slightly different, but locate the wireless tab, wireless security, change to WEP if applicable.

  10. #10
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: wlan not working; ethernet yes

    On Sun, 15 Dec 2013 15:06:01 +0000, jazmiel wrote:

    > Hi, again!
    > Going to Yast --> Network Settings --> Global Options -->
    > Configuration Method, I have activated: Controlled by NetworkManager,
    > and I don't see a WEP option.


    You haven't specified if you're using WEP or not - how's the router
    configured? You need to match that configuration.

    FYI, though, WEP is generally not recommended because it's easily
    hacked. WPA2 is generally recommended if you're encrypting the network.

    But you have to set that at the router and then match the configuration
    at the client.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •