Results 1 to 3 of 3

Thread: How to change desktop environment or get a login screen from grub?

  1. #1

    Default How to change desktop environment or get a login screen from grub?

    SUSE 13.1, KDE 4.11
    So I was messing around and "accidentally" changed my desktop environment from KDE to Metacity. It's related to updating my NVidia driver, but that's a separate issue. I have my login set up to bypass the login screen and go straight to desktop, but after uninstalling the video driver it went to the login screen, where I clicked on the configuration icon and switched to Metacity.
    Well, stupid me.
    Now I can't figure out how to switch back. When it boots into Metacity, I just get a mouse pointer and an unresponsive black window...no surprises there. Ideally, I'd like to go back to the login screen and change the configuration back to KDE, but I have it set up to bypass the login screen. I can drop to a runlevel 3 shell, but no idea what to do there. I can probably edit a configuration file somewhere and change it back, but which one?
    Is there a way to prompt a login screen from grub?
    Probably a really easy solution to this one, but I can't find anything on google, and I've exhausted all ideas I have on it.
    Help is appreciated. Thanks!

  2. #2

    Default Re: How to change desktop environment or get a login screen from grub?

    Quote Originally Posted by HuaiDan View Post
    I can probably edit a configuration file somewhere and change it back, but which one?
    Is there a way to prompt a login screen from grub?
    It should be possible to get to the Login Screen by pressing Ctrl+Alt+Backspace _twice_, this will kill and restart the X server.

    You can turn off Auto-Login in /etc/sysconfig/displaymanager:
    Code:
    DISPLAYMANAGER_AUTOLOGIN=""
    The currently selected Desktop session is saved in ~/.dmrc, remove that file and you should get the default one again.

  3. #3

    Default Re: How to change desktop environment or get a login screen from grub?

    Ctl-Alt-Backspace 2X...I knew that. Man, it's been a long week. Must be a Friday the 13th thing. Thanks a million!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •