Results 1 to 7 of 7

Thread: Cannot hibernate

  1. #1

    Default Cannot hibernate

    Hibernation with this computer used to work with opensuse 12.3. With 13.1, resuming after hibernation is actually a reboot.

    RAM is 16 GiB and swap is 17 GiB. Swap (partition 1) is unused, but active:

    Code:
    # free -m
                 total       used       free     shared    buffers     cached
    Mem:         16001       2112      13888          0         96        876
    -/+ buffers/cache:       1140      14861
    Swap:        17404          0      17404
    
    
    
    #  swapon -s
    Filename                                Type            Size               Used    Priority
    /dev/sda1                               partition       17822716        0       -1
    The relevant lines from menu.lst:

    Code:
    title Desktop -- openSUSE - 3.11.6-4
        root (hd0,1)
        kernel /boot/vmlinuz-3.11.6-4-desktop root=/dev/disk/by-id/ata-...-part2 resume=/dev/disk/by-id/ata-...-part1 splash=verbose showopts
        initrd /boot/initrd-3.11.6-4-desktop

    There are a few suspicious lines in log file pm-suspend.log which I don't understand; other lines report success:

    Code:
    usr/lib/pm-utils/sleep.d/00powersave hibernate hibernate: success.
    Running hook /usr/lib/pm-utils/sleep.d/02rtcwake hibernate hibernate:
    rtcwake alarm not enabled in /etc/pm/config.d/rtcwake.config, doing nothing...
    
    /usr/lib/pm-utils/sleep.d/02rtcwake hibernate hibernate: success.
    Running hook /usr/lib/pm-utils/sleep.d/06autofs hibernate hibernate:
    autofs.service - Automounts filesystems on demand
       Loaded: loaded (/usr/lib/systemd/system/autofs.service; disabled)
       Active: inactive (dead)
    Visually, it looks like hibernation is successful, but at waking up, the swap partition is ignored.

    How shall I proceed to debug?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Cannot hibernate

    So you are using Grub not Grub2?

    Can't say I have tried it recently, I pretty much only use Suspend
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Cannot hibernate

    Quote Originally Posted by caf4926 View Post
    So you are using Grub not Grub2?

    Can't say I have tried it recently, I pretty much only use Suspend
    I use Grub.

    Sleep (suspend to RAM) also works marginally, sometimes not restarting correctly. Used to work with opensuse 12.3. Otherwise, the computer works correctly.

    Hibernation by
    Code:
    /usr/sbin/pm-hibernate
    from command line fails the same way as from KDE's logout menu.

  4. #4

    Default Solved, at least in my computer.


  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cannot hibernate

    On 2013-12-16 13:06, ZStefan wrote:
    >
    > A possible solution found here:


    Is this a 32 bit kernel?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6

    Default Re: Cannot hibernate

    Quote Originally Posted by robin_listas View Post
    On 2013-12-16 13:06, ZStefan wrote:
    >
    > A possible solution found here:


    Is this a 32 bit kernel?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    No. Kernel is

    3.11.6-4-desktop #1 SMP PREEMPT x86_64 x86_64 x86_64

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cannot hibernate

    On 2013-12-16 19:56, ZStefan wrote:
    >
    > robin_listas;2608792 Wrote:


    >> Is this a 32 bit kernel?


    > No. Kernel is
    >
    > 3.11.6-4-desktop #1 SMP PREEMPT x86_64 x86_64 x86_64


    Oh.
    I asked because there is a bug on the 32 bit kernel in 13.1 that impedes
    hibernation.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •