Results 1 to 7 of 7

Thread: Dual boot: Nvidia or Intel (not Bumblebee!)

  1. #1

    Default Dual boot: Nvidia or Intel (not Bumblebee!)

    openSuse 13.1, Thinkpad T420s, Intel-GPU and Nvidia-GPU. I don't need Bumblebee, but once in a while I need the display port, which is connected to the nvidia card.

    So (thanks to hank_se) I figured out a dual boot system: If I need the display port, I switch in BIOS to the nvidia card and boot. If I don't need the dp, I choose the Intel GPU in the BIOS.

    Well, initially even using the intel card, there was a bug and I updated to X11/Xorg repo.

    Now I'm trying to install the nvidia driver , but to my great surprise X-server does not start, see here the last lines of the log:


    Code:
    [    15.452] Initializing built-in extension XFree86-DGA
    [    15.452] Initializing built-in extension XFree86-DRI
    [    15.452] Initializing built-in extension DRI2
    [    15.452] (II) "glx" will be loaded by default.
    [    15.452] (II) LoadModule: "dri2"
    [    15.452] (II) Module "dri2" already built-in
    [    15.452] (II) LoadModule: "glamoregl"
    [    15.458] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    [    15.459] (II) Module glamoregl: vendor="X.Org Foundation"
    [    15.459]     compiled for 1.14.99.903, module version = 0.5.1
    [    15.459]     ABI class: X.Org ANSI C Emulation, version 0.4
    [    15.459] (II) LoadModule: "glx"
    [    15.459] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    15.459] (II) Module glx: vendor="X.Org Foundation"
    [    15.459]     compiled for 1.14.99.903, module version = 1.0.0
    [    15.459]     ABI class: X.Org Server Extension, version 8.0
    [    15.459] (==) AIGLX enabled
    [    15.459] Loading extension GLX
    [    15.459] (II) LoadModule: "intel"
    [    15.460] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [    15.465] (II) Module intel: vendor="X.Org Foundation"
    [    15.465]     compiled for 1.14.99.903, module version = 2.99.906
    [    15.465]     Module class: X.Org Video Driver
    [    15.465]     ABI class: X.Org Video Driver, version 15.0
    [    15.465] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
    [    15.465] (++) using VT number 7
    
    [    15.465] (EE) No devices detected.
    [    15.465] (EE) 
    Fatal server error:
    [    15.465] (EE) no screens found(EE) 
    [    15.465] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    15.465] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    15.465] (EE)
    Any ideas, pleaze?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,735

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    I am a bit lost here.

    You say you use openSUSE 13.1 That is the current version. Thus what makes you posting this in the Pre-Release/Beta forum?
    I guess that not many people are watching this forum, because there is not pre-release version of openSUSE yet.
    Henk van Velden

  3. #3

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    Quote Originally Posted by hcvv View Post
    I am a bit lost here.

    You say you use openSUSE 13.1 That is the current version. Thus what makes you posting this in the Pre-Release/Beta forum?
    I guess that not many people are watching this forum, because there is not pre-release version of openSUSE yet.
    Because I updated to Xorg/X11 (e.g. Mesa 10). That said, maybe it makes sense to move this thread.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,735

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    Will be moved to Install/Boot/Login and is CLOSED for the moment.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,735

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    Quote Originally Posted by hcvv View Post
    Will be moved to Install/Boot/Login and is CLOSED for the moment.
    Moved from Pre-release/Beta and open again.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    You probably overwrote the libGL files that came with Mesa. Reinstall the Mesa-libGL* packages + xorg-x11-server
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Dual boot: Nvidia or Intel (not Bumblebee!)

    Quote Originally Posted by Knurpht View Post
    You probably overwrote the libGL files that came with Mesa. Reinstall the Mesa-libGL* packages + xorg-x11-server
    1. Did not help, same error.

    2. Maybe I did not describe properly that I tried to start X with the Nvidia card. To my surprise the log seems to say it tries to load libs which (to me) seem to be part of the Intel GPU installation? And the libglamoreg belongs to a packages called glamor?

    I really consider selling this notebook and buy one instead without a so called "discrete" GPU, but including a better integrated one.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •