Results 1 to 4 of 4

Thread: DOTA 2 Lags when I click

  1. #1

    Default DOTA 2 Lags when I click

    Hi Folks,

    after several days of pain i finally managed it to install Nvidia Graphics with Bumblebee and VirtualGL + all additional Packages to get it even running, deactivated pulseaudio to have Sound so my Dota 2 was ready to go.



    While starting my first Game I discovered that I had Lags, which was unusual to me because in Windows 8.1 I could play the Game on high. However getting the settings to low didn't solve the problem.

    After a while I found out that a lag every time then occurred when i clicked with my mouse somewhere on the screen in DOTA 2, whether i issued a command for my hero like move or attack or just clicked somewhere on the Gui, i got a micro lag right after.

    That's bad for a Game like DOTA lol

    I examined KSYSGuard while in game. Here's a Screenshot:

    http://http://www.imagebanana.com/vi.../snapshot7.png

    The part where CPU % is higher then in the other sections I'm left clicking like a maniac (left click doesn't cause any Action ingame). In the lower parts I'm just doing nothing, both time same game scenary, didn't change anything


    Have you experienced this or do you know how to fix it?

    Please Help me, would be a shame if I couldn't play the game because it runs like a charm when i do not click anywhere



    Specs:

    Lenovo Y580 UEFI
    Opensuse x64
    Nvidia GTX 660m (Bumblebee Driver, Newest Nvidia Driver 320 or something)
    Intel Core i 7 3630QM

  2. #2

    Default Re: DOTA 2 Lags when I click

    Can noone help me?

  3. #3

    Default Re: DOTA 2 Lags when I click

    I've made a Vdieo, maybe it's easier to understand...

    Problems with DOTA 2 on Opensuse 13.1 x64 Optimus - YouTube

  4. #4

    Default Re: DOTA 2 Lags when I click

    Ok, I have found out that I only get those Lags when i Click left Mouse Button, Right Mouse Button or the one in the middle (Wheel), Touchpad makes no difference. But If I click the other two buttons on the Side of the Mouse (aka Button 4 and Button 5) I don't get a lag.

    I played arround with my Xorg Config files Section "InputDevice" because I believe the right configration of the Mouse will solve the Problem.

    Now when I start the Game I can play without lags for a certain time, like 10 to 20 minutes of Game, after that it starts laging. To get rid of the lags again I have to restart X with CTRL + ALT + BACKSPACE and then start the Game again.

    heres my etc/bumblebee/Xorg.conf.nvidia:


    Code:
    Section "ServerLayout"
        Identifier  "Layout0"
        InputDevice     "Mouse1"
        Option      "AutoAddDevices" "false"
        Option      "AutoAddGPU" "false"
        
    
     Section "InputDevice"
            Identifier     "Mouse1"
           Driver         "mouse"
            Option "Protocol" "auto"
            Option "Device"  "/dev/input/mice"
            Option         "Emulate3Buttons" "false"
            Option         "ZAxisMapping" "4 5"
        EndSection
    
    Section "Device"
        Identifier  "DiscreteNvidia"
        Driver      "nvidia"
        VendorName  "NVIDIA Corporation"
    
    #   If the X server does not automatically detect your VGA device,
    #   you can manually set it here.
    #   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
    #   as you see in the commented example.
    #   This Setting may be needed in some platforms with more than one
    #   nvidia card, which may confuse the proprietary driver (e.g.,
    #   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    #   BusID "PCI:01:00:0"
    
    #   Setting ProbeAllGpus to false prevents the new proprietary driver
    #   instance spawned to try to control the integrated graphics card,
    #   which is already being managed outside bumblebee.
    #   This option doesn't hurt and it is required on platforms running
    #   more than one nvidia graphics card with the proprietary driver.
    #   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
    #   If this option is not set, the new Xorg may blacken the screen and
    #   render it unusable (unless you have some way to run killall Xorg).
        Option "ProbeAllGpus" "false"
    
        Option "NoLogo" "true"
        Option "UseEDID" "false"
        Option "UseDisplayDevice" "none"
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •