Results 1 to 4 of 4

Thread: Remote VNC funktioniert nicht mit neu installierter OpenSuse 13.1

  1. #1

    Question Remote VNC funktioniert nicht mit neu installierter OpenSuse 13.1

    Hi,

    bei meiner frisch installierten OpenSuse 13.1 kann ich keine Remove VNC Session eröffnen. Beim versuch einer Verbindung kann ich sehen wie der Login Screen aufgebaut wird, allerdings bevor dieser fertig dargestellt ist, wird die Verbindung abgebrochen. Folgendes kann ich in den Logfiles sehen:

    /var/log/messages
    2013-12-11T10:15:50.274163+01:00 myserver xinetd[803]: START: vnc1 from=10.80.29.1

    2013-12-11T10:15:50.539294+01:00 myserver kdm_config[3334]: Multiple occurrences of section [General] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:02:54.199642+01:00 myserver sudo: message repeated 19 times: [ pam_unix(sudo:auth): auth could not identify password for [root]]
    2013-12-11T10:15:50.540080+01:00 myserver kdm_config[3334]: Multiple occurrences of section [Xdmcp] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:15:50.540448+01:00 myserver kdm_config[3334]: Multiple occurrences of section [X-*-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:15:50.540818+01:00 myserver kdm_config[3334]: Multiple occurrences of section [X-*-Greeter] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:15:50.541208+01:00 myserver kdm_config[3334]: Multiple occurrences of section [X-:*-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:15:50.541554+01:00 myserver kdm_config[3334]: Multiple occurrences of section [X-:0-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2013-12-11T10:15:50.541901+01:00 myserver kdm[3805]: plymouth should quit after server startup
    2013-12-11T10:15:51.285500+01:00 myserver kdm: localhost:1[3340]: Abnormal termination of greeter for display localhost:1, code 1, signal 0
    2013-12-11T10:15:51.296061+01:00 myserver xinetd[803]: EXIT: vnc1 status=0 duration=1(sec)


    /var/log/kdm.log
    klauncher(3348) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
    kdeinit4: Communication error with launcher. Exiting!
    kdmgreet(3341)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: "Not connected to D-Bus server"


    kdmgreet(3341)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
    X Error of failed request: BadAccess (attempt to access private resource denied)
    Major opcode of failed request: 131 (MIT-SHM)
    Minor opcode of failed request: 1 (X_ShmAttach)
    Serial number of failed request: 605
    Current serial number in output stream: 606


    Woran könnte das liegen???

    Cheers

  2. #2

    Default Re: Remote VNC funktioniert nicht mit neu installierter OpenSuse 13.1

    I had the same issue.

    at a terminal window type
    dbus-launch vncserver
    enter a password
    take note of the session/port # (2, 3, 4, etc)

    go to /home/your_username/.vnc (it is a hidden folder)
    edit the file xstartup (I would save it first)

    for KDE contents should be
    #!/bin/sh
    /usr/bin/startkde

    for GNOME contents should be
    #!/bin/sh
    /usr/bin/gnome &

    had to REBOOT after editing xstartup to get GUI's to come

    from vnc client enter address of server followed by session number
    like xxx.xxx.xxx.xxx:# (e.g. 192.168.2.8:2)
    enter password when prompted

    This will get you started.
    read the article at the following link to set up other options like KDE or GNOME interfaces and to setup automatic start on boot

    TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

  3. #3

    Default Re: Remote VNC funktioniert nicht mit neu installierter OpenSuse 13.1

    Quote Originally Posted by jke12345 View Post
    I had the same issue.

    at a terminal window type
    dbus-launch vncserver
    enter a password
    take note of the session/port # (2, 3, 4, etc)

    go to /home/your_username/.vnc (it is a hidden folder)
    edit the file xstartup (I would save it first)

    for KDE contents should be
    #!/bin/sh
    /usr/bin/startkde

    for GNOME contents should be
    #!/bin/sh
    /usr/bin/gnome &

    had to REBOOT after editing xstartup to get GUI's to come
    also have to run dbus-launch vncserver again since is not configured for start on boot yet

    from vnc client enter address of server followed by session number
    like xxx.xxx.xxx.xxx:# (e.g. 192.168.2.8:2)
    enter password when prompted

    This will get you started.
    read the article at the following link to set up other options like KDE or GNOME interfaces and to setup automatic start on boot

    TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)


    see additional instructions above
    (also have to run dbus-launch vncserver again since is not configured for start on boot yet)

  4. #4

    Default Re: Remote VNC funktioniert nicht mit neu installierter OpenSuse 13.1

    Hallo Zusammen,

    ich hatte das selbe Problem: vncviewer blendet kurz den Login-Screen auf und
    die Verbindung bricht dann ab mit folgenden Fehlermeldungen:

    Client:
    Code:
    vncviewer: VNC server closed connection
    Server:
    Code:
    xinetd[684]: START: vnc1 from=192.168.1.100
    localhost:1[11187]: Abnormal termination of greeter for display localhost:1, code 1, signal 0
    xinetd[684]: EXIT: vnc1 status=0 duration=2(sec)
    Nach viel lesen, ausprobieren etc. bin ich darauf gekommen, dass beim Server IPv6 enabled
    ist, das Netzwerk aber ingesamt mit allen Maschinen IPv4.

    Nachdem ich unter Yast->Network Settings -> IPv6 Protocol Settings "unchecked" habe,
    geniesse ich wieder eine stabile Verbindung zu diesem System.
    4.4.138-59-default, GeForce 9800 GT passive, MEM 8GB,
    AMD FX(tm)-6300 Six-Core , Asrock 960GM/U3S3 FX

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •