Yes, this was an upgrade. 12.3 > 13.1

Method:

Change all repos to 13.1 > this was the list and settings

Code:
1 | download.nvidia.com-opensuse | nVidia Graphics Drivers            | Yes     | Yes    
 2 | extra411                     | extra411                           | Yes     | Yes    
 3 | ftp.gwdg.de-suse             | Packman Repository                 | Yes     | Yes    
 4 | google-chrome                | google-chrome                      | Yes     | Yes    
 5 | kde411                       | kde411                             | Yes     | Yes    
 6 | malcolms                     | malcolms                           | Yes     | Yes    
 7 | opensuse-guide.org-repo      | libdvdcss repository               | Yes     | Yes    
 8 | repo-debug                   | openSUSE-13.1-Debug                | No      | No     
 9 | repo-debug-update            | openSUSE-13.1-Update-Debug         | No      | No     
10 | repo-debug-update-non-oss    | openSUSE-13.1-Update-Debug-Non-Oss | No      | No     
11 | repo-non-oss                 | openSUSE-13.1-Non-Oss              | Yes     | Yes    
12 | repo-oss                     | openSUSE-13.1-Oss                  | Yes     | Yes    
13 | repo-source                  | openSUSE-13.1-Source               | No      | No     
14 | repo-update                  | openSUSE-13.1-Update               | Yes     | Yes    
15 | repo-update-non-oss          | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes
Then using Yast software manager I upgraded all unconditionally > marked for removal some unmaintained packages > switched on kde411 > switched on extra 411 > switched on Packman >
Apply
4 GB + to download
Reboot when done
All good.

Had to edit grub.cfg to reflect 13.1 (as it showed 12.3)