Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: kein automatischer Start von mythbackend beim booten

  1. #1

    Default kein automatischer Start von mythbackend beim booten

    Hallo,

    kann mir jemand sagen, wie man mythbackend unter opensuse 13.1 dazu bekommt, dass es beim booten geladen wird?
    Der Services Manager sagt der Dienst sei enabled aber inactive. Unter Details findet sich folgende Meldung:

    mythbackend.service - MythTV backend service
    Loaded: loaded (/usr/lib/systemd/system/mythbackend.service; enabled)
    Active: failed (Result: resources)
    Dec 08 23:12:33 linux-2eoc systemd[1]: Starting MythTV backend service...
    Dec 08 23:12:33 linux-2eoc systemd[1]: Failed to load environment files: No such file or directory
    Dec 08 23:12:33 linux-2eoc systemd[1]: mythbackend.service failed to run 'start' task: No such file or directory
    Dec 08 23:12:33 linux-2eoc systemd[1]: Failed to start MythTV backend service.
    Dec 08 23:12:33 linux-2eoc systemd[1]: Unit mythbackend.service entered failed state.

    Ein Starten des Dienstes ist manuell an der Konsole problemlos möglich. Der Service Manager behauptet übrigens auch dann noch, der Dienst sei inaktiv. Beim manuellen Start über den Services Manager kommt wieder oben genannte Fehlermeldung. Da ich Mythtv auch zum Aufnehmen von Fernsehsendungen nujtze, wäre es natürlich sehr hilfreich, wenn der Diewnst automatisch beim Start bootet zumal ich es dann auch nicht vergessen kann, ihn an der Konsole zu starten.

    vielen Dank im vorraus für Eure Hilfe

  2. #2

    Default Re: kein automatischer Start von mythbackend beim booten

    Hallo.
    Hab das gleiche Problem mit einem anderem Prog.
    Ich habe im Yast den dienst deaktiviert und nun ist das Prog nicht mehr in Yast2 zu finden !!
    Meine Vermutung ist, das die Programme nicht kompatibel zu Suse 13.1 sind.
    Frage: Wie bekomme ich den Eintrag in Yast hin, bzw. wie bekomme ich den Start beim booten hin ?

    Danke

  3. #3

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by darkcase View Post
    Hallo.
    Hab das gleiche Problem mit einem anderem Prog.
    Ich habe im Yast den dienst deaktiviert und nun ist das Prog nicht mehr in Yast2 zu finden !!
    Meine Vermutung ist, das die Programme nicht kompatibel zu Suse 13.1 sind.
    Frage: Wie bekomme ich den Eintrag in Yast hin, bzw. wie bekomme ich den Start beim booten hin ?
    Das ist aber nicht das "gleiche" Problem würde ich sagen...
    Um welches Programm handelt es sich?

    Probier "systemctl" zu verwenden.
    Zum manuellen Starten:
    Code:
    sudo systemctl start xxx.service
    Für den automatischen Start beim Booten:
    Code:
    sudo systemctl enable xxx.service

  4. #4

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by femurli View Post
    Hallo,

    kann mir jemand sagen, wie man mythbackend unter opensuse 13.1 dazu bekommt, dass es beim booten geladen wird?
    Der Services Manager sagt der Dienst sei enabled aber inactive.
    "enabled" heißt, dass es beim Booten gestartet wird. "inactive" heißt, dass es momentan nicht läuft (in diesem Fall, weil beim Starten ein Fehler aufgetreten ist).

    Unter Details findet sich folgende Meldung:

    mythbackend.service - MythTV backend service
    Loaded: loaded (/usr/lib/systemd/system/mythbackend.service; enabled)
    Active: failed (Result: resources)
    Dec 08 23:12:33 linux-2eoc systemd[1]: Starting MythTV backend service...
    Dec 08 23:12:33 linux-2eoc systemd[1]: Failed to load environment files: No such file or directory
    Dec 08 23:12:33 linux-2eoc systemd[1]: mythbackend.service failed to run 'start' task: No such file or directory
    Dec 08 23:12:33 linux-2eoc systemd[1]: Failed to start MythTV backend service.
    Dec 08 23:12:33 linux-2eoc systemd[1]: Unit mythbackend.service entered failed state.
    Da ist die Fehlermeldung.

    Wo hast du denn mythtv her? Von Packman?
    Und welche Version?

    Existieren die Dateien /usr/bin/mythbackend und /etc/sysconfig/mythbackend? Wenn nicht, würde das die Fehlermeldung erklären...

    Ein Starten des Dienstes ist manuell an der Konsole problemlos möglich. Der Service Manager behauptet übrigens auch dann noch, der Dienst sei inaktiv.
    Klar. Wenn du mythbackend in der Konsole aufrufst, wird ja nicht der System-Dienst gestartet.
    Dazu müßtest du "sudo systemctl start mythbackend.service" aufrufen, das ist genau das was YaST macht wenn du auf "Start/Stop" klickst.

  5. #5

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by wolfi323 View Post
    Das ist aber nicht das "gleiche" Problem würde ich sagen...
    Um welches Programm handelt es sich?

    Probier "systemctl" zu verwenden.
    Zum manuellen Starten:
    Code:
    sudo systemctl start xxx.service
    Für den automatischen Start beim Booten:
    Code:
    sudo systemctl enable xxx.service
    Hi
    Das Prog heißt "Intermapper" und hat kein xx.service
    Mit Intermapperd und auch mit systemctl kann ich den dienst starten.
    Durch das deaktivieren in yast ist der Eintrag dort verschwunden.
    Hatte eh nicht funktioniert.

    Gruß

  6. #6

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by darkcase View Post
    Hi
    Das Prog heißt "Intermapper" und hat kein xx.service
    Mit Intermapperd und auch mit systemctl kann ich den dienst starten.
    Durch das deaktivieren in yast ist der Eintrag dort verschwunden.
    Hatte eh nicht funktioniert.
    Der neue Service Manager in YaST hatte einen Fehler, wodurch er die alten sysvinit scripts (in /etc/init.d/) nicht anzeigte.
    Das ist aber mit einem Update behoben worden und sollte inzwischen einwandfrei funktionieren.

    Und wenn du ihn mit systemctl startest, sollte er auf jeden Fall wieder in YaST angezeigt werden.

  7. #7

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by wolfi323 View Post
    Der neue Service Manager in YaST hatte einen Fehler, wodurch er die alten sysvinit scripts (in /etc/init.d/) nicht anzeigte.
    Das ist aber mit einem Update behoben worden und sollte inzwischen einwandfrei funktionieren.

    Und wenn du ihn mit systemctl startest, sollte er auf jeden Fall wieder in YaST angezeigt werden.
    Ja, nach dem Start per systemctl ist er nun wieder in Yast2 zu sehen.
    Sobald ich im Yast den dienst deaktiviere, ist er weg.

  8. #8

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by darkcase View Post
    Ja, nach dem Start per systemctl ist er nun wieder in Yast2 zu sehen.
    Sobald ich im Yast den dienst deaktiviere, ist er weg.
    Tja, hast du die aktuelle Version vom Service Manager?
    Code:
    # rpm -q --changelog yast2-services-manager | head
    * Mon Nov 04 2013 vmoravec@suse.com- 0.0.11
    - list missing LSB services bnc#846422
    ...
    Wie gesagt, da war ein Fehler in der Version die mit 13.1 ausgeliefert wurde. Die Version aus dem Update repo zeigt aber alle SysVinit Dienste korrekt an.

    Allerdings hat das aber wirklich überhaupt nichts mit dem Problem des OP zu tun ("kein automatischer Start von mythbackend beim booten")...

  9. #9

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by wolfi323 View Post
    Tja, hast du die aktuelle Version vom Service Manager?
    Code:
    # rpm -q --changelog yast2-services-manager | head
    * Mon Nov 04 2013 vmoravec@suse.com- 0.0.11
    - list missing LSB services bnc#846422
    ...
    Wie gesagt, da war ein Fehler in der Version die mit 13.1 ausgeliefert wurde. Die Version aus dem Update repo zeigt aber alle SysVinit Dienste korrekt an.

    Allerdings hat das aber wirklich überhaupt nichts mit dem Problem des OP zu tun ("kein automatischer Start von mythbackend beim booten")...
    No update candidate for 'yast2-services-manager-0.0.11-3.4.1.noarch'. The highest available version is already installed.

    ich glaub schon

    ich werde mal was über den sysvinit lesen...

    auf jeden fall mal besten Danke für die Hilfe

  10. #10

    Default Re: kein automatischer Start von mythbackend beim booten

    Quote Originally Posted by darkcase View Post
    No update candidate for 'yast2-services-manager-0.0.11-3.4.1.noarch'. The highest available version is already installed.

    ich glaub schon
    0.0.11 ist die aktuelle Version und sollte funktionieren.
    Vielleicht liefert das Script aber einen Fehler und wird deshalb nicht angezeigt?

    Wie schon geschrieben, du kannst mit "systemctl xxx.service" für den automatischen Start beim Booten aktivieren (das ".service" musst du beim Dienstnamen anhängen, z.B. "mysql.service" für /etc/init.d/mysql).
    Aber wenn er jetzt nach manuellem Start im YaST sowieso angezeigt wird, kannst du ja auch dort einfach auf "Enable/Disable" klicken.

    ich werde mal was über den sysvinit lesen...
    Wozu?
    Den kann man sowieso seit 12.3 in openSUSE nicht mehr benutzen.
    Systemd kann aber aus Kompatibilätsgründen mit den alten SysVinit scripts in /etc/init.d/ weiterhin umgehen. Die Sachen, die in openSUSE enthalten sind werden aber nach und nach auf systemd-native Unit Files (xxx.service) umgestellt.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •