Results 1 to 7 of 7

Thread: opensuse 13.1 - enable https on apache2 for use with owncloud.

  1. #1

    Default opensuse 13.1 - enable https on apache2 for use with owncloud.

    I have owncloud6 running fine under http on a clean install of opensuse 13.1, but try as we might we cannot get apche2 (?) to run with https.

    this being the precondition to forcing owncloud to only accept https traffic via the admin settings, as i understand it.

    i set up the box with opensuse, installed RC2 via one-click from the OBS, and tinkered with the router settings, but the digging around in the various .conf files was beyond me, so there are limits to my technical understanding.

    anyway, the router has services and firewall rules to forward both https and http traffic to the static IP of the opensuse box.

    the opensuse firewall has has traffic enabled for both https and http.

    owncloud itself is running fine, working from inside my network and externally (only in http tho).

    apache seems to be running fine, i have a SSL cert generated, and apache has been started with SSL enabled. but all the various .conf files seem configured as should be appropriate.

    two things puzzle us:
    1. a lot of online documentation around this apache2 SSL area argues for look at the ports.conf - we don't have one in opensuse 13.1. we also don't have a direct equivalent of some a2e command...
    2. someone was talking about how the virtual host, while setup for both port 80 and port 443 was defaulting to the former. having fixed this https worked fine. where would he have 'fixed' this?

    any thoughts generally, or specific to the two points list, would be appreciated.

    my thanks.

  2. #2
    Join Date
    Dec 2008
    Location
    Between keyboard and chair
    Posts
    96

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    I've found this tutorial helpful, and still accurate for openSUSE 13.1. My owncloud runs on a very similar configuration, actually.

    Create SSL Certificates In OpenSUSE 12.3 | Unixmen

    What problem are you running into, exactly? Any relevant error messages?

  3. #3

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    thanks.

    i get as far as:

    Configure the main site to use HTTPS
    Edit the /etc/apache2/default-server.conf file and add Include /etc/apache2/vhost.d/*.conf line in that file.
    Include /etc/apache2/conf.d/*.conf
    Include /etc/apache2/vhosts.d/*.conf
    and get this from bash:

    "If 'Include' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf Include"

    Also, in all the stages up to now the commands have been accepted with absolutely no feedback in bash, is this normal?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    Quote Originally Posted by Jedibeeftrix View Post
    thanks.

    i get as far as:


    and get this from bash:

    "If 'Include' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf Include"

    Also, in all the stages up to now the commands have been accepted with absolutely no feedback in bash, is this normal?
    AFAICS you're trying to execute the .conf file. The thing you have to do to make changes have their effect, is to restart the webserver:
    Code:
    systemctl restart apache2.service
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    cheers, i have got past that bit, realised i need to be editing those lines into the conf files, not executing commands thru bash.

    stuck here now:

    i don't see the second line in the quote from the turorial:

    redirecting to systemctl restart apache2
    Enter SSL pass phrase for localhost:443 (RSA): ******

  6. #6

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    another q:

    the tutorial says - "<VirtualHost your.domain.com:443>"

    which is what i have put in, but. should it be - "<VirtualHost ipaddress:443>"

  7. #7

    Default Re: opensuse 13.1 - enable https on apache2 for use with owncloud.

    I ran through the above mentioned tutorial for getting SSL setup w/ apache, and it was complaining about shmbc module being missing. I had to navigate to /usr/sbin and run ./a2enmod sochache_shmcb to work properly. FYI.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •