Results 1 to 4 of 4

Thread: Some pages extremely slow to load

  1. #1

    Exclamation Some pages extremely slow to load

    So, I just did clean installation of OpenSUSE 13.1 and connected to my home wifi.
    When I open browser, then some pages take way longer to load than they should and sometimes they don't load all.
    Sometimes css or images dont get loaded or get loaded several minutes later.

    When I install Windows on the same hardware and connect to the same network, everything works just fine. I have aprox. 20 MB/s downlink and 0.5MB/s uplink.

    Same happens with both Chrome and Firefox.
    I have experienced similar problem on two laptops and with many different distros, althought they all might have been GNOME.

    When I reload pages (even Ctrl+Shift+r), then usually they load normally. Not always thought.
    Not all pages seem to be affected, but I have not found a pattern yet. Will try to memorise pages, that do it and pages that don't.

    Has anyone seen something like that before?
    Where should I start debugging it?

    As much as I have tested so far, it does not seem to depend on wheter page uses https or not.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Some pages extremely slow to load

    On 2013-12-10 15:16, ervion wrote:
    > Where should I start debugging it?


    Change DNS server.

    Disable IPv6 on browser, or on entire system.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,846
    Blog Entries
    14

    Default Re: Some pages extremely slow to load

    Did you run an online update, i.e. install the latest updates, incl. flashplayer?

    Do you have this behaviour when connecting to other networks, i.e. other ISP's? Like Carlos indicates, some ISP's don't support IPv6 (or say they do where they actually don't), this can cause time-outs on internet requests. It can be turned of throug Yast - System - Sysconfig editor, needs a reboot to be effected.

    Another option you have is to edit the settings of your wifi access, through "Manage Connections".
    Set it to "DHCP - address only" and use 8.8.8.8 and 8.8.4.4 as DNS's (Google's free DNS servers), your router's IP as the gateway. Make sure that "Use IPv4" is checked.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Some pages extremely slow to load

    Updated entire system, configured wifi interface: DNS 8.8.8.8, 8.8.4.4; IPv6 method: ignore
    rebooted

    Facebook loaded immideately, but for excample en.opensuse.org/SDB:Skype page took over a minute to load.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •