Results 1 to 5 of 5

Thread: ungewolltes Update von 12.2. auf 13.1

  1. #1

    Default ungewolltes Update von 12.2. auf 13.1

    Hallo Leute,

    wie kann das passieren?? Ich hatte eine etwas ältere Version von einem Programm und startete daher "zypper up" um auch gleich andere Updates herunterzuladen. Bei ca. 1,3GB hab ich mir natürlich nicht alle Pakete angeschaut. Auf jeden Fall vollzog er ein Update von 12.2 auf 13.1 (inkl. Grub) das ich garnicht wollte!! Hinzu kam zu der Misere, dass zypper abgebrochen hat. Nun steh ich da mit einem Recher, NetworkMananger geht nicht mehr, ebenso Firefox, Chrome, Evolution etc. wegen fehlenden libs.
    Besteht die Möglichkeit das wieder rückgänig zu machen? Und überhaupt, seit wann wird bei einem Update von Programmen gleich eine neue Version von SuSE heruntergeladen?

    Viele Grüße

  2. #2

    Default Re: ungewolltes Update von 12.2. auf 13.1

    Quote Originally Posted by revilosun View Post
    wie kann das passieren??
    Von alleine passiert das nicht.
    Du musst irgendwie das 13.1 (oder Factory?) repo eingebunden haben.
    Meiner Meinung nach am Wahrscheinlichsten:
    Du hast auf einen 1-click Install geklickt, der für 13.1 oder Factory war. Der hat dann wegen der Abhängigkeiten das Repo eingebunden.
    Allerdings wird angezeigt, welche Repos hinzugefügt werden, man muss das noch manuell bestätigen...

    Besteht die Möglichkeit das wieder rückgänig zu machen?
    Das entsprechende Repo wieder entfernen (z.B. mit YaST->Software-Repositories) und dann "sudo zypper dup" in einem Terminal ausführen und hoffen, dass alles klappt. Wird allerdings schwierig, wenn der NetworkManager nicht funktioniert. Evtl. auf ifup umschalten in YaST?

    Oder von einem 12.2 Installationsmedium booten und "Upgrade einer bestehenden Installation" auswählen.

    Und überhaupt, seit wann wird bei einem Update von Programmen gleich eine neue Version von SuSE heruntergeladen?
    Wie gesagt, das wird es normalerweise nicht.
    Außer du fügst das Software-Repository der neuen Version zu deinem System hinzu. Dort hat natürlich alles eine höhere/neuere Version und wird deshalb als Update angeboten und installiert, falls _du_ es befiehlst.

  3. #3

    Default Re: ungewolltes Update von 12.2. auf 13.1

    Quote Originally Posted by wolfi323 View Post
    Von alleine passiert das nicht.
    Du musst irgendwie das 13.1 (oder Factory?) repo eingebunden haben.
    Meiner Meinung nach am Wahrscheinlichsten:
    Du hast auf einen 1-click Install geklickt, der für 13.1 oder Factory war. Der hat dann wegen der Abhängigkeiten das Repo eingebunden.
    Allerdings wird angezeigt, welche Repos hinzugefügt werden, man muss das noch manuell bestätigen...

    Bewusst nicht, aber da Du das ansprichst, unter den vielen 12.2-repos ist mir ein 13.1 aufgefallen, das stimmt. Muss da mal nachschauen was das genau ist. Das kann aber eigentlich nur ein optionales Paket sein, heute abend bin ich schlauer.




    Quote Originally Posted by wolfi323 View Post
    Das entsprechende Repo wieder entfernen (z.B. mit YaST->Software-Repositories) und dann "sudo zypper dup" in einem Terminal ausführen und hoffen, dass alles klappt. Wird allerdings schwierig, wenn der NetworkManager nicht funktioniert. Evtl. auf ifup umschalten in YaST?
    ifup -> ja das ging



    Dann versucht ich mal mit der 12.2-DVD und bete....

  4. #4

    Default Re: ungewolltes Update von 12.2. auf 13.1

    Puuh das hat funktioniert, vielen Dank nochmal wolfi.

    Aber wie das Repo da reinkam, ist mir wirklich schleierhaft. Unter den ganzen Repos war die originale 12.2-Distri aber auch die 13.1-Distri??????
    Habe dann die 13.1 gelöscht und mit zypper ein Downgrade gemacht. Nun gehen wieder alle Progs.

    Gruß

  5. #5

    Default Re: ungewolltes Update von 12.2. auf 13.1

    Quote Originally Posted by revilosun View Post
    Puuh das hat funktioniert, vielen Dank nochmal wolfi.
    Freut mich!

    Aber wie das Repo da reinkam, ist mir wirklich schleierhaft. Unter den ganzen Repos war die originale 12.2-Distri aber auch die 13.1-Distri??????
    Wie gesagt, für mich wär am Wahrscheinlichsten, dass du ein Paket für 13.1 mittels 1-click Install installiert hast. Das fügt standardmäßig die benötigten Repos (in dem Fall das 13.1 Oss Repo) zu deinem System hinzu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •