Results 1 to 5 of 5

Thread: Suse 13.1 Internet Connection Problem and using static IP address

  1. #1

    Default Suse 13.1 Internet Connection Problem and using static IP address

    One of my colleges recently installed Opensuse 13.1 on a machine within our work network. The machine was given a static ip address for potential server purposes and it worked fine in the office environment. However I get the machine home and I don't have internet connection. My home network's dhcp was a different ip but I changed it to reflect that of the office. At work office we had a 192 address and my home office had a 172 but I changed this in the router.

    The default gateway reflects a 192.168.1 and the static address on the machine is a 192.168.1.222 and I configured the routers range to be from .1 to .200 so that I would have room for other static addresses. I thought after speaking with my college today that it would have been a gateway issue but it doesn't appear to be to me but maybe I'm wrong and its that or something else entirely. By the way I can ping other machines in the network just fine and vise verse. I pretty new to Linux and opensuse 13.1 so where do I start? Thanks in advance for any help.

  2. #2
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Suse 13.1 Internet Connection Problem and using static IP address

    On 12/9/2013 11:06 PM, VisionAI wrote:
    >
    > One of my colleges recently installed Opensuse 13.1 on a machine within
    > our work network. The machine was given a static ip address for
    > potential server purposes and it worked fine in the office environment.
    > However I get the machine home and I don't have internet connection. My
    > home network's dhcp was a different ip but I changed it to reflect that
    > of the office. At work office we had a 192 address and my home office
    > had a 172 but I changed this in the router.
    >
    > The default gateway reflects a 192.168.1 and the static address on the
    > machine is a 192.168.1.222 and I configured the routers range to be from
    > ..1 to .200 so that I would have room for other static addresses. I
    > thought after speaking with my college today that it would have been a
    > gateway issue but it doesn't appear to be to me but maybe I'm wrong and
    > its that or something else entirely. By the way I can ping other
    > machines in the network just fine and vise verse. I pretty new to Linux
    > and opensuse 13.1 so where do I start? Thanks in advance for any help.
    >
    >

    VisionAI;

    Can you ping Google's DNS server by number?
    Code:
    ping -c3 8.8.8.8
    If the ping succeeds you need only add DNS servers. If you do not know what to use try using Google's. 8.8.8.8 and
    8.8.4.4.

    If the ping fails, post the results of:
    Code:
    ip addr
    ip route
    cat /etc/resolv.conf | grep nameserver
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  3. #3

    Default Re: Suse 13.1 Internet Connection Problem and using static IP address

    Thank for the reply! I didn't think to try anything outside of my local network. I'll change this and hopefully it will resolve the issue.

  4. #4

    Default Re: Suse 13.1 Internet Connection Problem and using static IP address

    That worked perfectly! Why did the standard 192.168.1.1 not work? Just would like to understand. Thanks again.

  5. #5
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Suse 13.1 Internet Connection Problem and using static IP address

    On 12/9/2013 11:46 PM, VisionAI wrote:
    >
    > That worked perfectly! Why did the standard 192.168.1.1 not work? Just
    > would like to understand. Thanks again.
    >
    >

    VisionAI;

    Glad to see you have it sorted out. I assume 192.168.1.1 is the private IP of your router and the router is not passing
    DNS requests upstream. Moreover, as you are not using dhcp, it is not assigning the IP of a name server to your machine.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •