Results 1 to 2 of 2

Thread: Samba connecting outside of domain

  1. #1

    Default Samba connecting outside of domain

    I'm running a clean install of openSUSE 13.1 x64. If I open Dolphin and navigate to smb:/ I can access PC's through domains. Any PC I can connect to using this method I can also access by IP, such as smb://192.168.72.41. The issue I run into is I need to connect to IBM iSeries systems on their IFS which was compatible with Samba on my last install of openSUSE 12.2. Since these are not on domains I use the syntax smb://user@192.168.72.2 and I get "Timeout on server". I want to mount these servers to local directories, which I also did before using sudo mount -t cifs //192.168.72.2/www/zendsvr6/htdocs /home/user/smb/sa -o username=<username>,password=<password> but since the upgrade I now get "mount error(6): No such device or address". I have started using active directory for authentication, and my PC is not a domain controller, but I have tried creating a local user and still run into the same issue.

  2. #2

    Default Re: Samba connecting outside of domain

    After looking into it I think we're running into this bug:
    https://bugzilla.redhat.com/show_bug.cgi?id=905996

    It seems that the system I'm trying to connect to is running an old version of Active Directory (IBM iSeries NetServer) that is only compatible with Samba 2 or 3. To test try this:
    Code:
    smbclient --list <server name or ip>
    After typing my password I get this:
    Code:
    Conversion error: Incomplete multibyte sequence()
    protocol negotiation failed: NT_STATUS_INVALID_PARAMETER
    As a short-term workaround I'm going to VM 12.3 so I can run Samba 3.6 and use it as a sort of buffer to span the large version gaps. Has anyone successfully accessed old Samba servers from openSUSE 13.1?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •