Results 1 to 6 of 6

Thread: KDEConnect and VLC

  1. #1

    Default KDEConnect and VLC

    Hi folks,

    Just wondering if I'm the only person who has almost soiled their trousers whilst experimenting with KDEConnect and VLC? When I try to change the media volume from the Android remote (whether up or down) the response from VLC is to max its volume, taking the system volume with it and causing a panicked lunge for the mute button.

    The behaviour is not duplicated with Amarok. VLC behaves itself as far as all the other media controls are concerned. Any suggestions?

    opensuse 12.3, android 4.2.2 on a sony Xperia Z, KDEConnect 0.4.2, VLC 2.1.0

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,671
    Blog Entries
    14

    Default Re: KDEConnect and VLC

    Is pulseaudio enabled? If so, disable it, reboot and try again. Not based on experience, just a thought since most of these dubious audio issues seem pulse related
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: KDEConnect and VLC

    Quote Originally Posted by Knurpht View Post
    Is pulseaudio enabled?
    Hi, thanks for giving this some thought. Yes, it seems so. I tried the command:

    Code:
    ps wwup `pgrep pulse`
    and got the response

    Code:
    USER    PID    %CPU  %MEM    VSZ      RSS   TTY      STAT  START   TIME COMMAND
    joff      5201  0.3      0.1        468144  8588  ?          S<l    11:02     0:02 /usr/bin/pulseaudio --start --log-target=syslog

    Quote Originally Posted by Knurpht View Post
    If so, disable it, reboot and try again.
    OK, did this using the instructions here: Ubuntu Tip: Turning PulseAudio On and Off - Overlapping Controls and Confusion - Tutorials - LinuxPlanet although I stopped after editing /etc/pulse/client.conf

    Rebooted, ran the first command again and got:

    Code:
    USER    PID    %CPU  %MEM    VSZ      RSS   TTY      STAT  START   TIME COMMAND
    joff      4744   0.2     0.1        467976  8384  ?          S<l     11:21    0:00 /usr/bin/pulseaudio --start
    No logging = pulseaudio stopped? Wasn't sure, so tested with VLC and unfortunately the problem still exists. Then realised I was following instructions geared toward Gnome not KDE, so did a bit more hunting and ran the command:

    Code:
    sudo setup-pulseaudio --disable
    Rebooted again, with the result that:

    1. I had to un-pair and re-pair the Android through KDEConnect before it would be recognised.
    2. The sound through VLC is appalling - like an badly tuned AM radio.
    3. I have two playback streams for VLC appearing in KDEMixer. One slider is set to max, the other about half way. If I move the slider that is half way in either direction, the volume in VLC itself is maxed. If then try to bring the maxed slider (in KDEMixer) down, the other one goes to max instead, and the volume setting in VLC stays at max. I did not notice these duplicated sliders before, but it doesn't mean they weren't there.


    Meanwhile Amarok still behaves itself impeccably.

    So I must have a dubious sound configuration... I am running a reasonably ancient USB external sound system (MS Digital Sound System 80), perhaps it is related to this.

    Any further suggestions will be appreciated, but for now I might just re-enable PulseAudio to see if I can get decent sound through VLC again, and be very careful when altering the volume!

  4. #4

    Default Re: KDEConnect and VLC

    Quote Originally Posted by rusticbench View Post
    OK, did this using the instructions here: Ubuntu Tip: Turning PulseAudio On and Off - Overlapping Controls and Confusion - Tutorials - LinuxPlanet although I stopped after editing /etc/pulse/client.conf
    Don't follow the instructions of a random Ubuntu article.
    On openSUSE pulseaudio is started on user login, not at boot. And as your output shows, it _is_ still running

    Anyway, it's _much_ easier to disable in openSUSE:
    Enter YaST->Hardware->Sound, click on "Other" and choose "PulseAudio Configuration", then remove the checkmark on "Enable PulseAudio"...

  5. #5

    Default Re: KDEConnect and VLC

    Quick follow up - the appalling sound in VLC was due to VLC's volume going to max, whilst the system volume was low. If I can keep the VLC internal volume down and get the system volume up the sound quality is fine.

  6. #6

    Default Re: KDEConnect and VLC

    Quote Originally Posted by wolfi323 View Post
    Don't follow the instructions of a random Ubuntu article.
    Point taken, unfortunately I've got into the habit of doing this over the years as it has often got me moving in the right direction (or at least a direction that seems to be an improvement over being able to do nothing, I never really know whether it is the right one or not ).

    Quote Originally Posted by wolfi323 View Post
    Enter YaST->Hardware->Sound, click on "Other" and choose "PulseAudio Configuration", then remove the checkmark on "Enable PulseAudio"...
    Thankyou, that is much simpler! Done this and can confirm that the check is absent, so I managed to bring it down with that second command by the look of it. So definitely no pulse, but still have the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •