Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

  1. #1

    Default Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    The following is the error message I receive when attempting to play this URL. I did install codec's from packman.


    gstffmpegdec.c(2213): gst_ffmpegdec_audio_frame (): /GstPlayBin2layer/GstURIDecodeBin:uridecodebin35/GstDecodeBin2:decodebin235/ffdec_aac:ffdec_aac35: Decoding of AAC stream by FFMPEG failed.

    I'm new to linux, so I'm trying to learn albeit slowly and painfully at times.

    Chuck H.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    You mean you followed this
    https://forums.opensuse.org/blogs/ca...ion-guide-149/
    Assuming you have version 13.1??
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Rural Australia
    Posts
    301

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    When lookt at : Triton Digital - Richer Media

    view:

    We've Moved!

    The requested URL was not found on this server.
    Please visit our new website TritonDigital.com or click below to log in to the appropriate Console to find the requested infomration:



    Both Console sites required login details.

  4. #4
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    Quote Originally Posted by chaat View Post
    The following is the error message I receive when attempting to play this URL. I did install codec's from packman.


    gstffmpegdec.c(2213): gst_ffmpegdec_audio_frame (): /GstPlayBin2layer/GstURIDecodeBin:uridecodebin35/GstDecodeBin2:decodebin235/ffdec_aac:ffdec_aac35: Decoding of AAC stream by FFMPEG failed.

    I'm new to linux, so I'm trying to learn albeit slowly and painfully at times.

    Chuck H.
    I have this same error today.
    My guess is that ffmpeg is not compiled with aac support for whatever reason or there is some missing aac python lib.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  5. #5
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    Quote Originally Posted by anika200 View Post
    I have this same error today.
    My guess is that ffmpeg is not compiled with aac support for whatever reason or there is some missing aac python lib.
    Yes this is an ffmpeg problem/option provided by the openSUSE build of the program.
    Here is the version compiled with openSUSE 13.1, notice there is no aac support except for "--enable-libvo-aacenc" which is video in/out thing.
    Code:
    lee@linux-aa3c:~> ffmpeg --versionffmpeg version 2.1.1 Copyright (c) 2000-2013 the FFmpeg developers
      built on Nov 27 2013 18:31:36 with gcc 4.8 (SUSE Linux)
      configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --disable-static --enable-debug --disable-stripping --extra-cflags='-fmessage-length=0 -grecord-gcc-switches -fstack-protector -O2 -Wall -D_FORTIFY_SOURCE=2 -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm' --enable-gpl --enable-x11grab --enable-version3 --enable-pthreads --enable-avfilter --enable-libpulse --enable-libvpx --enable-libopus --enable-libass --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-libx264 --enable-libschroedinger --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-postproc --enable-libdc1394 --enable-librtmp --enable-libfreetype --enable-avresample --enable-libtwolame --enable-libvo-aacenc --enable-gnutls
      libavutil      52. 48.101 / 52. 48.101
      libavcodec     55. 39.101 / 55. 39.101
      libavformat    55. 19.104 / 55. 19.104
      libavdevice    55.  5.100 / 55.  5.100
      libavfilter     3. 90.100 /  3. 90.100
      libavresample   1.  1.  0 /  1.  1.  0
      libswscale      2.  5.101 /  2.  5.101
      libswresample   0. 17.104 /  0. 17.104
      libpostproc    52.  3.100 / 52.  3.100
    There should be at least one of the several options as listed on the ffmpeg wiki.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  6. #6

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    Quote Originally Posted by anika200 View Post
    Yes this is an ffmpeg problem/option provided by the openSUSE build of the program.
    Here is the version compiled with openSUSE 13.1, notice there is no aac support except for "--enable-libvo-aacenc" which is video in/out thing.
    That's wrong.
    ffmpeg _is_ compiled with AAC decoding support, and with support for 2 AAC encoders (libvo-aacenc as you mention yourself which is _not_ a video in/out thing but an audio aac encoder; and it's own experimental one, faac is missing though)

    Have a look at "ffmpeg --codecs" to see for yourself which codecs are included.

  7. #7
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    I forgot to mention, I am compiling everything now to test some things and should be able to post some work around.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  8. #8
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    Quote Originally Posted by wolfi323 View Post
    That's wrong.
    ffmpeg _is_ compiled with AAC decoding support, and with support for 2 AAC encoders (libvo-aacenc as you mention yourself which is _not_ a video in/out thing but an audio aac encoder; and it's own experimental one, faac is missing though)

    Have a look at "ffmpeg --codecs" to see for yourself which codecs are included.
    I get the same output as from the command "ffmpeg --version" which I already mentioned.
    There are two encoders and one is video and the other is "experimental" and "missing" so this does not help with our audio problem as described in the thread.

    We have no streaming aac from ffmpeg on 13.1 as far as I can detect.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  9. #9

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    Quote Originally Posted by anika200 View Post
    I get the same output as from the command "ffmpeg --version" which I already mentioned.
    There are two encoders and one is video and the other is "experimental" and "missing" so this does not help with our audio problem as described in the thread.

    We have no streaming aac from ffmpeg on 13.1 as far as I can detect.
    What are you talking about?

    First, there is _no_ such thing as AAC _video_, AAC is the abbreviation of Advanced Audio Coding after all.

    Then, see here: (this is ffmpeg from Packman)
    Code:
    # ffmpeg -codecs | grep -i aac
    ffmpeg version 2.1.1 Copyright (c) 2000-2013 the FFmpeg developers
      built on Nov 27 2013 18:31:36 with gcc 4.8 (SUSE Linux)
      configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --disable-static --enable-debug --disable-stripping --extra-cflags='-fmessage-length=0 -grecord-gcc-switches -fstack-protector -O2 -Wall -D_FORTIFY_SOURCE=2 -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm' --enable-gpl --enable-x11grab --enable-version3 --enable-pthreads --enable-avfilter --enable-libpulse --enable-libvpx --enable-libopus --enable-libass --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-libx264 --enable-libschroedinger --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-postproc --enable-libdc1394 --enable-librtmp --enable-libfreetype --enable-avresample --enable-libtwolame --enable-libvo-aacenc --enable-gnutls
      libavutil      52. 48.101 / 52. 48.101
      libavcodec     55. 39.101 / 55. 39.101
      libavformat    55. 19.104 / 55. 19.104
      libavdevice    55.  5.100 / 55.  5.100
      libavfilter     3. 90.100 /  3. 90.100
      libavresample   1.  1.  0 /  1.  1.  0
      libswscale      2.  5.101 /  2.  5.101
      libswresample   0. 17.104 /  0. 17.104
      libpostproc    52.  3.100 / 52.  3.100
     DEA.L. aac                  AAC (Advanced Audio Coding) (encoders: aac libvo_aacenc )
     D.A.L. aac_latm             AAC LATM (Advanced Audio Coding LATM syntax)
    "DEA.L. aac" means that there is an aac Decoder _and_ Encoder compiled in. In fact there are even _two_ encoders as can be seen in the brackets, namely "aac" and "libvo_aacenc" (and again, this is _no_ video encoder)

  10. #10
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Radio Tray error on this URL http://provisioning.streamtheworld.com/pls/WLSFMAAC.pls

    I believe I am making some headway on this issue, maybe some can find it useful or help me out with some info.

    First off, streaming aac audio via ffmpeg from anywhere into/out from openSUSE 13.1 does not work. No matter the claims otherwise.

    I have a suspicion it has something to do with this
    Code:
    [FFmpeg-user] --enable-libfdk-aac - not recognized
    
    Carl Eugen Hoyos cehoyos at ag.or.at 
    Sat Jan 12 20:17:43 CET 2013
    Previous message: [FFmpeg-user] --enable-libfdk-aac - not recognized
    
    Please understand that it is not legal (copyright-wise) 
    to distribute a FFmpeg binary that is compiled against 
    x264 and libfaac or libfdk at the same time.
    (x264 is GPL and you cannot fulfill the rules of the 
    GPL for faac and libfdk because they are not free 
    software.)
    
    
    For mono and stereo the native aac encoder should at 
    least produce acceptable quality.
    
    
    Carl Eugen
    So my guess is that the third party multimedia codec install totally misses the need for streaming aac audio and the libs needed.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •