Results 1 to 6 of 6

Thread: GUFW/UFW firewall troubles

  1. #1

    Default GUFW/UFW firewall troubles

    Hi folks, not new to Linux but rather new to opensuse. I'm using opensuse 13.1.

    I can not get gufw to load on start up with my few rules I use on other Linux OS.

    I only have a few rules which are to Deny all in and out.

    Then I load my rules as follow.

    To Action From
    -- ------ ----
    80/tcp ALLOW OUT Anywhere
    443/tcp ALLOW OUT Anywhere
    25/tcp ALLOW OUT Anywhere
    110/tcp ALLOW OUT Anywhere
    143/tcp ALLOW OUT Anywhere
    67/udp ALLOW OUT Anywhere
    68/udp ALLOW OUT Anywhere
    123/udp ALLOW OUT Anywhere
    53 ALLOW OUT Anywhere
    631 ALLOW OUT Anywhere
    515 ALLOW OUT Anywhere
    1194 ALLOW OUT Anywhere

    My post at GUFW.

    I went to the GUFW site and posted a question and it seems I am not getting to far with it, hoping someone who used or tried gufw can view the post and maybe give me a few suggestions. Many Thanks for your time.

  2. #2
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    130

    Default Re: GUFW/UFW firewall troubles

    Hi sammiev,

    You do know that openSUSE has got a built-in firewall, do you?
    You can set up the firewall in YaST (or switch it off if you want to use a different firewall).
    I can't help you with GUFW but I don't think you actually need it.

    Best regards

    Kasi

  3. #3

    Default Re: GUFW/UFW firewall troubles

    Quote Originally Posted by kasi042 View Post
    Hi sammiev,

    You do know that openSUSE has got a built-in firewall, do you?
    You can set up the firewall in YaST (or switch it off if you want to use a different firewall).
    I can't help you with GUFW but I don't think you actually need it.

    Best regards

    Kasi
    Hi Kasi, I thank you for your reply. I see from my link above that GUFW is still looking into my problem.
    I took a shine to opensuse lately and moved it to my main OS as I test usually per released OS.
    Yast is very new to me but what I like about GUFW is that I can export my rules and load them into most other OS.
    Usually I have most OS fully running with all my applications wanted with 10 to 15 min after loading the new OS.
    I may just have to learn the yast firewall after all.
    Thanks

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GUFW/UFW firewall troubles

    On 2013-12-07 19:26, sammiev wrote:

    > I may just have to learn the yast firewall after all.


    I see all your rules are egression rules. The SuSEfirewall2 allows you
    "out" on all ports, and "in" on none, till you open them.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Default Re: GUFW/UFW firewall troubles

    Quote Originally Posted by robin_listas View Post
    On 2013-12-07 19:26, sammiev wrote:

    > I may just have to learn the yast firewall after all.


    I see all your rules are egression rules. The SuSEfirewall2 allows you
    "out" on all ports, and "in" on none, till you open them.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    Thanks Carlos E. R. glad to hear all ports in are closed.

  6. #6

    Default Re: GUFW/UFW firewall troubles

    Found this on another site posted by handy and it works.

    Required & important Terminal commands follow:

    After installing (g)ufw, you must run the following command. You won't need to do it twice:

    Code: [Select]
    sudo ufw enable
    The next Terminal command enables ufw (on our systemd machines):

    Code: [Select]
    systemctl enable ufw

    This command starts ufw:

    Code: [Select]
    systemctl start ufw
    Run the following command at any time to view your IPTable rules:

    Code: [Select]
    ufw status
    For more information on ufw enter the following command into the Terminal:

    Code: [Select]
    man ufw

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •