Results 1 to 3 of 3

Thread: What's the deal with Python 3?

  1. #1

    Default What's the deal with Python 3?

    Is it even possible to use it in OpenSuse? I can't find it in YAST, so I'm guessing I need to add a special repo?

    Also, I downloaded the tarball provided on the python website for 3.3, extracted it, opened the directory in terminal and tried to follow the directions in the readme which went something like:

    ./configure
    make
    make install

    but I kept getting "command not found" for all three instructions! Is that normal? Does everyone who installs OpenSuse 12.3 have this issue?

  2. #2

    Default Re: What's the deal with Python 3?

    Quote Originally Posted by newtonian_fig View Post
    Is it even possible to use it in OpenSuse? I can't find it in YAST, so I'm guessing I need to add a special repo?
    No, python3 is included in the standard repo.
    It should be there in YaST. Type "python3" into the search field. You need "python3-base" as well, but this should be installed automatically.

    And you can run it with "python3".

    Also, I downloaded the tarball provided on the python website for 3.3, extracted it, opened the directory in terminal and tried to follow the directions in the readme which went something like:

    ./configure
    make
    make install

    but I kept getting "command not found" for all three instructions! Is that normal? Does everyone who installs OpenSuse 12.3 have this issue?
    Then you don't have the necessary tools installed.
    You need the package "make" to run make of course, but you likely also miss the compiler and other necessary packages as well.
    So better install the C/C++ development pattern in YaST (View->Patterns).

    configure should be included in the python tarball though, but maybe you have to generate it first. Are you sure you followed the included instructions? (exactly, not "something like" )
    And did you change the current directory to the extracted folder?

    But it would be better to just use the included version anyway...

  3. #3

    Default Re: What's the deal with Python 3?

    On 2013-12-07, newtonian fig <newtonian_fig@no-mx.forums.opensuse.org> wrote:
    >
    > Is it even possible to use it in OpenSuse? I can't find it in YAST, so
    > I'm guessing I need to add a special repo?


    Try console installation:

    Code:
    sh-4.2$ su -c "zypper in python3"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •