Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

  1. #1

    Default Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    Hi,

    I just updated to 13.1 from 12.3. My installation language is english (UK) and
    my keyboard is Switzerland (french).

    I remarked two things:

    1) When updating to 13.1, the keyboard is always resetting itself to the default one (us)
    when I reboot the machine. I always have to do:
    Yast -> Hardware -> System Keyboard Layout -> French (Switzerland)
    every time I login to have my keyboard layout. It seems that Yast is not registering
    my change permanetly.

    As a turnaround solution, I added a line to my .bashrc file as
    # set the keyboard to swiss french
    setxkbmap -layout ch -variant fr

    But I have to remember when to login that I have to use the "us" layout when
    entering my account password.

    Is there a solution to this problem?

    2) I am using also emacs as an editor and have an alias for emacs as:
    alias e='emacs -fn "-misc-fixed-medium-r-semicondensed--13-*-*-*-c-60-iso8859-1"'
    this was working for the last twenty years on different unixes. It was working on all
    previous versions of SuSE and opensuse (starting from 1997 on my side).

    But when updating to 13.1, I am getting the message:
    Font `-misc-fixed-medium-r-semicondensed--13-*-*-*-c-60-iso8859-1' is not defined

    When adding the "-q" option to emacs, I am getting the same message while using "-Q"
    emacs launchs but without processing X resources. This means that x.org is buggy
    somewhere.

    What I am missing here?

    Thank you.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    What desktop? Did you make you keyboard selection in the desktop configuration?

    EMACS maybe a missing font??

  3. #3

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    My desktop is KDE. I made the selection the keyboard layout selection with Yast as explained.

    For emacs, when I add "-Q" to options, I get the right display but without any X resources,
    Without "-Q", I got the message that the font is not defined.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacsfonts.

    On 2013-12-05 12:56, Genfer wrote:
    >
    > Hi,
    >
    > I just updated to 13.1 from 12.3.


    How? Which type of upgrade? Online upgrade (zypper dup) or offline
    upgrade (DVD)? Or fresh install on top of the old one?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    Well, I made a first update with DVD network update. I was getting the same problems as explained then I made a new installation
    with a full DVD. And yes I did a md5 checksum of the DVD.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacsfonts.

    On 2013-12-06 00:06, Genfer wrote:
    >
    > Well, I made a first update with DVD network update. I was getting the
    > same problems as explained then I made a new installation
    > with a full DVD. And yes I did a md5 checksum of the DVD.


    I don't recognize that upgrade method. There are two:

    1) Boot the full DVD, then choose "upgrade system" instead of "install
    system". This is the Offline System Upgrade Method.

    2) Run a zypper dup with the new repos. This is the Online System
    Upgrade Method.

    There is a variant of the zypper dup method in which the dvd is used as
    static repository source, instead of using internet.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #7

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    So you didn't have that keyboard problem with 12.3?
    And the layout is written correctly to /etc/sysconfig/keyboard?

    There apparently is a problem like this with specific keyboard models (there's a bug report) but that was already the case with 12.3.

    What graphics card do you have?
    I know of somebody who had the same problem (amongst others) after installing 13.1, for him it was fixed after installing the proprietary fglrx driver (apparently radeon was causing this and his other problems... )

    Regarding Emacs, I cannot really say anything, except that I get the same error when running your line.
    If you think this is a bug, please report it at http://bugzilla.novell.com/ (same username/password as here).

  8. #8

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    I haven't any problem with 12.3.

    My graphic card is a NVIDIA GTX 660 Ti and I installed the latest driver from NVIDIA web site (through "sh NVIDIA-Linux-x86_64-331.20.run"). I have also
    dual monitors for a while.

    The content of /etc/sysconfig/keyboard (I deleted the comments)
    KEYTABLE="fr_CH-latin1.map.gz"
    KBD_DELAY=""
    KBD_RATE=""
    KBD_NUMLOCK="bios"
    KBD_SCRLOCK="no"
    KBD_CAPSLOCK="no"
    KBD_DISABLE_CAPS_LOCK="no"
    KBD_TTY=""
    COMPOSETABLE="clear latin1.add"
    YAST_KEYBOARD="french-ch,pc104"

    As I explained before, I added a command to .bashrc to have a Swiss french keyboard layout but I have to remember to use the "us" layout
    to login (which means the system is with the "us" keyboard).

    The emacs alias was used for twenty years without any error.

    Thank you again for your help.

  9. #9

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    The values in /etc/sysconfig/keyboard was set by the system.

  10. #10

    Default Re: Update to 13.1: Always reset keyboard to "us" layout and emacs fonts.

    Quote Originally Posted by Genfer View Post
    As I explained before, I added a command to .bashrc to have a Swiss french keyboard layout but I have to remember to use the "us" layout
    to login (which means the system is with the "us" keyboard).
    You don't have to do that in .bashrc.
    Just set the keyboard in your desktop's keyboard settings as already suggested (for KDE: Configure Desktop->Hardware->Input Devices->Keyboard).
    This won't help for the login screen of course.

    Does the xdm init script generate a /etc/X11/xorg.conf.d/90-keytable.conf with the correct content?

    Do you have the correct layout when you switch to text mode? (Ctrl+Alt+F1)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •