Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Static IP doesn't take effect after reboot

  1. #1

    Default Static IP doesn't take effect after reboot

    Yesterday i had do a "zypper up" remoted
    and then i reboot the server.
    the connection lost

    then i went to the data center and check on the server,
    found out that the IP for eth0 and eth1 all gone.

    i checked in YAST, both cards the settings still remain there
    but in "ifconfig", it shows nth.....

    any idea what cause this to happen ?

    how do i get the static ip working again ?

  2. #2

    Default Re: Static IP doesn't take effect after reboot

    lordlaw wrote:
    > Yesterday i had do a "zypper up" remoted
    > and then i reboot the server.
    > the connection lost
    >
    > then i went to the data center and check on the server,
    > found out that the IP for eth0 and eth1 all gone.
    >
    > i checked in YAST, both cards the settings still remain there
    > but in "ifconfig", it shows nth.....
    >
    > any idea what cause this to happen ?
    >
    > how do i get the static ip working again ?


    What OS version? What is 'nth.....'? Please post code output

  3. #3

    Default Re: Static IP doesn't take effect after reboot

    OS Version 12.1
    CodeName: Asparagus

    #ifconfig
    eth0 inet addr: 192.168.1.110 Bcast:192.168.1.255 Mask:255.255.255.0


    in YAST
    eth0

    (x) Statically assigned IP Address

    IP Address
    203.226.159.244 / 28


    **************************************

    between, just now i tried

    #ifconfig eth0 203.223.159.244 netmask 255.255.255.240

    it works. but when i reboot. the IP gone missing again.

    looks like it cant bind the static ip.

  4. #4

    Default AW: Re: Static IP doesn't take effect after reboot

    Quote Originally Posted by lordlaw View Post
    OS Version 12.1
    CodeName: Asparagus

    #ifconfig
    eth0 inet addr: 192.168.1.110 Bcast:192.168.1.255 Mask:255.255.255.0


    in YAST
    eth0

    (x) Statically assigned IP Address

    IP Address
    203.226.159.244 / 28


    **************************************

    between, just now i tried

    #ifconfig eth0 203.223.159.244 netmask 255.255.255.240

    it works. but when i reboot. the IP gone missing again.

    looks like it cant bind the static ip.
    Is the IP address written to /etc/sysconfig/network/ifcfg-eth0? (probably, since YaST does show it correctly)

    Is some dhcp client running?
    Code:
    ps aux |egrep "(dh|dhcp)"

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Static IP doesn't take effect after reboot

    A shot in the dark is that you might have Network Manager configured to run instead of "Classic IFUP/IFDOWN" -- That would be a setting which would change your connection type on next boot if <you're certain> you've configured your static connection properly.
    In fact, if you have a Desktop installed, you might search to see if any NM packages are installed... Obviously if you're not using NM, those packages can probably be removed safely.

    Or,
    An alternative might be to go ahead and use Network Manager, just set up a network connection with a static address and be sure that "system startup" (or similar) is checked for your connection to be active on boot instead of on logon (which is default).

    HTH,
    TSU

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,681
    Blog Entries
    3

    Default Re: Static IP doesn't take effect after reboot

    Quote Originally Posted by lordlaw View Post
    any idea what cause this to happen ?
    This probably has to do with a changed scheme for naming network devices. Check whether release-notes says anything relevant.

    You can probably get things working with NetworkManager, since how that works is not name-dependent.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: AW: Re: Static IP doesn't take effect after reboot

    Quote Originally Posted by wolfi323 View Post
    Is the IP address written to /etc/sysconfig/network/ifcfg-eth0? (probably, since YaST does show it correctly)

    Is some dhcp client running?
    Code:
    ps aux |egrep "(dh|dhcp)"
    i had tried check the /etc/sysconfig/network/ifcfg-eth0, the value in the file remain unchanged even after i use the ifconfig to change the ip value.

    i run the
    Code:
    ps aux |egrep "(dh|dhcp)"
    it give me some results, not sure what it mean

    Code:
    #ps aux |egrep "(dh|dhcp)"
    root 2351 0.0 0.1 8288 5796 ? S 09:10 0:00 /sbin/dhclient -d -4 -sf /usr/lib/nm-dhcp-client.action -pf /var/run/dhclient-eth1.pid -lf /var/lib/dhcp/dhclient-253fcba-edc9-4b22-861e-ff6a28bfdfac-eth1.lease -cf /var/run/nm-dhclient-eth1.conf eth1
    root 3096 0.0 0.0 2576 768 tty1 S+ 10:10 0:00 egrep --color=auto (dh|dhcp)



    Quote Originally Posted by tsu2 View Post
    A shot in the dark is that you might have Network Manager configured to run instead of "Classic IFUP/IFDOWN" -- That would be a setting which would change your connection type on next boot if <you're certain> you've configured your static connection properly.
    In fact, if you have a Desktop installed, you might search to see if any NM packages are installed... Obviously if you're not using NM, those packages can probably be removed safely.

    Or,
    An alternative might be to go ahead and use Network Manager, just set up a network connection with a static address and be sure that "system startup" (or similar) is checked for your connection to be active on boot instead of on logon (which is default).

    HTH,
    TSU

    using YAST > network device > network card setup
    i had checked, Activate device is "At Boot Time"


    Quote Originally Posted by nrickert View Post
    This probably has to do with a changed scheme for naming network devices. Check whether release-notes says anything relevant.

    You can probably get things working with NetworkManager, since how that works is not name-dependent.
    i checked also on the YAST > Support > Release note

    not found anything related to network device naming.

    but the release note showed version 12.3, but my OS is 12.1
    and it only mention regarding to no network after installation....guess that one is not related to my problem....

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Static IP doesn't take effect after reboot

    On 2013-12-04 20:36, nrickert wrote:
    >
    > lordlaw;2605133 Wrote:
    >> any idea what cause this to happen ?

    >
    > This probably has to do with a changed scheme for naming network
    > devices. Check whether release-notes says anything relevant.


    He did not say he is using 13.1.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Static IP doesn't take effect after reboot

    On 2013-12-05 03:26, lordlaw wrote:


    > it give me some results, not sure what it mean
    >
    >
    > Code:
    > --------------------
    >
    > #ps aux |egrep "(dh|dhcp)"
    > root 2351 0.0 0.1 8288 5796 ? S 09:10 0:00 /sbin/dhclient -d -4 -sf /usr/lib/nm-dhcp-client.action -pf /var/run/dhclient-eth1.pid -lf /var/lib/dhcp/dhclient-253fcba-edc9-4b22-861e-ff6a28bfdfac-eth1.lease -cf /var/run/nm-dhclient-eth1.conf eth1
    > root 3096 0.0 0.0 2576 768 tty1 S+ 10:10 0:00 egrep --color=auto (dh|dhcp)
    >
    > --------------------
    >


    Well, you do have a dhcp client running, which should be there. That's
    your problem, find out why.

    Probably started by network manager (see the filename).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  10. #10

    Default Re: Static IP doesn't take effect after reboot

    Quote Originally Posted by robin_listas View Post
    On 2013-12-05 03:26, lordlaw wrote:
    Well, you do have a dhcp client running, which should be there. That's
    your problem, find out why.

    Probably started by network manager (see the filename).
    I just now tried to find anything related to Network Manager,
    but seem like that network manager not working in my server.

    so you mean i should disable the network manager ?

    sorry, i am very new to linux and i am just a merely programmer who know nth bout OS.
    now trying to learn.......

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •