Results 1 to 8 of 8

Thread: OpenSUSE 13.1 - KDE hangs at login

  1. #1
    Join Date
    Jan 2009
    Location
    Near Utrecht
    Posts
    8

    Default OpenSUSE 13.1 - KDE hangs at login

    Hi,

    Since I installed some updates on monday I can't login in KDE anymore. Icewm works normal and I can login on KDE via VNC.

    I installed these updates. When I try to login the system doesnt react for a few seconds and I see the messages in the message log that say that say there was a soft lockup and the cpu was stuck for 22 seconds with the process number of Xorg en kwin. Here you can find the Xorg.0.log.

    The system is OpenSUSE 13.1 x86-64.

    I hope this is enough information to help me in the right direction to solve this problem.

    Regards,
    Arjan

  2. #2

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    Quote Originally Posted by Arjanjnl View Post
    Since I installed some updates on monday I can't login in KDE anymore. Icewm works normal and I can login on KDE via VNC.

    I installed these updates. When I try to login the system doesnt react for a few seconds and I see the messages in the message log that say that say there was a soft lockup and the cpu was stuck for 22 seconds with the process number of Xorg en kwin. Here you can find the Xorg.0.log.
    There was a problem with the pulseaudio update, so that most likely causes your problem.
    It has been removed from update repo again, but since you already installed it, you have to switch back the affected packages to the versions from the standard repo manually.
    The packages should be shown as red in YaST->Software Management, right-click on all of them and select "Update Unconditionally".

    If you want to know more details, see here:
    https://bugzilla.novell.com/show_bug.cgi?id=853383

  3. #3
    Join Date
    Jan 2009
    Location
    Near Utrecht
    Posts
    8

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    I tried your suggestion but I still get the same result.

    In the bug report there is talk about 32bit installations. I have a 64bit installation.

  4. #4

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    Quote Originally Posted by Arjanjnl View Post
    I tried your suggestion but I still get the same result.

    In the bug report there is talk about 32bit installations. I have a 64bit installation.
    Right, only 32bit systems are affected by this. Sorry, I overlooked that you mentioned having a 64bit system.

    Can you maybe try switching off PulseAudio completely? (YaST->Hardware->Sound->Other->PulseAudio Configuration)

    Maybe try to roll back the other updated packages from the list you posted to the versions from the standard repo as well?
    You could then try to install the updates one by one to find out which one causes the issue.

    OTOH you are using nouveau, maybe that causes it? (would be strange though, since it worked before, but your messages would also point to nouveau)
    You could try to install the proprietary nvidia driver. Unfortunately the official repo still doesn't exist for 13.1, but you could use this one:
    DKMS + NVIDIA 331.20 on openSUSE - Blogs - openSUSE Forums

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,590
    Blog Entries
    14

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    The kernel reports inconsistency for both kernel-default and kernel-desktop, caused by the openvswitch kmp packages.
    First: why are both kernels installed?
    Second: what's the openvswitch
    Third: please post output of
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    Me feel it might be something to do with

    install|openvswitch-kmp-desktop

    install|openvswitch-kmp-default



    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    Quote Originally Posted by Knurpht View Post
    The kernel reports inconsistency for both kernel-default and kernel-desktop, caused by the openvswitch kmp packages.
    First: why are both kernels installed?
    And since you are booting kernel-default in you Xorg.0.log, try choosing kernel-desktop in the boot menu ("Advanced Options"). Does it work then?
    You would just have to uninstall kernel-default (and openvswitch-kmp-default) in that case to get a working system again...

  8. #8
    Join Date
    Jan 2009
    Location
    Near Utrecht
    Posts
    8

    Default Re: OpenSUSE 13.1 - KDE hangs at login

    Thank you for all you suggestions.

    The reason I have the default and the desktop kernel is that I never bothered to remove the desktop kernel.

    Here is the output of zypper lr -d.
    Code:
    # | Alias                  | Name                         | Enabled | Refresh | Priority | Type   | URI                                                                               | Service
    --+------------------------+------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
    1 | isv:ownCloud:community | isv:ownCloud:community       | Yes     | Yes     |  150     | rpm-md | http://download.opensuse.org/repositories/isv:/ownCloud:/community/openSUSE_13.1/ |        
    2 | repo-13.1-debug        | openSUSE-13.1 Debug          | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/13.1/repo/oss/                                 |        
    3 | repo-13.1-debug-update | openSUSE-13.1 Debug Updates  | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                                   |        
    4 | repo-13.1-non-oss      | openSUSE-13.1 Non-OSS        | Yes     | Yes     |   10     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                      |        
    5 | repo-13.1-oss          | openSUSE-13.1 OSS            | Yes     | Yes     |   10     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                          |        
    6 | repo-13.1-source       | openSUSE-13.1 Source         | No      | No      |   99     | NONE   | http://download.opensuse.org/source/13.1/repo/oss/                                |        
    7 | repo-13.1-update       | openSUSE-13.1 Updates        | Yes     | Yes     |   10     | rpm-md | http://download.opensuse.org/update/13.1/                                         |        
    8 | repo-update-non-oss    | openSUSE-13.1-Update-Non-Oss | Yes     | Yes     |   10     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                 |
    I removed openvswitch, I only used it for a test, but it didn't solve the problem.
    Booting with the desktop kernel didn't solve the problem either. Because I didn't use the desktop kernel I also removed it.
    Disabling pluseaudio also didn't solve it.

    The solution to the problem was installing the NVidia drivers.

    Now I just need to find the reason why the nouveau drivers stopped working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •