Results 1 to 6 of 6

Thread: how to kill ipv6 from root command line?

  1. #1
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default how to kill ipv6 from root command line?

    I have been having the usual struggle getting the laptop to surf after upgrading from 12.3 to 13.1 on an old X31 ThinkPad. Only Apper does updates and that lets me know that ipv6 must be working and sites that don't use it don't work, I think. I have set ipv6 not to work in network manager. I have usually used ifup in order to avoid using network manager in the past but that method does not work this time because it says that it needs some services that are unavailable. If I plug in a LAN cable it surfs. It is wireless that is causing me trouble. The wifi uses an Intel chip and I also have used a Ralink chip based wifi card in the past but it is not surfing now either... I have tried both DHCP and manual set up of the ip address in Network Management settings.

    If I was a cynic I would think that the recurring network issues each generation of software are meant to keep desktop Linux from becoming popular... (Just a joke.) Should I delete network manager from packages and reboot and try to get ifup to work or what? I renamed the random name assigned to the wifi as wlan0 per previous generations. Does this matter?

    KDE desktop
    X31 thinkpad with Intel 2200 BG Calexico 2 wifi chipset
    suse 13.1

    cheers...

    zxr250cc

  2. #2

    Default Re: how to kill ipv6 from root command line?

    If you want to disable IPv6 then do so within Yast regardless of your use
    of network manager or the "traditional" ifup stuff. Run this and then
    under a General or Global tab or something uncheck the 'Enable IPv6'
    option and reboot (required):

    Code:
    --------------------
    sudo /sbin/yast lan
    --------------------

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: how to kill ipv6 from root command line?

    zxr250cc wrote:
    >
    > I have been having the usual struggle getting the laptop to surf after
    > upgrading from 12.3 to 13.1 on an old X31 ThinkPad. Only Apper does
    > updates and that lets me know that ipv6 must be working and sites that
    > don't use it don't work, I think. I have set ipv6 not to work in network
    > manager. I have usually used ifup in order to avoid using network
    > manager in the past but that method does not work this time because it
    > says that it needs some services that are unavailable. If I plug in a
    > LAN cable it surfs. It is wireless that is causing me trouble. The wifi
    > uses an Intel chip and I also have used a Ralink chip based wifi card in
    > the past but it is not surfing now either... I have tried both DHCP and
    > manual set up of the ip address in Network Management settings.
    >
    > If I was a cynic I would think that the recurring network issues each
    > generation of software are meant to keep desktop Linux from becoming
    > popular... (Just a joke.) Should I delete network manager from packages
    > and reboot and try to get ifup to work or what? I renamed the random
    > name assigned to the wifi as wlan0 per previous generations. Does this
    > matter?
    >
    > KDE desktop
    > X31 thinkpad with Intel 2200 BG Calexico 2 wifi chipset
    > suse 13.1
    >
    > cheers...
    >
    > zxr250cc
    >
    >

    you can disable ipv6 in gecko based browsers(firefox,seamonkey) using
    about:config. search for ipv6 in about:config

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop

  4. #4
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default Re: how to kill ipv6 from root command line?

    I have to confess I can't understand your instructions for modifying Firefox settings to disable ipv6.

    I am typing this with another computer using 12.3 on an old T23 ThinkPad and using Network Manager on it. I automatically removed NM in the past (also apper) and used ifup for the wifi and had no trouble. I am using NM on the T23 because it works. In the past on the same laptop it didn't but ifup did. Since NM is working I am using it.

    I logged into the forum with the X31 and because OpenSUSE are using ipv6, I believe, I am able to read the forum. I am unable to log in however to make this post because I believe attachmate are only using ipv4 and the x31 cannot connect to log in. These are the sort of quirks that have made me RANT about networking in the past in both Mandriva/Mageia and SUSE forums... Until ipv6 is actually fully turned on for the whole web the default setting for it should be OFF, I think. Why create trouble by being cutting edge with ipv6 on by default when it causes so many problems in small and irritating ways? Consider a new user trying to deal with this and feeling frustrated and winding up using some other software that will surf the web without issues...

    enough complaints. I am still unable to get the X31 to fully surf with wifi but it is OK with a LAN cable. Thanks for the method to call up the old version of yast. I was actually wanting an explicit command for a root command line to kill ipv6, not call up yast. I already knew how to do that but I guess my question wasn't as clear as possible. It would be great if one instance of killing ipv6 or any other multi location setting in KDE would kill every instance of the setting being changed. (Locking screen saver when coming out of hibernation or sleep setting is in two different places, for example, and you have to kill both settings to avoid it.)

    Oh, off topic but relevant to me: what happened to the RED CURSOR in the mouse settings? I used it in the past for root log in use to constantly remind me visually that I was using root log in for maintenance. Could someone put it back? I also miss the old bombs and exclamation point background page when logged in as root.

    I am still not sure what to do to get the X31 surfing with 13.1 and wifi.

    KDE 4.11.2
    X31
    Linux 3.11.6-4
    32 bit 13.1 (i586)


    cheers

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: how to kill ipv6 from root command line?

    zxr250cc wrote:
    >
    > I have to confess I can't understand your instructions for modifying
    > Firefox settings to disable ipv6.
    >


    In the address bar of Firefox type about:config and then press "Enter" key
    In the "search" window type ipv6
    Right click on the ipv6 setting that comes up click on "toggle" to
    change it to to true.
    Restart Firefox and check whether internet works

    --
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    Where are my penguins :- https://features.opensuse.org/316767

  6. #6
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    502

    Default Re: how to kill ipv6 from root command line?

    Quote Originally Posted by zxr250cc View Post
    T23 ThinkPad
    A word of warning about your T23: do not put 13.1 on it until this bug is fixed: https://bugzilla.novell.com/show_bug.cgi?id=857141.

    My T23 worked OK with 12.3 once the S3 SuperSavage graphics got sorted out. This was supposed to be fixed in 13.1, but I cannot get any graphic log-in, only text-based. Since 13.1 is Evergreen, I was hoping this might be the last upgrade to the old hardware. I'll see what develops on the bug. May go back to 12.3

    Regards,
    Howard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •