Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

  1. #1

    Default on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    on my samsung rv520 with fresh install opensuse 13.1 with kde
    at startup sound don't works, if I go to >yast2>sound found 2 cards 0=intel corporation 1=nvidia corporation
    if I select 0 and test it works
    if I select 1, click on delete, click ok, click on edit and choose quick automatic setup, click ok, click ok again so yast perform setup, now sound works, if I reboot sound doesn't works again.

    how can I have a permanent working sound????
    manythanks, :-) ciao :-) pier

  2. #2

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    added some infos as pointed here
    Code:
    /usr/sbin/alsa-info.sh
    is provided here:
    http://www.alsa-project.org/db/?f=5a...df63ec7b6059f8

    then:
    rpm -qa '*alsa*'
    Code:
    procuste@linux-p7qg:~> rpm -qa '*alsa*'
    libdrumstick-alsa0-0.5.0-4.1.x86_64
    alsa-oss-32bit-1.0.25-8.1.2.x86_64
    alsa-utils-1.0.27.2-4.2.1.x86_64                                                                                                                                                                
    alsa-oss-1.0.25-8.1.2.x86_64                                                                                                                                                                    
    alsa-plugins-1.0.27-3.1.1.x86_64                                                                                                                                                                
    alsa-plugins-pulse-32bit-1.0.27-3.1.1.x86_64                                                                                                                                                    
    alsa-devel-1.0.27.2-3.5.1.x86_64                                                                                                                                                                
    alsa-1.0.27.2-3.5.1.x86_64                                                                                                                                                                      
    alsa-plugins-pulse-1.0.27-3.1.1.x86_64
    alsa-plugins-32bit-1.0.27-3.1.1.x86_64
    procuste@linux-p7qg:~>
    rpm -qa '*pulse*'
    Code:
    procuste@linux-p7qg:~> rpm -qa '*pulse*'
    libpulse0-32bit-4.0.git.270.g9490a-4.1.x86_64
    libxine2-pulse-1.2.3-89.2.x86_64
    alsa-plugins-pulse-32bit-1.0.27-3.1.1.x86_64
    libpulse-mainloop-glib0-4.0.git.270.g9490a-4.1.x86_64
    pulseaudio-4.0.git.270.g9490a-1.1.x86_64
    mpg123-pulse-32bit-1.16.0-1.1.x86_64
    libpulse0-4.0.git.270.g9490a-4.1.x86_64
    alsa-plugins-pulse-1.0.27-3.1.1.x86_64
    mpg123-pulse-1.16.0-1.1.x86_64
    procuste@linux-p7qg:~>
    rpm -q libasound2
    Code:
    procuste@linux-p7qg:~> rpm -q libasound2
    libasound2-1.0.27.2-3.5.1.x86_64
    procuste@linux-p7qg:~>
    uname -a
    Code:
    procuste@linux-p7qg:~> uname -a
    Linux linux-p7qg.site 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux
    procuste@linux-p7qg:~>
    cat /etc/modprobe.d/50-sound.conf
    Code:
    procuste@linux-p7qg:~> cat /etc/modprobe.d/50-sound.conf
    
    options snd slots=snd-hda-intel,snd-hda-intel
    # u1Nb.Mfbr4UrBan1:Intel Corporation
    alias snd-card-0 snd-hda-intel
    # NXNs.b2XYI_6FFP6:nVidia Corporation
    alias snd-card-1 snd-hda-intel
    procuste@linux-p7qg:~>

  3. #3

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    After the procedure in the first post, during the sound was working and sounding a song perfectly, I performed a
    Code:
    /usr/sbin/alsa-info.sh
    you can see here
    http://www.alsa-project.org/db/?f=a1...19cb7182243731
    maybe this can be useful to see differences between this file with working-sound and the one in the second post not-working-sound

    manythanx :-) ciao :-) pier

  4. #4

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    i also think that there's big problem with sound on OpenSUSE 13.1
    the first time i installed OpenSUSE 13.1, everything is ok, but after upgrading anything, sound is just went wrong, no sound on speaker any more.
    i still do not know how to fix this
    Sometimes I forget to tell information about version, desktop.
    I'm using OpenSUSE 13.1, KDE 4.11

  5. #5

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    Your pulseaudio is not running
    Can you try to install pavucontrol and see if it will work.

    The nvidia soundcard you have is for your HDMI
    If you are not using hdmi make sure that the intel card is your default soundcard.
    People who do not break things first will never learn to create anything

  6. #6

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    hi, manythanx,
    Quote Originally Posted by conram View Post
    Your pulseaudio is not running
    starting from the condition where sound works, I reboot and sound doesn't works.
    I don't know when pulseaudio is running or not, could you tell me how to know this??
    but, if sound works when pulseaudio is not running, could you tell me how to get rid of running pulseaudio so to have a permanent working sound???
    Quote Originally Posted by conram View Post
    Can you try to install pavucontrol and see if it will work.
    I installed pavucontrol and pulseaudio manager, if I run clementine to sound a song and run pavucontrol, in the playback tab I can see clementine sound working (the cursor indicator moves like the song) but I haven' sound from the speakers, in output devices tab I have only the nvidia soundcard and also it seems to works but no sound from speakers
    Quote Originally Posted by conram View Post
    The nvidia soundcard you have is for your HDMI
    If you are not using hdmi make sure that the intel card is your default soundcard.
    in yast2>sound the intel is the default sound card, but in pavucontrol doesn't appear anywhere

    manythanx, :-) ciao :-) pier

  7. #7

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    Quote Originally Posted by pier_andreit View Post
    but, if sound works when pulseaudio is not running, could you tell me how to get rid of running pulseaudio so to have a permanent working sound???
    Disable it in YaST->Hardware->Sound->Other->PulseAudio Configuration.

  8. #8

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    Quote Originally Posted by wolfi323 View Post
    Disable it in YaST->Hardware->Sound->Other->PulseAudio Configuration.
    I disabled it, but at reboot sound doesn't works, clementine gives me this error: failed to connect: connection refused
    and it is an endless error repeated 1 time per second or less.
    To have a working sound I have to Yast>sound>click-on-intel-card>edit>reset-all>click-on-yes-to-reset-all-values>next>click-on-yes-to-restart-sound-system-now>OK
    I noted that after this Kmix disappear from the system tray
    now sound works, but at the reboot doesn't works again.
    I suspect that the who does the trick is the restart sound system, and not the card reset... :-) :-) :-) maybe, perhaps, could be...
    to try this, how can I perform a sound system restart only??? without all the yast procedure?? from konsole??
    manythnx, :-) ciao :-) pier

  9. #9

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    Quote Originally Posted by pier_andreit View Post
    I noted that after this Kmix disappear from the system tray
    That's normal. If you restart the sound system that way, all applications using it currently will be killed.

    I suspect that the who does the trick is the restart sound system, and not the card reset... :-) :-) :-) maybe, perhaps, could be...
    to try this, how can I perform a sound system restart only??? without all the yast procedure?? from konsole??
    Code:
    sudo /usr/sbin/rcalsasound restart
    That said, what does this say when sound is not working?
    Code:
    /usr/sbin/rcalsasound status
    Maybe some program is started on boot/login that grabs the soundcard and blocks access to it for other apps (including pulseaudio)?
    By doing your card reset, that program would be killed as well, so that would explain why your sound is working afterwards.

    Did you try with a new user already? That would at least tell if it's a system-wide issue, or just something specific to your user configuration.

  10. #10

    Default Re: on 13.1 kde samsung rv520 sound works only if I delete and reinstall sound card

    CODE]sudo /usr/sbin/rcalsasound restart[/CODE]
    rcalsasound restart gives this results:
    Code:
    linux-p7qg:/home/procuste # /usr/sbin/rcalsasound restart
    redirecting to systemctl restart alsasound
    linux-p7qg:/home/procuste #
    kmix doesn't disappear from system tray

    sound doesn't works


    performed yast procedure answering NOT restart sound system now
    Yast>sound>click-on-intel-card>edit>reset-all>click-on-yes-to-reset-all-values>next>click-on-NOT-to-restart-sound-system-now>OK
    sound works
    kmix disappear from system tray

    it seems that my suspect was wrong and the trick is to reset sound card,
    or maybe when I klick on OK and yast-sound-window disappear yast perform a sound system restart....

    That said, what does this say when sound is not working?
    Code:
    /usr/sbin/rcalsasound status
    Maybe some program is started on boot/login that grabs the soundcard and blocks access to it for other apps (including pulseaudio)?
    By doing your card reset, that program would be killed as well, so that would explain why your sound is working afterwards.

    Did you try with a new user already? That would at least tell if it's a system-wide issue, or just something specific to your user configuration.
    rcalsasound status when sound doesn't works

    Code:
    procuste@linux-p7qg:~> /usr/sbin/rcalsasound status
    ALSA sound driver loaded.                                                                                                                                                            running
    alsa-restore.service - Restore Sound Card State
       Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
       Active: inactive (dead) since Fri 2013-12-06 16:31:03 CET; 29min ago
      Process: 725 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
     Main PID: 725 (code=exited, status=0/SUCCESS)
    
    procuste@linux-p7qg:~>
    rcalsasound status when sound works

    Code:
    procuste@linux-p7qg:~> /usr/sbin/rcalsasound status
    ALSA sound driver loaded.                                                                                                                                                            running
    alsa-restore.service - Restore Sound Card State
       Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
       Active: inactive (dead) since Fri 2013-12-06 17:03:11 CET; 4min 58s ago
      Process: 2578 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
     Main PID: 2578 (code=exited, status=0/SUCCESS)
    
    procuste@linux-p7qg:~>
    with new-fresh-just-created user sound doesn't works and clementine gives me the error: failed to connect: connection refused

    manythanx, :-) ciao :-) pier

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •