Results 1 to 8 of 8

Thread: Установка более старых версий ПО

  1. #1

    Default Установка более старых версий ПО

    Подскажите, смогу ли я установив последнюю версию OpenSuse 13.1 и использовать к примеру NetworkManager 0.8 (в 0.9 не работает Bluetooth PAN в связке с Blueman). Я так понимаю, нужно подключить репо от предыдущего релиза?
    Такой же вопрос относительно Gnome 2

  2. #2
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    679

    Default Re: Установка более старых версий ПО

    Ну вы же понимаете, что старые версии собраны со старыми библиотеками. Попытка их установить погрузит в dependency hell. Если же повыдергивать бинарники из пакета, подсунуть таким же способом добытые библиотеки и умудриться запустить, то может что-то и получится, но я очень сомневаюсь.

  3. #3
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: Установка более старых версий ПО

    Можно попробовать локально собрать в 13.1, но это будет тот еще цирк. Gnome 2 -> Mate, по этому поводу я и возмущаюсь в последнее время))

  4. #4

    Default Re: Установка более старых версий ПО

    Quote Originally Posted by kill_it View Post
    Ну вы же понимаете, что старые версии собраны со старыми библиотеками. Попытка их установить погрузит в dependency hell. Если же повыдергивать бинарники из пакета, подсунуть таким же способом добытые библиотеки и умудриться запустить, то может что-то и получится, но я очень сомневаюсь.
    Ну Б-г с ним, с гномом, таки да, есть мэйт и он вполне себе не плох... Ну вот к примеру NetworkManager 0.8 или Remmina - это даже более актуально...

  5. #5
    Join Date
    Aug 2009
    Location
    Санкт-Петербург
    Posts
    1,037

    Default Re: Установка более старых версий ПО

    Quote Originally Posted by winhex View Post
    Подскажите, смогу ли я установив последнюю версию OpenSuse 13.1 и использовать к примеру NetworkManager 0.8 (в 0.9 не работает Bluetooth PAN в связке с Blueman). Я так понимаю, нужно подключить репо от предыдущего релиза?
    Такой же вопрос относительно Gnome 2
    Пакет от предыдущего релиза с большой вероятностью что-то нибудь поломает, ибо это системный софт, а не дополнительная программа на версию которой ничего в системе не завязано. Но попробовать то можно.
    Более правильно собрать нужную вам версию самому для 13.1, но возможно придется менять что-то в других пакетах, которые могут быть уже настроены на использование именно новой версии.
    Поэтому самый правильный путь это разобраться и починить "(в 0.9 не работает Bluetooth PAN в связке с Blueman)" для новой версии.
    ⇩ Здесь можно сказать "Спасибо!". P.S. Спасибо можно говорить не только мне, но и другим пользователям.

  6. #6

    Default Re: Установка более старых версий ПО

    Quote Originally Posted by Gankov View Post
    Пакет от предыдущего релиза с большой вероятностью что-то нибудь поломает, ибо это системный софт, а не дополнительная программа на версию которой ничего в системе не завязано. Но попробовать то можно.
    Более правильно собрать нужную вам версию самому для 13.1, но возможно придется менять что-то в других пакетах, которые могут быть уже настроены на использование именно новой версии.
    Поэтому самый правильный путь это разобраться и починить "(в 0.9 не работает Bluetooth PAN в связке с Blueman)" для новой версии.
    Короче, Dependency hell не избежать в любом бинарном дистре.... Нет в мире совершенства.... Думал в сусе с этим как-то проще... Тут же умудряются как-то третьи кеды использовать....
    А разобраться и починить не выйдет, т.к. проблемы в апстриме. Разработчики Blueman не реализовали поддержку BT PAN для NM 0.9 - штатный плагин только для 0.8 Тоже касается и другого софта. К примеру в Remmina выше 0.8.3 уже год как сломана работа плагина RDP...

  7. #7
    Join Date
    Aug 2009
    Location
    Санкт-Петербург
    Posts
    1,037

    Default Re: Установка более старых версий ПО

    Quote Originally Posted by winhex View Post
    К примеру в Remmina выше 0.8.3 уже год как сломана работа плагина RDP...
    Да сам удивляюсь авторам, почему исправления всякие не зарелизят, действительно последний релиз вышел больше года, назад, уже куча проблем в коде исправлена. А релиза нет. Дистры вынуждены патчами править и далеко не всегда удачно.
    А RDP работает, пользуюсь каждый день, вот только проблемы есть не исправленные: с буфером обмена и прокруткой в vnc.
    ⇩ Здесь можно сказать "Спасибо!". P.S. Спасибо можно говорить не только мне, но и другим пользователям.

  8. #8
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,050
    Blog Entries
    1

    Default Re: =?UTF-8?B?0KPRgdGC0LDQvdC+0LLQutCwINCx0L7Qu9C10LUg0YHRgtCw?==?UTF-8?B?0YDRi9GFINCy0LXRgNGB0LjQuSDQn9Ce?=

    winhex wrote:

    > Короче, Dependency hell не избежать в любом
    > бинарном дистре.... Нет в мире
    > совершенства..... Думал в сусе с этим
    > как-то проще...


    Да нет никакого "Dependency hell".
    Просто, solver не позволит вам поставить неподходящую версию
    библиотеки, если форсировать не будете.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •