Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 13.1: upsd.service missing in Yast Services Manager

  1. #1

    Default 13.1: upsd.service missing in Yast Services Manager

    13.1 replaces the previous Yast system runlevel management with a
    new systemd services management.

    In 12.2, the NUT package (UPS management) placed upsd in the runlevel
    table and made it possible to activate upsd for automatic running at system start.

    But in 13.1 this is missing. When nut is installed, there is no upsd in Yast =>
    System => Services Manager. It looks as if some systemd engineering is missing.

    How does one specify automatic start for upsd?

    Roger

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Unfortunately it seems upsd doesn't have systemd compatible sections / proper service file.

    However, you should still be able to use (as root):
    chkconfig upsd on

    chkconfig --list

    should then show something like:
    Code:
    upsd                      0:off  1:off  2:off  3:on   4:off  5:on   6:off
    rcupsd start
    to fire it up the service.
    .: miuku @ #opensuse @ irc.libera.chat

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,349
    Blog Entries
    15

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    On Mon 02 Dec 2013 11:36:01 PM CST, xiaoti wrote:


    13.1 replaces the previous Yast system runlevel management with a
    new systemd services management.

    In 12.2, the NUT package (UPS management) placed upsd in the runlevel
    table and made it possible to activate upsd for automatic running at
    system start.

    But in 13.1 this is missing. When nut is installed, there is no upsd in
    Yast =>
    System => Services Manager. It looks as if some systemd engineering is
    missing.

    How does one specify automatic start for upsd?

    Roger


    Hi
    By the looks a service file doesn't exist for it....
    https://build.opensuse.org/package/v....SUSE?expand=1

    What happens when you run the start script?
    Code:
    /etc/init.d/upsd start
    /etc/init.d/upsd status
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.101-0.8-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by malcolmlewis View Post
    What happens when you run the start script?
    Hi, The manual start runs correctly:
    Code:
    pinta:~ # rcupsd start
    redirecting to systemctl start upsd
    pinta:~ # ps aux | grep ups
    upsd      4338  0.0  0.0  19848  1104 ?        Ss   Dec02   0:00 /usr/sbin/upsd -u upsd
    upsd      6137  0.0  0.0  13232   644 ?        Ss   09:35   0:00 /usr/lib/ups/driver/usbhid-ups -a Eaton-66781
    root      6142  0.0  0.0  19388   652 ?        Ss   09:35   0:00 /usr/sbin/upsmon
    upsd      6143  0.0  0.0  19812   812 ?        S    09:35   0:00 /usr/sbin/upsmon
    pinta:~ # rcupsd status
    Checking for service NUT UPS server                                                                                             running
    Checking for service NUT UPS monitor                                                                                            running
    upsd.service - LSB: UPS monitoring software (remote/local)
       Loaded: loaded (/etc/init.d/upsd)
       Active: active (running) since Tue 2013-12-03 09:35:16 CET; 39s ago
      Process: 6116 ExecStart=/etc/init.d/upsd start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/upsd.service
               ├─6137 /usr/lib/ups/driver/usbhid-ups -a Eaton-66781
               ├─6142 /usr/sbin/upsmon
               └─6143 /usr/sbin/upsmon
    
    Dec 03 09:35:16 pinta usbhid-ups[6137]: Startup successful
    Dec 03 09:35:16 pinta upsd[6116]: Starting NUT UPS drivers ..done
    Dec 03 09:35:16 pinta upsd[6116]: Starting NUT UPS server ..done
    Dec 03 09:35:16 pinta upsmon[6142]: Startup successful
    Dec 03 09:35:16 pinta upsd[6116]: Starting NUT UPS monitor ..done
    Dec 03 09:35:16 pinta systemd[1]: Started LSB: UPS monitoring software (remote/local).
    Roger

  5. #5

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by Miuku View Post
    However, you should still be able to use (as root):
    chkconfig upsd on
    chkconfig --list
    Here is what happens:
    Code:
    pinta:~ # chkconfig upsd on
    pinta:~ # chkconfig --list | grep ups
    Note: This output shows SysV services only and does not include native
    systemd services. SysV configuration data might be overridden by native
    systemd configuration.
    
    upsd                      0:off  1:off  2:off  3:on   4:off  5:on   6:off
    ... rcupsd start to fire it up the service.
    This is an unattended server. When power comes back on there is no-one to type a
    command. Perhaps a Bash script linked to /usr/lib/systemd/system/multi-user.target.wants
    could do the job, but I am a systemd novice and I hesitate to hack into the systemd setup.

    Roger

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    You misunderstood me - the "rc" command was to merely start it up for the first time if you hadn't started it up yet.

    As you can see from the chkconfig --list, it has been enabled for levels 3 and 5, meaning it's going to automatically startup at the next system reboot (without GUI the default init level is 3, with GUI it's 5).
    .: miuku @ #opensuse @ irc.libera.chat

  7. #7

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by Miuku View Post
    As you can see from the chkconfig --list, it has been enabled for levels 3 and 5,
    meaning it's going to automatically startup at the next system reboot
    Sorry, I misunderstood. I restarted the box, and I see that upsd has
    been automatically started.

    It looks as if command chkconfig upsd on followed by chkconfig --list | grep upsd
    as a check is a complete workaround for the missing entry in the Yast Services Manager.

    Thanks, Roger

  8. #8

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by xiaoti View Post
    It looks as if command chkconfig upsd on followed by chkconfig --list | grep upsd
    as a check is a complete workaround for the missing entry in the Yast Services Manager.
    You can also use:
    Code:
    systemctl enable upsd.service
    And it should be shown in YaST's Services Manager.

    But the version shipped with 13.1 had a bug in that it did not show sysvinit scripts (from /etc/init.d/).
    This has been fixed already though. Have you installed all online updates?

    Edit:
    I just installed "nut" as a test, and the service is really not shown in YaST's Services Manager as well here.
    Seems to be another bug...

  9. #9

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by wolfi323 View Post
    I just installed "nut" as a test, and the service is really not shown in YaST's Services Manager as well here.
    Seems to be another bug...
    No, there is _no_ bug!
    upsd shows up fine in YaST's Services Manager here.

    But you have to configure it first (in /etc/ups/upsd.conf). Otherwise /etc/init.d/upsd only gives an error:
    Code:
    /etc/ups/ups.conf not configured, see /usr/share/doc/packages/nut/README.SUSE
    And that's the reason why YaST doesn't show it, I think.

  10. #10

    Default Re: 13.1: upsd.service missing in Yast Services Manager

    Quote Originally Posted by wolfi323 View Post
    But you have to configure it first (in /etc/ups/upsd.conf).
    This should have been /etc/ups/ups.conf of course.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •