Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 13.1: Grafikfehler

  1. #1

    Default 13.1: Grafikfehler

    Hallo,

    ich hab eine nVidia GeForce GTX560 in meinem Rechner. Nach dem Upgrade von 12.2 auf 13.1 habe ich jetzt links und rechts ca. 3,5 cm sowie oben und unten ca. 2 cm breite schwarze Balken und Kreise sind elliptisch. YaST erzählt mir, dass folgendes installiert ist:

    libdrm_nouveau2
    xf86-video-nv
    xorg-x11-driver-video-nouveau
    nvidia-computeG02
    nvidia-gfxG02-kmp-desktop
    x11-video-nvidiaG02

    Die letzten 3 haben unter Installiert (Verfügbar) einen roten Zahleneintrag.

    In der Newsgroup alt.linux.suse (oder war's de.com.os.unix.linux.misc?) ist mir gesagt worden, es gäbe noch kein Repository für die 13.1, es solle aber am 27.11. erscheinen. Heute ist der 2.12. und kein nVidia-Repository in Sicht. Kommt das Repository später oder handelt es sich hier um eine Fehlinformation?

    Gibt es ansonsten eine Anfänger-konforme Möglichkeit, die Grafik in Ordnung zu bringen?

    MfG

    Surfaround

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,725

    Default AW: 13.1: Grafikfehler

    Quote Originally Posted by Surfaround View Post
    Hallo,

    ich hab eine nVidia GeForce GTX560 in meinem Rechner. Nach dem Upgrade von 12.2 auf 13.1 habe ich jetzt links und rechts ca. 3,5 cm sowie oben und unten ca. 2 cm breite schwarze Balken und Kreise sind elliptisch. YaST erzählt mir, dass folgendes installiert ist:

    libdrm_nouveau2
    xf86-video-nv
    xorg-x11-driver-video-nouveau
    nvidia-computeG02
    nvidia-gfxG02-kmp-desktop
    x11-video-nvidiaG02

    Die letzten 3 haben unter Installiert (Verfügbar) einen roten Zahleneintrag.

    In der Newsgroup alt.linux.suse (oder war's de.com.os.unix.linux.misc?) ist mir gesagt worden, es gäbe noch kein Repository für die 13.1, es solle aber am 27.11. erscheinen. Heute ist der 2.12. und kein nVidia-Repository in Sicht. Kommt das Repository später oder handelt es sich hier um eine Fehlinformation?

    Gibt es ansonsten eine Anfänger-konforme Möglichkeit, die Grafik in Ordnung zu bringen?

    MfG

    Surfaround
    Wo hast Du denn die 3 NvidiaPakete her bzw. warum die G02 Variante?

    Das Repo wird schon erscheinen, mach Dir keine Sorgen.

    Ansonsten bleib wohl nur die Deinstallation der obigen Nvidia-Pakete und Installation der Treiber auf die harte Art.
    Funktioniert hier sehr gut.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: 13.1: Grafikfehler

    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: AW: 13.1: Grafikfehler

    Quote Originally Posted by Sauerland View Post
    Wo hast Du denn die 3 NvidiaPakete her bzw. warum die G02 Variante? Das Repo wird schon erscheinen, mach Dir keine Sorgen. Ansonsten bleib wohl nur die Deinstallation der obigen Nvidia-Pakete und Installation der Treiber auf die harte Art. Funktioniert hier sehr gut.
    Als ich noch die 12.2 drauf hatte, waren G03-Treiber drauf und nix von kmp, sondern Desktop. Also müssen diese Pakete wohl beim Upgrade auf die 13.1 drauf gekommen sein. Wenn ich diese deinstalliere, muss ich aber sicherlich im Gegenzug andere installieren, weil Linux sonst nur noch im Textmodus läuft, oder?

    Was ist eine Installation der Treiber auf die harte Art? Solange probieren, bis es klappt?

  5. #5

    Default Re: 13.1: Grafikfehler

    Quote Originally Posted by Knurpht View Post
    Ich habe mir den Artikel durchgelesen. Als Anfänger frage ich mich, ob dieses Prozedere mir nicht zu kompliziert ist. Das geht ja schon damit los, dass ich mich frage, wie man ein solches heruntergeladenes Paket installiert. Welche der Optionen sollte ich verwenden und welche nicht?

  6. #6

    Default Re: 13.1: Grafikfehler

    Quote Originally Posted by Surfaround View Post
    Als ich noch die 12.2 drauf hatte, waren G03-Treiber drauf und nix von kmp, sondern Desktop.
    Wenn du den nvidia Treiber aus dem Repo installiert hattest, musst du auch das entsprechende kmp installiert gehabt haben (vermutlich nvidia-gfxG03-kmp-desktop), weil der Treiber ohne nicht funktioniert.

    Also müssen diese Pakete wohl beim Upgrade auf die 13.1 drauf gekommen sein. Wenn ich diese deinstalliere, muss ich aber sicherlich im Gegenzug andere installieren, weil Linux sonst nur noch im Textmodus läuft, oder?
    Nein.
    Linux (oder besser X) nimmt automatisch einen anderen Treiber, vorausgesetzt du hast keine /etc/X11/xorg.conf.
    Der G02 Treiber, den du installiert hast, funktioniert aber sowieso nicht mit 13.1's kernel, also welchen Kernel verwendest du jetzt überhaupt?
    Code:
    uname -a
    Die G02 Pakete, die du jetzt installiert hast, kommen wahrscheinlich aus dem nvidia repo für 12.3. Hast du das vor dem Upgrade nicht entfernt?
    Entweder du verwendest jetzt sowieso nicht den nvidia Treiber, oder du läufst immer noch mit dem Kernel von 12.3.

    Was ist eine Installation der Treiber auf die harte Art? Solange probieren, bis es klappt?
    Nein, das ist Download und Installation des Treiber als .run Datei von der nvidia Homepage.
    http://de.opensuse.org/SDB:NVIDIA-Treiber-Modulebau

    Das nvidia Repo sollte jetzt aber wirklich bald auch für 13.1 vorhanden sein, die Pakete wurden schon am Freitag erstellt...

  7. #7

    Default Re: 13.1: Grafikfehler

    Quote Originally Posted by Surfaround View Post
    Ich habe mir den Artikel durchgelesen. Als Anfänger frage ich mich, ob dieses Prozedere mir nicht zu kompliziert ist. Das geht ja schon damit los, dass ich mich frage, wie man ein solches heruntergeladenes Paket installiert. Welche der Optionen sollte ich verwenden und welche nicht?
    Einfach auf den 1-click Install für 13.1 in dem Artikel klicken:
    http://software.opensuse.org/ymp/hom...kms-nvidia.ymp

    Oder du wartest noch ein bisschen und installierst so wie immer aus dem offiziellen nvidia Repo.

  8. #8

    Default Re: 13.1: Grafikfehler

    [QUOTE=wolfi323;2604784]Wenn du den nvidia Treiber aus dem Repo installiert hattest, musst du auch das entsprechende kmp installiert gehabt haben (vermutlich nvidia-gfxG03-kmp-desktop), weil der Treiber ohne nicht funktioniert.


    Nein.
    Linux (oder besser X) nimmt automatisch einen anderen Treiber, vorausgesetzt du hast keine /etc/X11/xorg.conf.
    Der G02 Treiber, den du installiert hast, funktioniert aber sowieso nicht mit 13.1's kernel, also welchen Kernel verwendest du jetzt überhaupt?
    Code:
    uname -a
    Ich habe die 3 fraglichen Pakete deinstalliert. Jetzt kommt der Desktop ohne schwarze Ränder oben, unten, rechts und links, allerdings wenn in dem Bild in der Bildschirmmitte unscharf die Festplatte erscheint, bleibt der Rechner stehen.

    Darf ich jetzt die 13.1 drüberinstallieren oder sollte ich jetzt vielleicht sogar die root-Partition löschen und eine komplette Neuinstallation vornehmen? Oder gibt es eine andere Lösung?

    Quote Originally Posted by wolfi323 View Post
    Die G02 Pakete, die du jetzt installiert hast, kommen wahrscheinlich aus dem nvidia repo für 12.3. Hast du das vor dem Upgrade nicht entfernt?
    Nein. Ich wusste nicht, dass man das tun sollte.

    Quote Originally Posted by wolfi323 View Post
    Das nvidia Repo sollte jetzt aber wirklich bald auch für 13.1 vorhanden sein, die Pakete wurden schon am Freitag erstellt...

  9. #9

    Default Re: 13.1: Grafikfehler

    Quote Originally Posted by wolfi323 View Post
    Einfach auf den 1-click Install für 13.1 in dem Artikel klicken:
    http://software.opensuse.org/ymp/hom...kms-nvidia.ymp

    Oder du wartest noch ein bisschen und installierst so wie immer aus dem offiziellen nvidia Repo.
    Ich hätte wohl besser den 1-Click-Install probiert, bevor ich die 3 G02-Pakete deinstalliert habe (denn jetzt hängt der Rechner, noch bevor KDE komplett geladen ist). Allerdings habe ich den Artikel so verstanden, dass diese Installationsmethode nicht funktioniert, wenn noch Grafiktreiber (Nouveau) vorhanden sind.

  10. #10

    Default Re: 13.1: Grafikfehler

    Quote Originally Posted by Surfaround View Post
    Ich hätte wohl besser den 1-Click-Install probiert, bevor ich die 3 G02-Pakete deinstalliert habe (denn jetzt hängt der Rechner, noch bevor KDE komplett geladen ist).
    Probier "Wiederherstellungsmodus" im Bootmenü unter "Erweiterte Einstellungen" auszuwählen.

    Kommt überhaupt ein grafischer Bildschirn, oder landest du im Textmodus?

    Allerdings habe ich den Artikel so verstanden, dass diese Installationsmethode nicht funktioniert, wenn noch Grafiktreiber (Nouveau) vorhanden sind.
    Nein. Den nouveau Treiber brauchst du nicht zu deinstallieren.
    Aber du musst alle vorherigen nvidia-Treiber-Installationen entfernen.

    Quote Originally Posted by Surfaround View Post
    Darf ich jetzt die 13.1 drüberinstallieren oder sollte ich jetzt vielleicht sogar die root-Partition löschen und eine komplette Neuinstallation vornehmen?
    Ja, darfst du.
    Aber ich dachte du hast bereits auf 13.1 aktualisiert?

    Probier doch einfach mal den nvidia Treiber mit dem 1-click Install zu installieren.

    Falls der Wiederherstellungsmodus genauso hängt, drücke einfach 2x Ctrl+Alt+Backspace um zum Anmeldebildschirm zu kommen, und wähle dort eine andere Desktopumgebung aus (auf das Schraubenziehersymbol am unteren Bildschirmrand klicken)

    Nein. Ich wusste nicht, dass man das tun sollte.
    In jeder Upgrade-Anleitung steht dabei, dass man alle Softwarequellen für die alte Version vorher entfernen sollte.
    Sonst kann es Probleme mit dem Upgrade geben.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •