Results 1 to 5 of 5

Thread: fonts screwed up in browsers (FF, Midory, Chromium)

  1. #1

    Default fonts screwed up in browsers (FF, Midory, Chromium)

    Hello! I've been using Ubuntu-based distros (mostly Xubuntu) for several years on my main PC at home (regular stuff like Inet/music/accounting/etc., plus some light s/w development). Have been trying to switch for a couple of years, given Canonical's mobile priorities and ugly/unusable Unity, but nothing was comparable to Ubuntu's hardware support. Tested OpenSuSE for a week (with KDE) - seemed solid and stable, but with one issue: often fonts are screwed up in Firefox (and other browsers), e.g. Gmail in FF on Windows & Ubuntu looks OK, but in OpenSuse some text is rendered in too small a font. I installed ms fonts (msttcorefonts), did not help. Webkit browsers (Midori, Chromium) have same issues. Same in Konqueror.

    As I spend most of my time online, having no properly working browser is deal breaker - I'll probably switch to Mint now (have to install a new OS soon, given non-rolling nature of Ubuntu), unless there is an easy fix. Is there? Why this is not taken care of - web rendering seems to be a kind of essential these days...

  2. #2
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: fonts screwed up in browsers (FF, Midory, Chromium)

    Quote Originally Posted by antrek View Post
    Hello! I've been using Ubuntu-based distros (mostly Xubuntu) for several years on my main PC at home (regular stuff like Inet/music/accounting/etc., plus some light s/w development). Have been trying to switch for a couple of years, given Canonical's mobile priorities and ugly/unusable Unity, but nothing was comparable to Ubuntu's hardware support. Tested OpenSuSE for a week (with KDE) - seemed solid and stable, but with one issue: often fonts are screwed up in Firefox (and other browsers), e.g. Gmail in FF on Windows & Ubuntu looks OK, but in OpenSuse some text is rendered in too small a font. I installed ms fonts (msttcorefonts), did not help. Webkit browsers (Midori, Chromium) have same issues. Same in Konqueror. As I spend most of my time online, having no properly working browser is deal breaker - I'll probably switch to Mint now (have to install a new OS soon, given non-rolling nature of Ubuntu), unless there is an easy fix. Is there? Why this is not taken care of - web rendering seems to be a kind of essential these days...
    As an uneducated "expert" I can only guess but I think it might be your font rendering settings. First of all in the KDE settings, make sure the fonts are set to what you want. If they are, then mess around with the font rendering options it provides. If it still does not fix it then you might want to consider trying infinality font patch. To use it, open up YaST and install the infinality patch from the repos. However this alone is not enough for 13.1 (in my experience anyways). You will also have to add this repository using YaST http://download.opensuse.org/reposit...:subpixel.repo (replace 13.1 with the version you are using) and then in yast search up libfreetype6, click the versions tab and select to install version 2.4 for your architecture. The reason for this long process is because 13.1 provides v2.5 of libfreetype but infinality is unable to use it (from what I have read). So you end up having to jump through this hoop to get nice font rendering in openSUSE. Once this is done I believe you will have to log out and then log back in to get it to work. Hopefully this fixes it but again I am no linux guru and am just posting what I would do if this happened to me.

  3. #3

    Default Re: fonts screwed up in browsers (FF, Midory, Chromium)

    Quote Originally Posted by alanbortu View Post
    As an uneducated "expert" I can only guess but I think it might be your font rendering settings. First of all in the KDE settings, make sure the fonts are set to what you want. If they are, then mess around with the font rendering options it provides. If it still does not fix it then you might want to consider trying infinality font patch. To use it, open up YaST and install the infinality patch from the repos. However this alone is not enough for 13.1 (in my experience anyways). You will also have to add this repository using YaST http://download.opensuse.org/reposit...:subpixel.repo (replace 13.1 with the version you are using) and then in yast search up libfreetype6, click the versions tab and select to install version 2.4 for your architecture. The reason for this long process is because 13.1 provides v2.5 of libfreetype but infinality is unable to use it (from what I have read). So you end up having to jump through this hoop to get nice font rendering in openSUSE. Once this is done I believe you will have to log out and then log back in to get it to work. Hopefully this fixes it but again I am no linux guru and am just posting what I would do if this happened to me.
    FF rendering was bad "out of the box", and my playing with KDE font settings, and FF font settings did not help. Is it really necessary to enable a third party repository to fix this? I'm using 13.1.

  4. #4
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: fonts screwed up in browsers (FF, Midory, Chromium)

    Quote Originally Posted by antrek View Post
    FF rendering was bad "out of the box", and my playing with KDE font settings, and FF font settings did not help. Is it really necessary to enable a third party repository to fix this? I'm using 13.1.
    To fix that? I dunno, your issue might just be something to do with some messed up settings or it could be something deeper. However to get Ubuntu like font rendering you have to use a similar patch or do it yourself manually. I'd just wait for some of the smart posters to show up . You could also try the IRC, you might be able to get some immediate help! Oh and maybe uploading a screenshot would help just so people can see what exact parts are looking strange.

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: fonts screwed up in browsers (FF, Midory, Chromium)

    Quote Originally Posted by antrek View Post
    Hello! I've been using Ubuntu-based distros (mostly Xubuntu) for several years on my main PC at home (regular stuff like Inet/music/accounting/etc., plus some light s/w development). Have been trying to switch for a couple of years, given Canonical's mobile priorities and ugly/unusable Unity, but nothing was comparable to Ubuntu's hardware support. Tested OpenSuSE for a week (with KDE) - seemed solid and stable, but with one issue: often fonts are screwed up in Firefox (and other browsers), e.g. Gmail in FF on Windows & Ubuntu looks OK, but in OpenSuse some text is rendered in too small a font. I installed ms fonts (msttcorefonts), did not help. Webkit browsers (Midori, Chromium) have same issues. Same in Konqueror.

    As I spend most of my time online, having no properly working browser is deal breaker - I'll probably switch to Mint now (have to install a new OS soon, given non-rolling nature of Ubuntu), unless there is an easy fix. Is there? Why this is not taken care of - web rendering seems to be a kind of essential these days...
    My fonts out of the box were great (with a couple of minor tweaks)

    this is my font settings

    SUSE Paste

    I have anti-aliasing set to Full but some people prefer slight. Just try out and see what you like.

    In openSUSE 13.1 I'm not sure but in earlier releases installing msttcorefonts messed up font rendering a little.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •